Оптимизация разработки. Шаблоны

0. 750 21.11.21 17:34 Сейчас в теме
При разработке мы часто сталкиваемся с тем, что приходится писать однотипный код, либо вызывать процедуры и функции названия (или путь), которых мы точно не помним (привет БСП). Для того, чтобы облегчить жизнь разработчика, вполне уместно использовать шаблоны текста.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. olololeg 23.11.21 15:25 Сейчас в теме
Не боитесь ли вы, что с течением времени, шаблонов будет такое кол-во, что потом поиск нужного превратиться в поиск по БСП?) А так довольно идея хорошая.
IgorS; Rustig; +2 Ответить
2. Rustig 1382 23.11.21 15:36 Сейчас в теме
(0) интересная разработка....
вы озвучили проблему - не помним какой метод БСП и по какому пути искать....
хорошее предложили решение....

но есть проблема, что нет поиска по вашим шаблонам - об этом я писал давным давно вот тут https://infostart.ru/public/89310/

это было на обычных формах....
сейчас для управляемых форм я реализовал вот что https://infostart.ru/public/1444273/

некоторые испытывают проблемы дальнейшего наполнения шаблонов, проблемы поиска среди тысячи алгоритмов, проблемы доступа к файлу шаблонов....

рано или поздно все столкнутся с какой-либо проблемой этих шаблонов....
примечательно то, что лучше поиска в интернете пока что ничего не придумали
3. AnryMc 829 23.11.21 17:39 Сейчас в теме
(2)
что лучше поиска в интернете пока что ничего не придумали
9. mrChOP93 56 24.11.21 10:50 Сейчас в теме
(2)
примечательно то, что лучше поиска в интернете пока что ничего не придумали

Мне для поиска по БСП очень помогает турбопоиск в TurboConf (не реклама)
Прикрепленные файлы:
10. Rustig 1382 24.11.21 11:41 Сейчас в теме
4. AnryMc 829 23.11.21 17:45 Сейчас в теме
То же вёл свой шаблон.
"Дёргал" в него разный код...

Потом перестал понимать где искать...
И бросил его вести...

З.Ы. Главный недостаток (ИМХО) отсутствие категорий (ключевых слов)....
5. МимохожийОднако 140 23.11.21 17:58 Сейчас в теме
Не важно какие и в каком количестве ведёт шаблоны разработчик.
Сократить объем всего этого добра позволяет только ПОНИМАНИЕ поведения объектов,их свойств и методов.
Многие умеют копипастить и вести свои библиотеки наработанных кодов, но только реальные профессионалы понимают, что это в определенный момент становится не нужным )
Знакомство, знание, умение, навык, понимание...Вот такая цепочка
6. muskul 24.11.21 03:56 Сейчас в теме
Есть целых 11 %вставить нужное% нужно объединить их и сделать едиными и однообразными. Появилось 12 %вставить нужное%
pavlov_dv; +1 Ответить
7. quazare 1580 24.11.21 08:05 Сейчас в теме
шаблоны имеют свойство быстро устаревать, товарищи
8. Yashazz 4143 24.11.21 10:34 Сейчас в теме
Допиливание шаблона "по месту" быстро становится менее выгодным, чем хлопоты с шаблоном как таковым. Ну и портируется хуже.

Скорее уж разумно делать малые универсалы, процедуры-функции, и их таскать с места на место копипастом, и тюнинговать параметрами.

А что до публикации, так это должно было быть во встроенной справке платформы, и жаль, что нету.
Ekovichev; +1 Ответить
11. zqzq 23 24.11.21 15:44 Сейчас в теме
Пользуюсь шаблонами Чистова. Удобно для рутинных/частых/типовых операций, типа набрать "Если" и шаблон сам подставит обёртку "Если Тогда КонецЕсли;". Там только встроенный язык, поэтому не устаревает и объём небольшой.
12. Rustig 1382 24.11.21 16:04 Сейчас в теме
(11)
Если Тогда КонецЕсли;"

не велика выгода

иногда часами думаешь как механизм запилить, а вы тут
(11)
Если Тогда КонецЕсли
13. Rustig 1382 24.11.21 16:05 Сейчас в теме
(11)я к тому , что выигрыш от этих шаблонов, тогда, когда сложный алгоритм копипастим - чтобы с нуля его не писать....
15. zqzq 23 25.11.21 10:51 Сейчас в теме
(13) Так выше и писали, что шаблоны не для этого, и я согласен. Храню несколько кусков запросов (вроде генерации всех дней в периоде) в Образцах программы CLCL. А шаблоны платформы как раз для мелочи нужны, типа начал набирать, а шаблон дополнил конструкцию.
16. Rustig 1382 25.11.21 11:51 Сейчас в теме
(15) я , к большому сожалению 1с и всем кто причастен к стандартным шаблонам, ими не пользуюсь....
я часы трачу чтобы изучить их код, придумать обход (решение для клиента), их шаблоны - это копейки
14. CheBurator 3379 24.11.21 23:57 Сейчас в теме
на ИС
https://infostart.ru/public/199364/
.
есть еще на ИС библиотека шаблонов в облаке, с интеграцией в конфигуратор (вроде)
17. Дмитрий74Чел 209 25.11.21 17:35 Сейчас в теме
18. Rustig 1382 27.11.21 13:37 Сейчас в теме
(17) после просмотра я изменил свое отношение к шаблонам.

для тех, кто забыл, как вызвать в конфигураторе Шаблоны: ctrl+shift+T
19. Rustig 1382 27.11.21 14:25 Сейчас в теме
(0)
типовой шаблон, предоставляемый в поставке платформы. Типовой шаблон недоступен для редактирования


Копируете файл шаблона в свою папку, подключаете в меню шаблонов и редактируете... все возможно...
Прикрепленные файлы:
21. Ekovichev 750 29.11.21 14:17 Сейчас в теме
(19)
недоступен для редактирования


Что и описано во второй части публикации
23. Rustig 1382 29.11.21 14:39 Сейчас в теме
(21) да, я потом внимательно прочитал
20. triviumfan 28 29.11.21 10:31 Сейчас в теме
Откуда столько плюсов? Неужели шаблоны первый раз увидели...
22. Ekovichev 750 29.11.21 14:19 Сейчас в теме
(20) Использование шаблонов не освещается широко. Пользуются ими единицы и даже, если и знали об этой возможности, то со временем забывают. Вероятно, для кого-то публикация полезна.
24. Rustig 1382 29.11.21 14:41 Сейчас в теме
(22) меня ваша публикация сподвигла пересмотреть алгоритм парсера шаблонов.
все не зря...
25. Rustig 1382 29.11.21 16:26 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Тестировщик 1С
Санкт-Петербург
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Программист 1С
Харьков
зарплата от 135 000 руб. до 180 000 руб.
Полный день

Архитектор НСИ
Москва
зарплата от 250 000 руб. до 300 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
зарплата от 180 000 руб. до 220 000 руб.
Полный день