Непонятная кодировка при чтении кириллицы

1. Yamat2004 17.11.21 22:48 Сейчас в теме
Здравствуйте, столкнулся с проблемой, при чтении текстового файла
Прикрепленные файлы:
По теме из базы знаний
Найденные решения
11. ls600 22.11.21 08:57 Сейчас в теме
(10)
текст.Прочитать(файл.ПолноеИмя);

Нужно прописать кодировку.
 текст.Прочитать(файл.ПолноеИмя,КодировкаТекста.UTF8); //тут мы читаем наш файл
Yureckaya; Yamat2004; +2 Ответить
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. Yamat2004 17.11.21 23:25 Сейчас в теме
Всё, поменял кодировку с UTF-8 на ANSI все нормально читает ,но не понял почему
4. Yamat2004 18.11.21 09:39 Сейчас в теме
(3)Спасибо, понял хотя бы что такое кодировка) но все таки почему, когда я указываю универсальную кодировку UTF-8 он читает кракозябры?
5. Pixar0000 18.11.21 11:02 Сейчас в теме
потому что виндовый Notepad пытается подобрать кодировку, поставьте Notepad++ и будет вам счастье
6. Yamat2004 18.11.21 11:13 Сейчас в теме
(5)То есть поменять его в редакторе реестре?
7. ls600 18.11.21 12:45 Сейчас в теме
(6) в реестр лезть не нужно.
для счастья нужно установить программу Notepad++, забыть что такое блокнот)))
Sashares; +1 Ответить
8. Yamat2004 19.11.21 11:55 Сейчас в теме
(7)Немного не догоняю, начал юзать notepad++ но что то тоже самое при сохранении в UTF-8)) кракозябры
9. ls600 19.11.21 13:01 Сейчас в теме
Закинь обработку сюда, посмотрим.
10. Yamat2004 19.11.21 15:24 Сейчас в теме
(9)
&НаКлиенте
Процедура ИмяКаталагоОткрытие(Элемент, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь; //отключаем страндартную отработку, то есть предупреждение
	
	//С помощью этого мы можем задать каталог с данными, собственно открыть его и т.п.
	Диалог = Новый ДиалогВыбораФайла (РежимДиалогаВыбораФайла.ВыборКаталога);
	
	Если Диалог.Выбрать() Тогда
		ИмяКаталага = Диалог.Каталог;	
	КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьДанныеИзФайлов(Команда)
	Текст = Новый ТекстовыйДокумент; //Создаем временный файл
	
	СтрокаВнешнихДанных = ""; //Очищаем строку внешних данных
	
	МассивФайлов = НайтиФайлы(ИмяКаталага, "*.txt", ложь); //ищем в выбранном каталоге
											//все файлы с расширением txt
											//Функция НайтиФайлы() возвращает массив
											
	Для каждого файл Из Массивфайлов Цикл
	
		текст.Прочитать(файл.ПолноеИмя); //тут мы читаем наш файл
		
		СтрокаВнешнихДанных = СтрокаВнешнихДанных + Текст.ПолучитьТекст();   //заполняем наше поле
	КонецЦикла;
КонецПроцедуры
Показать
11. ls600 22.11.21 08:57 Сейчас в теме
(10)
текст.Прочитать(файл.ПолноеИмя);

Нужно прописать кодировку.
 текст.Прочитать(файл.ПолноеИмя,КодировкаТекста.UTF8); //тут мы читаем наш файл
Yureckaya; Yamat2004; +2 Ответить
12. Yamat2004 22.11.21 09:14 Сейчас в теме
(11)
текст.Прочитать(файл.ПолноеИмя,КодировкаТекста.UTF8); //тут мы читаем наш файл
Большое спасибо!) всё теперь читается нормально)
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот