Повторяются области в макете

1. 13.10.21 14:17 Сейчас в теме
Здравствуйте, коллеги. Такая ситуация, повторяется область ОбластьДок в макете. Подскажите, пожалуйста, как сделать проверку чтоб не было еще строк с одним и тем же документом.

Документ.НачатьАвтогруппировкуСтрок();
	
        ОбластьДок = Макет.ПолучитьОбласть("СтрокаДокумент");
	ОбластьСтрока =  Макет.ПолучитьОбласть("Строка");
        ОбластьПодСтрокой = Макет.ПолучитьОбласть("ПодСтрокой");
	
	Пока Выборка.Следующий() Цикл

	    ОбластьДок .Параметры.Заполнить(Выборка);
		Документ.Вывести(ОбластьДок ,1);/////////////////////////Повторяется эта область
		
		Для Каждого Строка Из Выборка.ДокСсылка.ТоварыЦикл
		
		ОбластьСтрока .Параметры.Номенклатура= Строка.Наименование;
		ОбластьСтрока .Параметры.Колво= Строка.Количество;
		
		Документ.Вывести(ОбластьСтрока ,2);
		
		КонецЦикла;
		
		Для Каждого Стр из   ВыборкаДетальныеЗаписи.Спецификация.ПриходМатериалов Цикл
			
			ОбластьПодСтрокой .Параметры.Материал = Стр.Наименование;	
			ОбластьПодСтрокой .Параметры.Сумма= Стр.Количество * Выборка.Цена;	
			Документ.Вывести(ОбластьПодСтрокой ,3);
		КонецЦикла;
Показать
Найденные решения
4. DBV 13.10.21 14:55 Сейчас в теме
(3) Изменить запрос, добавить итоги и выборку делать по группировкам
Или запрос оставить, но обход делать методом СледующийПоЗначениюПоля(<ИмяПоля>)
Или добавить проверку на документ, если в запросе отсортировано по документу
user1619761; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. provadyuga 97 13.10.21 14:35 Сейчас в теме
Может
ОбластьДок .Параметры.Заполнить(Выборка);
Документ.Вывести(ОбластьДок ,1);/////////////////////////Повторяется эта область
поставить перед циклом
Пока Выборка.Следующий() Цикл
3. user1619761 13.10.21 14:48 Сейчас в теме
(2) Спасибо, я пробовал такое:

 Если выборка.Следующий() тогда 

ОбластьДок .Параметры.Заполнить(Выборка);
Документ.Вывести(ОбластьДок ,1);

КонецЕсли;

Пока Выборка.Следующий() Цикл
Показать

Но в этом случае только первый документ в макет попадает, а мне нужен обход циклом всех документов за определенный период )
4. DBV 13.10.21 14:55 Сейчас в теме
(3) Изменить запрос, добавить итоги и выборку делать по группировкам
Или запрос оставить, но обход делать методом СледующийПоЗначениюПоля(<ИмяПоля>)
Или добавить проверку на документ, если в запросе отсортировано по документу
user1619761; +1 Ответить
6. user1619761 13.10.21 15:24 Сейчас в теме
5. puzo50 13.10.21 15:18 Сейчас в теме
(3)
или после конецесли написать выборка.сбросить()
user1619761; +1 Ответить
7. user1619761 13.10.21 15:25 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Ведущий разработчик 1С
Москва
зарплата от 250 000 руб.
Полный день

Руководитель проектов 1С
Москва
зарплата от 200 000 руб.
Полный день

Консультант-аналитик 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день

Аналитик 1С ERP
Санкт-Петербург
зарплата до 200 000 руб.
Полный день