Где можно просмотреть запрос, по которому формируется типовой отчет

1. 12.10.21 18:53 Сейчас в теме
Нужно переделать отчет продажи, (Отчет строиться на основе универсального отчета) сделал из его копии внешний отчет и не могу найти запрос, по которому он формируется, формы обычные
Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
	УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент);
КонецПроцедуры 

Процедура ОбработкаРасшифровки(Расшифровка, Объект) Экспорт
	ДополнительныеПараметры = Неопределено;
	УниверсальныйОтчет.ОбработкаРасшифровкиУниверсальногоОтчета(Расшифровка, Объект, ДополнительныеПараметры);	
КонецПроцедуры // ОбработкаРасшифровки()

Процедура СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками) Экспорт	
	УниверсальныйОтчет.СформироватьСтруктуруДляСохраненияНастроек(СтруктураСНастройками);	
КонецПроцедуры // СформироватьСтруктуруДляСохраненияНастроек()


Функция ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками) Экспорт	
	Возврат УниверсальныйОтчет.ВосстановитьНастройкиИзСтруктуры(СтруктураСНастройками, ЭтотОбъект);	
КонецФункции // ВосстановитьНастройкиИзСтруктуры()
Показать


сверху представил, все что было в модуле, кроме функции установки настроек, или может я не туда смотрю?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
6. ZergKRSK 128 13.10.21 11:19 Сейчас в теме
(1)
сверху представил, все что было в модуле

еще должно быть
Процедура УстановитьНачальныеНастройки
7. I_train 13.10.21 11:23 Сейчас в теме
(6) она была, но я ее не включил, там нет даже намека на запрос, по которому отчет формируется
8. ZergKRSK 128 13.10.21 11:38 Сейчас в теме
(7) там или намек на запрос или намек на Регистр. Другого не дано.
2. provadyuga 97 12.10.21 19:12 Сейчас в теме
Макеты->ОсновнаяСхемаКомпоновкиДанных - там нету разве запроса?
3. I_train 12.10.21 19:47 Сейчас в теме
(2) и там тоже нет
Прикрепленные файлы:
4. Dr.HiHi 3 12.10.21 19:58 Сейчас в теме
в отчете УниверсальныйОтчет
5. Dr.HiHi 3 12.10.21 20:00 Сейчас в теме
посмотрите любой отчет формируемы на основании универсального... в модуле указывается или регистр, или текст запроса... ищите там где формируется на основании текста запроса и от туда скопируйте шаблон ;))
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день

Ведущий разработчик 1С
Москва
зарплата от 250 000 руб.
Полный день

Руководитель проектов 1С
Москва
зарплата от 200 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб.
Полный день