Нужна помощь в нахождении ошибки!

1. 19.09.21 12:38 Сейчас в теме
&НаКлиенте
Процедура ИзменениеЦены(Команда)

Перем ВводимоеЧисло;
ОбратныйВызов = Новый ОписаниеОповещения("ОбратныйВызов", ЭтотОбъект);
ПоказатьВводЧисла(ОбратныйВызов, ВводимоеЧисло, "Введите Число", 15, 5);
Строка = Элементы.Товары.ТекущиеДанные;
Сумма = Строка.СуммаСНДС;
Сумма = Сумма + ВводимоеЧисло;


КонецПроцедуры

&НаКлиенте
Процедура ОбратныйВызов(ВводимоеЧисло, ДопПар) Экспорт

Если ВводимоеЧисло = Неопределено Тогда
Сообщить("Ничего не введено!");
Иначе
Сообщить(ВводимоеЧисло);
КонецЕсли;

КонецПроцедуры


Была поставлена задача создать команду, которая запрашивает у пользователя число и изменяет сумму на введенное число. Проблема в том, что при отладке возникает ошибка, что преобразования к типу число невозможно, хотя значение в колонке таблицы- число
Найденные решения
2. spacecraft 19.09.21 12:55 Сейчас в теме
(1)
Проблема в том, что при отладке возникает ошибка, что преобразования к типу число невозможно, хотя значение в колонке таблицы- число

Конечно невозможно преобразовать Неопределено к числу.

Как вариант:
&НаКлиенте
Процедура ИзменениеЦены(Команда)
  ОбратныйВызов = Новый ОписаниеОповещения("ОбратныйВызов", ЭтотОбъект);
  ПоказатьВводЧисла(ОбратныйВызов, 0, "Введите Число", 15, 5);
КонецПроцедуры

&НаКлиенте
Процедура ОбратныйВызов(ВводимоеЧисло, ДопПар) Экспорт
  Если НЕ ВводимоеЧисло = Неопределено Тогда
    Строка = Элементы.Товары.ТекущиеДанные;
    Строка.СуммаСНДС = Строка.СуммаСНДС + ВводимоеЧисло;
  КонецЕсли;
КонецПроцедуры
Показать
Pishka622; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. spacecraft 19.09.21 12:55 Сейчас в теме
(1)
Проблема в том, что при отладке возникает ошибка, что преобразования к типу число невозможно, хотя значение в колонке таблицы- число

Конечно невозможно преобразовать Неопределено к числу.

Как вариант:
&НаКлиенте
Процедура ИзменениеЦены(Команда)
  ОбратныйВызов = Новый ОписаниеОповещения("ОбратныйВызов", ЭтотОбъект);
  ПоказатьВводЧисла(ОбратныйВызов, 0, "Введите Число", 15, 5);
КонецПроцедуры

&НаКлиенте
Процедура ОбратныйВызов(ВводимоеЧисло, ДопПар) Экспорт
  Если НЕ ВводимоеЧисло = Неопределено Тогда
    Строка = Элементы.Товары.ТекущиеДанные;
    Строка.СуммаСНДС = Строка.СуммаСНДС + ВводимоеЧисло;
  КонецЕсли;
КонецПроцедуры
Показать
Pishka622; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Руководитель проектов 1С
Москва
зарплата от 200 000 руб.
Полный день

Консультант-аналитик 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день

Аналитик 1С ERP
Санкт-Петербург
зарплата до 200 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 100 000 руб.
Полный день