СКД выбор варианта отчета

1. 15.09.21 08:35 Сейчас в теме
Не управляемая форма СКД. В командной панеле в кнопке "Ещё"-"Прочее"-"Выбрать вариант отчета". Вот как разные варианты поместить на разные кнопки ? И как обратиться к варианту и вывести его?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. user5300 709 15.09.21 08:49 Сейчас в теме
(1)
одна кнопка. пользователь сам выбирает вариант

Процедура ДействияФормыВыбратьВариант(Кнопка)
	
	макет = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
        спВарианты = Новый СписокЗначений;
        Для каждого вариант из макет.ВариантыНастроек Цикл
               спВарианты.Добавить(вариант.Настройки, вариант.Представление);
        КонецЦикла;
        выбор = спВарианты.ВыбратьЭлемент();
        Если выбор = Неопределено Тогда
               Возврат;       
        КонецЕсли;       
        КомпоновщикНастроек.ЗагрузитьНастройки(выбор.Значение);
	
КонецПроцедуры

Показать
orlin553; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 100 000 руб.
Полный день

Программист 1С: ЗУП
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Разработчик 1C: ERP (Блоки: Снабжение, закупки, склад; Финансы и казначейство)
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день