Получение записей регистра сведений на изменение.

1. 10.09.21 20:48 Сейчас в теме
1С:Комплексная автоматизация 2 (2.4.13.227)

Коллеги, помогите разобраться с вот такой ситуацией.
из расширения в модуль объекта Поступление ДС в процедуру &После("ОбработкаПроведения")
Процедура Расш_ПослеОбработкаПроведения ()

Добавлен код по поиску и изменению записей в регистре сведений "Состояния Заказов Покупателя":

Набор = РегистрыСведений.СостоянияЗаказовКлиентов.СоздатьНаборЗаписей();
			Набор.Отбор.Заказ.Установить(Заказ);
			
			Набор.Прочитать();
			Если Набор.Количество() > 0 Тогда
				Для каждого Запись из Набор ЦИкл
					//ПолучилиСтарыеДанные
					СтарыйПроцентОплаты = Запись.ПроцентОплаты;
					СтарыйПроцентОтгрузки = Запись.ПроцентОтгрузки;
					// ЗаписалиНовые
					Запись.ДатаСобытия = ЭтотОбъект.Дата;
					Запись.Заказ = Заказ;
					Запись.Активность = Истина;
					Запись.ПроцентОплаты = ПроцентОплаты;
					Запись.СуммаОплаты   = СуммаОплаты;
				КонецЦикла;
			Иначе
				Запись = Набор.Добавить();
				Запись.ДатаСобытия = ЭтотОбъект.Дата;
				Запись.Заказ = Заказ;
				Запись.Активность = Истина;
				Запись.ПроцентОплаты = ПроцентОплаты;
				Запись.СуммаОплаты   = СуммаОплаты;
			КонецЕсли;
			
			Набор.Записать(Истина);
Показать



и по сути такой же кусок добавлен в в ту же процедуру в документ "Реализация товаров и услуг"


Набор = РегистрыСведений.СостоянияЗаказовКлиентов.СоздатьНаборЗаписей();
			Набор.Отбор.Заказ.Установить(Заказ);
			
					
			Набор.Прочитать();
			Если Набор.Количество() > 0 Тогда
				Для каждого Запись из Набор ЦИкл
					Запись.ДатаСобытия = ЭтотОбъект.Дата;
					Запись.Заказ = Заказ;
					Запись.Активность = Истина;
					Запись.ПроцентОтгрузки = ПроцентОтгрузкиТовара;
					Запись.СуммаОтгрузки  = СуммаОтгрузки;
				КонецЦикла;
			Иначе
				Запись = Набор.Добавить();
				Запись.ДатаСобытия = ЭтотОбъект.Дата;
				Запись.Заказ = Заказ;
				Запись.Активность = Истина;
				Запись.ПроцентОтгрузки = ПроцентОтгрузкиТовара;
				Запись.СуммаОтгрузки  = СуммаОтгрузки;
			КонецЕсли;
			
			Набор.Записать(Истина);
Показать



Но при этом когда получаем записи из модуля документа Поступления ДС то все ранее внесенные данные сохраняются. все реквизиты заполнены.

Когда мы получаем данные из модуля реализация то найденный записи все пустые , все реквизиты пустые.
Что я делаю не так?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. FatPanzer 14 11.09.21 13:33 Сейчас в теме
(1)
Что я делаю не так?
Заказ не того типа значения.
3. kimNeo 13.09.21 14:04 Сейчас в теме
(2)Заказ покупателя может быть не того типа ?
4. FatPanzer 14 13.09.21 14:26 Сейчас в теме
(3) Конечно. Он может быть равен Неопределено, например.
А может быть и просто нет записей по этому заказу в регистре.
5. kimNeo 13.09.21 16:37 Сейчас в теме
(4).

Нет. В данном случае как отбор фигурирует один и тот же заказ. он 100% найден верно. а вот дальше с записями что то странное происходит.
6. kimNeo 14.09.21 16:20 Сейчас в теме
неужели ни кто не сталкивался с подобным ?
7. FatPanzer 14 14.09.21 16:24 Сейчас в теме
(6) Да никто в сказки не верит просто.
8. kimNeo 14.09.21 17:04 Сейчас в теме
(7)ну от чего же сказки то ? реальная ситуация. могу по тим подключить показать. разница только в том что один код выполняется в расширении процедуры обработкипроведения документа реализация, а другой в поступлении ДС.
10. FatPanzer 14 14.09.21 17:10 Сейчас в теме
(8) Здесь аргумент "мамой клянусь" не прокатывает.
11. kimNeo 14.09.21 19:41 Сейчас в теме
12. FatPanzer 14 14.09.21 20:02 Сейчас в теме
(11) 2500/ч, номер карты дать? Велком, чо.
13. kimNeo 14.09.21 21:25 Сейчас в теме
(12)Ай молодца, не решишь за час с тебя 5000 руб. номер карты дать ?
9. kimNeo 14.09.21 17:05 Сейчас в теме
поменяю их местами посмотрю результат.
14. kimNeo 15.09.21 10:09 Сейчас в теме
Вопрос решен, спасибо всем сочувствующим. И вопрос был совершенно не в том что рекомендовал предыдущий оратор!
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Новосибирск
зарплата от 90 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 230 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 100 000 руб. до 140 000 руб.
Полный день

Программист 1С
Хабаровск
зарплата от 130 000 руб. до 160 000 руб.
Полный день