Нужна выгрузка/загрузка через XML с отбором через запрос

1. 14 10.06.21 18:27 Сейчас в теме
Мне коллега сваял правило конвертации для документов ОперацияБух для штатной выгрузки/загрузки через XML.

Существует ли возможность подсунуть ей результат запроса для нужных доков ОперацияБух ???
Прикрепленные файлы:
Найденные решения
10. kasper076 77 10.06.21 18:55 Сейчас в теме
(9)
Пока Выборка.Следущий() Цикл
    ВыгрузитьПоПравилу(Выборка.Ссылка, , , , "Документ.ВидДокумента");
КонецЦикла;
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. kasper076 77 10.06.21 18:35 Сейчас в теме
Можно удалить регистрацию всех объектов нужного типа и зарегистрировать только те, которые попадут в выборку запроса. После этого выполнить выгрузку стандартным способом.
Либо можно допилить правило выгрузки объектов.
3. makfromkz 14 10.06.21 18:37 Сейчас в теме
(2) у меня не обмен, а банальная выгрузка/загрузка доков с правилами сделанными в КД20
5. kasper076 77 10.06.21 18:40 Сейчас в теме
(3) Так файл правил же используется. Если выполняется выгрузка только зарегистрированных объектов, то химичить с регистрацией. Если по ПВД, то правило подправить.
4. makfromkz 14 10.06.21 18:39 Сейчас в теме
(2) т.е. я из архивной базы выгружаю ОперацияБух в рабочую
6. makfromkz 14 10.06.21 18:44 Сейчас в теме
(5) нет у меня регистрации, задается только период выгрузки
7. kasper076 77 10.06.21 18:46 Сейчас в теме
(6) Значит выгружаются данные полученные в ПВД. Доработать ПВД и будет счастье.
9. makfromkz 14 10.06.21 18:48 Сейчас в теме
(7) В чем заключается доработка ПВД ?
Я например создал запрос, возвращающий список нужных для выгрузки доков.
10. kasper076 77 10.06.21 18:55 Сейчас в теме
(9)
Пока Выборка.Следущий() Цикл
    ВыгрузитьПоПравилу(Выборка.Ссылка, , , , "Документ.ВидДокумента");
КонецЦикла;
11. makfromkz 14 10.06.21 19:16 Сейчас в теме
12. makfromkz 14 10.06.21 19:28 Сейчас в теме
(10) Эти строки вставляют в какой-то обработчик событий, типо ПередВыгрузкой()?
13. kasper076 77 10.06.21 19:29 Сейчас в теме
Да.
И "Способ выборки" выставить "Произвольный алгоритм"
14. makfromkz 14 10.06.21 19:31 Сейчас в теме
Спасибо!
Постараюсь отписаться о результате :)
15. makfromkz 14 13.06.21 08:25 Сейчас в теме
Первые сто блинов - комом)))
Прикрепленные файлы:
16. makfromkz 14 13.06.21 09:12 Сейчас в теме
оказывается не объявил переменную Запрос
17. makfromkz 14 13.06.21 09:33 Сейчас в теме
исправил все ошибки синтаксиса и добрался до:


Начало выгрузки: 13.06.2021 12:23:32

Окончание выгрузки: 13.06.2021 12:25:50

Выгружено объектов: 0
Выгрузка данных завершена.
18. makfromkz 14 13.06.21 13:03 Сейчас в теме
в обработчике ПередВыгрузкой написал:

Пока Выборка.Следущий() Цикл
	Сообщить("проверка");
    ВыгрузитьПоПравилу(Выборка.Регистратор, , , , "Документ.ОперацияБух");
КонецЦикла;


при выгрузке Универсалка задумалась, ничего не выгрузила.
И вывода Сообщить() не было :(
19. makfromkz 14 13.06.21 13:57 Сейчас в теме
Перенес в обработчик ПередОбработкой, появилось сообщение:

Ошибка при выгрузке данных: {Обработка.УниверсальныйОбменДаннымиXML.МодульОбъекта(3230)}: Ошибка в обработчике события ПередОбработкойПравилаВыгрузки
ПВД = ОперацияБух
Обработчик = ПередОбработкойВыгрузкиДанных
ОписаниеОшибки = Метод объекта не обнаружен (Следущий)
ПозицияМодуля = (60)
КодСообщения = 31
Прикрепленные файлы:
20. makfromkz 14 13.06.21 14:01 Сейчас в теме
21. makfromkz 14 13.06.21 14:28 Сейчас в теме
как обычно - невнимательность:
ОписаниеОшибки = Метод объекта не обнаружен (Следущий)
22. makfromkz 14 13.06.21 16:57 Сейчас в теме
в общем, у меня таки получилось.
Всем спасибо за советы!!!
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Программист 1С
Москва
зарплата от 170 000 руб.
Полный день

Архитектор 1С
Москва
зарплата от 200 000 руб.
Полный день

Программист 1С (Казань)
Казань
зарплата до 130 000 руб.
Полный день

Программист 1С (Новосибирск)
Новосибирск
зарплата до 130 000 руб.
Полный день