Обычные формы. Для чего у процедуры действия кнопки в скобках (кнопка)?

1. 104 03.05.21 18:19 Сейчас в теме
На обычной форме есть кнопка. У неё есть действие.
Иногда мне нужно вызывать это действие не только этой кнопкой, а из другой процедуры.
Вопрос. Для чего нужна эта заморочка с кнопкой?
Вот так не работает:
Процедура Тест1()
	КоманднаяПанельОстаткиРазвернуть(неопределено);
КонецПроцедуры

Процедура КоманднаяПанельОстаткиРазвернуть(Кнопка)	
	// Код процедуры...
КонецПроцедуры

А вот так работает:
Процедура Тест1()
	КоманднаяПанельОстаткиРазвернуть(ЭлементыФормы.КоманднаяПанельОстатки.Кнопки.Развернуть); // Из-за вот этой городьбы у меня и возник вопрос
КонецПроцедуры

Процедура КоманднаяПанельОстаткиРазвернуть(Кнопка)	
	// Код процедуры...
КонецПроцедуры
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Torin 365 03.05.21 18:45 Сейчас в теме
(1)
Развернуть
:)

Процедура Тест1()
    КоманднаяПанельОстаткиРазвернуть("Развернуть");
КонецПроцедуры

Процедура КоманднаяПанельОстаткиРазвернуть(Кнопка)    
    // Код процедуры...
КонецПроцедуры
4. Fox-trot 127 03.05.21 20:29 Сейчас в теме
(1)
Процедура КоманднаяПанельОстаткиРазвернуть(Кнопка)

обычно вот так пишу
Процедура КоманднаяПанельОстаткиРазвернуть(Кнопка=Неопределено) 
3. DNN13 34 03.05.21 19:34 Сейчас в теме
(1) можно вообще вот так:
КоманднаяПанельОстаткиРазвернуть("");

А кнопка нужна, потому что один обработчик может быть привязан к нескольким кнопкам и тогда через кнопку можно узнать на какую кнопку нажали
Aleksandr55555; FatPanzer; Sungang; Fox-trot; +4 Ответить
5. resonance 04.05.21 00:15 Сейчас в теме
Определение обработчика кнопки, что бы отличить вызов обычного метода, от нажатия кнопки.
Оставьте свое сообщение
Вопросы с вознаграждением