При удалении элемента удаляется элемент в другом массиве

1. 02.05.21 12:13 Сейчас в теме
В момент удаления элемента в МассивВСД2 элемент также удаляется из МассивВСД
		сч = 0;
		МассивВСД2 = МассивВСД;
		Для каждого ВСД Из МассивВСД Цикл
		
			Для  каждого ВТО Из МассивВТО Цикл
			
				Если ВСД = ВТО Тогда
				
					МассивВСД2.Удалить(сч);
					
				КонецЕсли;
			
			КонецЦикла;
			
			сч = сч + 1;
			
		КонецЦикла;
Показать
Найденные решения
2. DNN13 34 02.05.21 12:21 Сейчас в теме
Потому что обе переменные ссылаются на один массив
nomad_irk; Xershi; FilimonVl; VKuser148011742; lefthander; +5 Ответить
3. Global__IT 13 02.05.21 16:08 Сейчас в теме
Что бы один массив перекачать в другой, то через цикл.
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. DNN13 34 02.05.21 12:21 Сейчас в теме
Потому что обе переменные ссылаются на один массив
nomad_irk; Xershi; FilimonVl; VKuser148011742; lefthander; +5 Ответить
3. Global__IT 13 02.05.21 16:08 Сейчас в теме
Что бы один массив перекачать в другой, то через цикл.
Оставьте свое сообщение
Вопросы с вознаграждением