Минимальный размер панели

1. 29.04.21 09:09 Сейчас в теме
Добрый день!
Есть форма, на ней есть панель со страницами, и существует привязка (При растяжении формы - панель растягивается, при сжатии - панель сжимается)
Нужно задать минимальный размер панели, чтоб когда панель при сжатии достигла минимума, дальше уже не сжималась, а включалась вертикальная полоса прокрутки для всей формы.
Помогите пожалуйста новичку
Вознаграждение за ответ
Показать полностью
Найденные решения
6. KVIKS 86 29.04.21 15:36 Сейчас в теме
На ум приходит такая конструкция
Процедура ПриОткрытии()
	ПодключитьОбработчикОжидания("Размер",1);
КонецПроцедуры

Процедура Размер()
	Если ЭлементыФормы.ТабличноеПоле1.Ширина<300 тогда 
		ЭлементыФормы.ТабличноеПоле1.Ширина=300;
	КонецЕсли;	
	Если ЭлементыФормы.ТабличноеПоле1.Высота<190 тогда 
		ЭлементыФормы.ТабличноеПоле1.Высота=190;
	КонецЕсли;	
КонецПроцедуры

Показать

Но работает это коряво на вид.
Либо привязки установить не жестко а Сохранять пропорции до - но тоже не решает всех проблем
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Kongo2019 29.04.21 09:56 Сейчас в теме
3. G_110913743683437366230 29.04.21 10:11 Сейчас в теме
4. Kongo2019 29.04.21 11:26 Сейчас в теме
(3)Смотри у меня такая фигня есть.

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

Этаформа.Высота=600;
Этаформа.Ширина=800;

КонецПроцедуры

Может у тебя по аналогии что-то?
5. G_110913743683437366230 29.04.21 11:45 Сейчас в теме
(4) Мне при динамическом изменении размера, когда пользователь мышью растягивает
6. KVIKS 86 29.04.21 15:36 Сейчас в теме
На ум приходит такая конструкция
Процедура ПриОткрытии()
	ПодключитьОбработчикОжидания("Размер",1);
КонецПроцедуры

Процедура Размер()
	Если ЭлементыФормы.ТабличноеПоле1.Ширина<300 тогда 
		ЭлементыФормы.ТабличноеПоле1.Ширина=300;
	КонецЕсли;	
	Если ЭлементыФормы.ТабличноеПоле1.Высота<190 тогда 
		ЭлементыФормы.ТабличноеПоле1.Высота=190;
	КонецЕсли;	
КонецПроцедуры

Показать

Но работает это коряво на вид.
Либо привязки установить не жестко а Сохранять пропорции до - но тоже не решает всех проблем
7. G_110913743683437366230 30.04.21 07:47 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Санкт-Петербург
зарплата от 110 000 руб.
Полный день

Программист 1С
Москва
зарплата от 180 000 руб.
Полный день

Программист 1С (Казань)
Казань
зарплата до 130 000 руб.
Полный день

Программист 1С (Новосибирск)
Новосибирск
зарплата до 130 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 180 000 руб.
Полный день