Поле объекта не обнаружено (ПериодДатыПриемки) в структуре 1С (ЕРП)

1. 14.01.21 11:30 Сейчас в теме
При загрузке формы списка вылетает ошибка
Поле объекта не обнаружено (ПериодДатыПриемки)



&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
	СохранитьНастройки();
КонецПроцедуры

&НаСервере
Процедура СохранитьНастройки()
	
	ИменаСохраняемыхРеквизитов =
		"Склад,
		|Контрагент,
		|Статус,
		|ПериодДатыПриемки";
	
	Настройки = Новый Структура(ИменаСохраняемыхРеквизитов);
	ЗаполнитьЗначенияСвойств(Настройки, ЭтаФорма);
	
	ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("Документ.СТ_РаспоряжениеНаПриемку.Форма.ФормаСписка", КлючНазначенияИспользования, Настройки);
	
КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройки(Параметры)
	
	Если Параметры.Свойство("СтруктураБыстрогоОтбора") Тогда
		СтруктураБыстрогоОтбора = Параметры.СтруктураБыстрогоОтбора;
		СтруктураБыстрогоОтбора.Свойство("Контрагент",Контрагент);
		СтруктураБыстрогоОтбора.Свойство("Склад",Склад);
		СтруктураБыстрогоОтбора.Свойство("Статус",Статус);
		СтруктураБыстрогоОтбора.Свойство("ПериодДатыПриемки", ПериодДатыПриемки);
	Иначе
		Настройки = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("Документ.СТ_РаспоряжениеНаПриемку.Форма.ФормаСписка", КлючНазначенияИспользования);
		
		Если ТипЗнч(Настройки) = Тип("Структура") Тогда
			Склад      = Настройки.Склад;
			Контрагент = Настройки.Контрагент;
			Статус     = Настройки.Статус;
			Если НЕ Настройки.ПериодДатыПриемки = Неопределено Тогда
				 ПериодДатыПриемки = Настройки.ПериодДатыПриемки;
			 Иначе
				 Возврат;
			КонецЕсли; 
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры

Показать


Также добавлял проверку свойства.
Найденные решения
4. user1304317 14.01.21 12:09 Сейчас в теме
(2) Правда? Отладчик?))) Я уже исправил ошибку, спасибо совет.
			Склад      = ?(Настройки.Свойство("Склад"), Настройки.Склад, Справочники.Склады.ПустаяСсылка());
			Контрагент = ?(Настройки.Свойство("Контрагент"), Настройки.Контрагент, Справочники.Контрагенты.ПустаяСсылка());
			Статус     = ?(Настройки.Свойство("Статус"), Настройки.Статус, "");
			ПериодДатыПриемки = ?(Настройки.Свойство("ПериодДатыПриемки"), Настройки.ПериодДатыПриемки, Дата(1, 1, 1));

Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. soft_wind 14.01.21 12:03 Сейчас в теме
а отладчик на что? запустите под ним!

а вообще похоже на ошибку здесь
СтруктураБыстрогоОтбора.Свойство("ПериодДатыПриемки", ПериодДатыПриемки);

видимо в форме нет такого реквизита: ПериодДатыПриемки
4. user1304317 14.01.21 12:09 Сейчас в теме
(2) Правда? Отладчик?))) Я уже исправил ошибку, спасибо совет.
			Склад      = ?(Настройки.Свойство("Склад"), Настройки.Склад, Справочники.Склады.ПустаяСсылка());
			Контрагент = ?(Настройки.Свойство("Контрагент"), Настройки.Контрагент, Справочники.Контрагенты.ПустаяСсылка());
			Статус     = ?(Настройки.Свойство("Статус"), Настройки.Статус, "");
			ПериодДатыПриемки = ?(Настройки.Свойство("ПериодДатыПриемки"), Настройки.ПериодДатыПриемки, Дата(1, 1, 1));

3. user633533_encantado 8 14.01.21 12:04 Сейчас в теме
"ПериодДатыПриемки" это реквизит формы ?
5. user1304317 14.01.21 12:09 Сейчас в теме
(3) Да. Ошибку уже исправил доп.проверкой.
6. soft_wind 14.01.21 12:56 Сейчас в теме
(5) Замечательно!!! Очень рады что смогли вам помочь!!!
(я правда не совсем про отладчик понял, наверно не дано 8+()
Оставьте свое сообщение
Вопросы с вознаграждением