Ошибка совместимости КА

1. 13.01.21 11:03 Сейчас в теме
Всем привет. Решили поюзать Комплексную Автоматизацию для Казахстана. Нужно было добавить расширение в документе. Для этого отключить совместимость.
Отключаю с 8.3.10 на "не использовать". Убираю совместимость интерфейса на Такси. При запуске в итоге имею следующий текст:
{ОбщийМодуль.СтандартныеПодсистемыСервер.Модуль(2486)}: Режим совместимости конфигурации с 1С:Предприятием версии 8.3.18 не поддерживается.
Для запуска установите в конфигурации режим совместимости "Не использовать" при разработке на версии 8.3.10
(или "Версия 8.3.10" при разработке на более старших версиях).
ВызватьИсключение СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(

Кто знает как побороть?

Платформа 8.3.18, КА для Казахстана 2.4.4.76
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
5. Swetlana 13 13.01.21 12:48 Сейчас в теме
Расширение можно использовать и на версии 8.3.10
8. vsesam80 13.01.21 14:00 Сейчас в теме
(5)Не реально. Всё равно что на 8.2 вернуться
2. stein13 3 13.01.21 11:16 Сейчас в теме
не стоит отключать совместимость, пусть стоит то, что предложено программой.
3. FatPanzer 9 13.01.21 11:16 Сейчас в теме
Ну так вам же все написали... Нельзя так просто взять и отключить совместимость - придется переписать очень много методов под новую платформ.
7. vsesam80 13.01.21 14:00 Сейчас в теме
(3)И че теперь расширения не юзать?!
9. FatPanzer 9 13.01.21 14:08 Сейчас в теме
(7) Вам решать. Можете воспользовать советом из (4), но во что вам это выльется в дальнейшем - никто не знает. Режим совместимости - он не просто так устанавливается, от него зависит то, синтаксис какой платформы понимает ваше решение, а какой не понимает.
Расширения может и заработают, а вот ошибки старого синтаксиса будут вылазить в самых неожиданных местах типового кода...
10. vsesam80 13.01.21 14:16 Сейчас в теме
(9)
а вот ошибки старого синтаксиса будут вылазить в самых неожиданных местах типового кода...
- вот это и напрягает сильно.
4. SlavaKron 13.01.21 12:08 Сейчас в теме
На свой страх и риск можно закомментировать проверку версии платформы.
6. vsesam80 13.01.21 13:49 Сейчас в теме
В общем поставил 8.3.17, ошибка та же:

Режим совместимости конфигурации с 1С:Предприятием версии 8.3.17 не поддерживается.
Для запуска установите в конфигурации режим совместимости "Не использовать" при разработке на версии 8.3.10
(или "Версия 8.3.10" при разработке на более старших версиях).

А что бы реквизит в конфу добавить надо убрать совместимость. Че за на фиг?
Это что получается расширения в КА нельзя использовать в этом случае?
11. vsesam80 13.01.21 23:09 Сейчас в теме
Народ, я таки не догоняю. Почему ругается на "Для запуска установите в конфигурации режим совместимости "Не использовать" при разработке на версии 8.3.10". Я же по отключал всё!
12. Оберон 11 14.01.21 16:27 Сейчас в теме
должен быть одинаковый режим совместимости в конфе и в расширении
13. vsesam80 14.01.21 16:34 Сейчас в теме
(12)делал по всякому. Смотрел видосы Леонтьева из курса расширений, Гилева про эту же тему - не работает. Все виды совместимости тупо брутфоросом перебрал к утру. не работает. Пробовал комментировать строчки эксепшена где на совместимость ругается, но это тянет за собой лавину других ошибок.
Оставьте свое сообщение
Вопросы с вознаграждением