Нужно передать количество документов через запрос в поле

1. 12.01.21 18:25 Сейчас в теме
Здравствуйте! Нужно получить количество документов за день, чтобы передать это количество в поле ввода. Я написал соответствующий код, но это почему-то не работает. Через отладчик тоже никакой инфы нет. Не могу понять в чем дело. Буду рад помощи. Спасибо заранее.

Если ЗначениеЗаполнено(ВыбранныйМенеджер) Тогда
Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	Количество(ЗаданиеМенеджера.Ссылка) КАК Количество
		|ИЗ
		|	Документ.ЗаданиеМенеджера КАК ЗаданиеМенеджера
		|ГДЕ
		|	ЗаданиеМенеджера.Дата = &Дата
		|	И ЗаданиеМенеджера.Менеджер= &Менеджер";
		ДатаБезВремени = Объект.Дата;
		Запрос.УстановитьПараметр("Менеджер",Объект.Менеджер);
		Запрос.УстановитьПараметр("Дата",ДатаБезВремени);
		РезультатЗапроса = Запрос.Выполнить();
		Выборка = РезультатЗапроса.Выбрать();
		Если Выборка.Следующий() Тогда
			Объект.НомерРаботы = Выборка.Количество + 1;
		Иначе
			Объект.НомерРаботы = 1;
		КонецЕсли;
		
	КонецЕсли;
Показать
Вознаграждение за ответ
Показать полностью
Найденные решения
2. Varlant1n 12.01.21 18:41 Сейчас в теме +0.05 $m
(1) Решил. Надо вместо
| ЗаданиеЭкспедитора.Дата = &Дата

НАЧАЛОПЕРИОДА(ЗаданиеЭкспедитора.Дата,ДЕНЬ)=НАЧАЛОПЕРИОДА(&Дата,ДЕНЬ)
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Varlant1n 12.01.21 18:41 Сейчас в теме +0.05 $m
(1) Решил. Надо вместо
| ЗаданиеЭкспедитора.Дата = &Дата

НАЧАЛОПЕРИОДА(ЗаданиеЭкспедитора.Дата,ДЕНЬ)=НАЧАЛОПЕРИОДА(&Дата,ДЕНЬ)
4. dominatorwarr 13.01.21 09:28 Сейчас в теме
(2) Сделайте как в (3) и не делайте условия, в которых нужно что-то вычислять, это очень тормозит запрос
3. stein13 2 12.01.21 18:42 Сейчас в теме
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Количество(ЗаданиеМенеджера.Ссылка) КАК Количество
|ИЗ
| Документ.ЗаданиеМенеджера КАК ЗаданиеМенеджера
|ГДЕ
| ЗаданиеМенеджера.Дата Между &НачалоПериода И &КонецПериода
| И ЗаданиеМенеджера.Менеджер= &Менеджер";

Запрос.УстановитьПараметр("Менеджер",Объект.Менеджер);
Запрос.УстановитьПараметр("НачалоПериода", НачалоДня(Объект.Дата));
Запрос.УстановитьПараметр("КонецПериода", КонецДня(Объект.Дата));

Выборка= Запрос.Выполнить().Выбрать();

Количество = 0;

Пока Выборка.Следующий() Цикл

Количество = Выборка.Количество;

КонецЕсли
dominatorwarr; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением