Изменить наименование номенклатуры на наименование покумателя во внешней УПД для БП 3.0

1. 13.11.20 10:43 Сейчас в теме
Добрый день!

Есть впф УПД для БП 3.0.
В табл часть РТиУ внесла доп поле НаименованиеПокупателя, строка неогран длины. Пользователь вносит туда нужные для печати наименования.

Нужно распечатать УПД именно с наименованием покупателя.

Добрые люди подскажите, в каком месте заменить наименованиеТовара на наименованиепокупателятовара?

у меня не получается пока найти..Пожалуйста,подскажите!
Прикрепленные файлы:
Вознаграждение за ответ
Показать полностью
Найденные решения
4. surebk 13.11.20 11:10 Сейчас в теме +0.5 $m
Реализовывал тоже самое в БП, добавлял сюда, функция ВывестиСчетФактуруВТабличныйДокумент
Для каждого СтрокаДокумента Из ТаблицаДокумента Цикл
		
		НомерСтроки = НомерСтроки + 1;
		СтрокаДокумента.НомерСтроки = НомерСтроки;
		
		ОбластьМакета.Параметры.Заполнить(СтрокаДокумента);
		//+13.07.2018
		Если ПустаяСтрока(СтрокаДокумента.СоответствиеНоменклатуры)  Тогда
			ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.ТоварНаименование;
		ИНАЧЕ
			ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.СоответствиеНоменклатуры;
		КонецЕсли;
		//-- 13.07.2018
		Если НЕ ЗначениеЗаполнено(СтрокаДокумента.СтавкаНДС) Тогда
			ОбластьМакета.Параметры.СтавкаНДС = "--";
			Если СтрокаДокумента.СуммаНДС = 0 Тогда
				ОбластьМакета.Параметры.СуммаНДС = "--";
			КонецЕсли;
		КонецЕсли;
Показать

Предварительно добавлял в ТЗ колонку, чтобы типовой запрос не ковырять
Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РеализацияТоваровУслугТовары.Ссылка КАК Ссылка,
	|	РеализацияТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
	|	РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
	|	РеализацияТоваровУслугТовары.КоличествоМест КАК КоличествоМест,
	|	РеализацияТоваровУслугТовары.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
	|	РеализацияТоваровУслугТовары.Коэффициент КАК Коэффициент,
	|	РеализацияТоваровУслугТовары.Количество КАК Количество,
	|	РеализацияТоваровУслугТовары.Цена КАК Цена,
	|	РеализацияТоваровУслугТовары.Сумма КАК Сумма,
	|	РеализацияТоваровУслугТовары.СтавкаНДС КАК СтавкаНДС,
	|	РеализацияТоваровУслугТовары.СуммаНДС КАК СуммаНДС,
	|	РеализацияТоваровУслугТовары.СчетУчета КАК СчетУчета,
	|	РеализацияТоваровУслугТовары.ПереданныеСчетУчета КАК ПереданныеСчетУчета,
	|	РеализацияТоваровУслугТовары.СчетДоходов КАК СчетДоходов,
	|	РеализацияТоваровУслугТовары.Субконто КАК Субконто,
	|	РеализацияТоваровУслугТовары.СчетУчетаНДСПоРеализации КАК СчетУчетаНДСПоРеализации,
	|	РеализацияТоваровУслугТовары.СчетРасходов КАК СчетРасходов,
	|	РеализацияТоваровУслугТовары.ДокументОприходования КАК ДокументОприходования,
	|	РеализацияТоваровУслугТовары.Себестоимость КАК Себестоимость,
	|	РеализацияТоваровУслугТовары.НомерГТД КАК НомерГТД,
	|	РеализацияТоваровУслугТовары.СтранаПроисхождения КАК СтранаПроисхождения,
	|	РеализацияТоваровУслугТовары.КиЗ_ГИСМ КАК КиЗ_ГИСМ,
	|	РеализацияТоваровУслугТовары.КодТНВЭД КАК КодТНВЭД,
	|	РеализацияТоваровУслугТовары.СоответствиеНоменклатуры КАК СоответствиеНоменклатуры
	|ИЗ
	|	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
	|ГДЕ
	|	РеализацияТоваровУслугТовары.Ссылка = &Ссылка
	|
	|УПОРЯДОЧИТЬ ПО
	|	НомерСтроки";
	
	Запрос.УстановитьПараметр("Ссылка", ВыборкаСФ.СчетФактура.ДокументОснование);
	
	РезультатЗапроса = Запрос.Выполнить();
	Таблица1 = РезультатЗапроса.Выгрузить();
	
	ТаблицаДокумента.Колонки.Добавить("СоответствиеНоменклатуры",Новый ОписаниеТипов("Строка"));
	//ТаблицаДокумента = Таблица1.Скопировать("СоответствиеНоменклатуры");  
	ТаблицаДокумента.ЗагрузитьКолонку(Таблица1.ВыгрузитьКолонку("СоответствиеНоменклатуры"),"СоответствиеНоменклатуры");
Показать
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. PhoenixAOD 60 13.11.20 10:52 Сейчас в теме
(1)посмотри в обработке печатьВнешнихФорм, там есть заполнитьтаблчастьУПД или как то так
6. user856012 13 13.11.20 11:35 Сейчас в теме
(1)
Пожалуйста,подскажите!
Подсказываю: надо было хотя бы переименовать файл, а то сразу понятно, откуда вы его взяли: https://infostart.ru/public/586367/

Или, может быть, автор дал вам разрешение на выкладывание его разработки?
FatPanzer; +1 Ответить
7. FatPanzer 9 13.11.20 11:40 Сейчас в теме
2. FatPanzer 9 13.11.20 10:49 Сейчас в теме
В запросе. В модуле менеджера документа методы что-то типа ПолучитьДанныеДляПечатиУниверсальныйПередаточныйДокумент()
4. surebk 13.11.20 11:10 Сейчас в теме +0.5 $m
Реализовывал тоже самое в БП, добавлял сюда, функция ВывестиСчетФактуруВТабличныйДокумент
Для каждого СтрокаДокумента Из ТаблицаДокумента Цикл
		
		НомерСтроки = НомерСтроки + 1;
		СтрокаДокумента.НомерСтроки = НомерСтроки;
		
		ОбластьМакета.Параметры.Заполнить(СтрокаДокумента);
		//+13.07.2018
		Если ПустаяСтрока(СтрокаДокумента.СоответствиеНоменклатуры)  Тогда
			ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.ТоварНаименование;
		ИНАЧЕ
			ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.СоответствиеНоменклатуры;
		КонецЕсли;
		//-- 13.07.2018
		Если НЕ ЗначениеЗаполнено(СтрокаДокумента.СтавкаНДС) Тогда
			ОбластьМакета.Параметры.СтавкаНДС = "--";
			Если СтрокаДокумента.СуммаНДС = 0 Тогда
				ОбластьМакета.Параметры.СуммаНДС = "--";
			КонецЕсли;
		КонецЕсли;
Показать

Предварительно добавлял в ТЗ колонку, чтобы типовой запрос не ковырять
Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	РеализацияТоваровУслугТовары.Ссылка КАК Ссылка,
	|	РеализацияТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
	|	РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
	|	РеализацияТоваровУслугТовары.КоличествоМест КАК КоличествоМест,
	|	РеализацияТоваровУслугТовары.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
	|	РеализацияТоваровУслугТовары.Коэффициент КАК Коэффициент,
	|	РеализацияТоваровУслугТовары.Количество КАК Количество,
	|	РеализацияТоваровУслугТовары.Цена КАК Цена,
	|	РеализацияТоваровУслугТовары.Сумма КАК Сумма,
	|	РеализацияТоваровУслугТовары.СтавкаНДС КАК СтавкаНДС,
	|	РеализацияТоваровУслугТовары.СуммаНДС КАК СуммаНДС,
	|	РеализацияТоваровУслугТовары.СчетУчета КАК СчетУчета,
	|	РеализацияТоваровУслугТовары.ПереданныеСчетУчета КАК ПереданныеСчетУчета,
	|	РеализацияТоваровУслугТовары.СчетДоходов КАК СчетДоходов,
	|	РеализацияТоваровУслугТовары.Субконто КАК Субконто,
	|	РеализацияТоваровУслугТовары.СчетУчетаНДСПоРеализации КАК СчетУчетаНДСПоРеализации,
	|	РеализацияТоваровУслугТовары.СчетРасходов КАК СчетРасходов,
	|	РеализацияТоваровУслугТовары.ДокументОприходования КАК ДокументОприходования,
	|	РеализацияТоваровУслугТовары.Себестоимость КАК Себестоимость,
	|	РеализацияТоваровУслугТовары.НомерГТД КАК НомерГТД,
	|	РеализацияТоваровУслугТовары.СтранаПроисхождения КАК СтранаПроисхождения,
	|	РеализацияТоваровУслугТовары.КиЗ_ГИСМ КАК КиЗ_ГИСМ,
	|	РеализацияТоваровУслугТовары.КодТНВЭД КАК КодТНВЭД,
	|	РеализацияТоваровУслугТовары.СоответствиеНоменклатуры КАК СоответствиеНоменклатуры
	|ИЗ
	|	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
	|ГДЕ
	|	РеализацияТоваровУслугТовары.Ссылка = &Ссылка
	|
	|УПОРЯДОЧИТЬ ПО
	|	НомерСтроки";
	
	Запрос.УстановитьПараметр("Ссылка", ВыборкаСФ.СчетФактура.ДокументОснование);
	
	РезультатЗапроса = Запрос.Выполнить();
	Таблица1 = РезультатЗапроса.Выгрузить();
	
	ТаблицаДокумента.Колонки.Добавить("СоответствиеНоменклатуры",Новый ОписаниеТипов("Строка"));
	//ТаблицаДокумента = Таблица1.Скопировать("СоответствиеНоменклатуры");  
	ТаблицаДокумента.ЗагрузитьКолонку(Таблица1.ВыгрузитьКолонку("СоответствиеНоменклатуры"),"СоответствиеНоменклатуры");
Показать
5. FatPanzer 9 13.11.20 11:15 Сейчас в теме
(4) То есть ты добавил строчку в запрос, и еще изменил процедуру вывода. А можно сразу в запросе написать, и не менять процедуру вывода.
|ВЫБОР
|    КОГДА Товары.СоответствиеНоменклатуры = ""
|        ТОГДА Товары.Номенклатура.Наименование
|    ИНАЧЕ Товары.СоответствиеНоменклатуры
|КОНЕЦ КАК ТоварНаименование
9. surebk 13.11.20 15:24 Сейчас в теме
13. Linda1C 19.11.20 14:37 Сейчас в теме
(9), подскажите пожалуйста.

Возникла непонятная ситуация с этой обработкой ,на тестовой все работало.
На рабочей уже нет..

я обработку не меняла, но создала в РТиУ новое поле заново, те не загружала конфу. Все совпадает по наименованиям.. Но ошибка не дает сформировать ВПФ

Ругается на эту строчку..

ТаблицаДокумента.Колонки.Добавить("СоответствиеНоменклатуры",Новый ОписаниеТипов("Строка"));
Прикрепленные файлы:
14. surebk 21.11.20 00:24 Сейчас в теме
(13)Проверьте тип и наименование, или просто перезагрузите из тестовой базы в которой все работает этот реквизит. У себя вы реквизит так "СоответствиеНоменклатуры" назвали?
15. Linda1C 23.11.20 15:20 Сейчас в теме
(14), пробовала из тестовой грузить конфигурацию-не помогает, какой-то глюк..
16. Linda1C 23.11.20 15:39 Сейчас в теме
(14), но я попробовала этот реквизит удалить, создала новый и назвала его НоменклатураДляПечати. Переименовала в вашем коде СоответствиеНоменклатуры на НоменклатураДляПечати. Опять выходит ошибка.

Посмотрите пожадуйста код. Все нормально там?
Запрос = Новый Запрос;
    Запрос.Текст = 
    "ВЫБРАТЬ
    |    РеализацияТоваровУслугТовары.Ссылка КАК Ссылка,
    |    РеализацияТоваровУслугТовары.НомерСтроки КАК НомерСтроки,
    |    РеализацияТоваровУслугТовары.Номенклатура КАК Номенклатура,
    |    РеализацияТоваровУслугТовары.КоличествоМест КАК КоличествоМест,
    |    РеализацияТоваровУслугТовары.ЕдиницаИзмерения КАК ЕдиницаИзмерения,
    |    РеализацияТоваровУслугТовары.Коэффициент КАК Коэффициент,
    |    РеализацияТоваровУслугТовары.Количество КАК Количество,
    |    РеализацияТоваровУслугТовары.Цена КАК Цена,
    |    РеализацияТоваровУслугТовары.Сумма КАК Сумма,
    |    РеализацияТоваровУслугТовары.СтавкаНДС КАК СтавкаНДС,
    |    РеализацияТоваровУслугТовары.СуммаНДС КАК СуммаНДС,
    |    РеализацияТоваровУслугТовары.СчетУчета КАК СчетУчета,
    |    РеализацияТоваровУслугТовары.ПереданныеСчетУчета КАК ПереданныеСчетУчета,
    |    РеализацияТоваровУслугТовары.СчетДоходов КАК СчетДоходов,
    |    РеализацияТоваровУслугТовары.Субконто КАК Субконто,
    |    РеализацияТоваровУслугТовары.СчетУчетаНДСПоРеализации КАК СчетУчетаНДСПоРеализации,
    |    РеализацияТоваровУслугТовары.СчетРасходов КАК СчетРасходов,
    |    РеализацияТоваровУслугТовары.ДокументОприходования КАК ДокументОприходования,
    |    РеализацияТоваровУслугТовары.Себестоимость КАК Себестоимость,
    |    РеализацияТоваровУслугТовары.НомерГТД КАК НомерГТД,
    |    РеализацияТоваровУслугТовары.СтранаПроисхождения КАК СтранаПроисхождения,
    |    РеализацияТоваровУслугТовары.КиЗ_ГИСМ КАК КиЗ_ГИСМ,
    |    РеализацияТоваровУслугТовары.КодТНВЭД КАК КодТНВЭД,
    |    РеализацияТоваровУслугТовары.НоменклатураДляПечати КАК НоменклатураДляПечати
    |ИЗ
    |    Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |ГДЕ
    |    РеализацияТоваровУслугТовары.Ссылка = &Ссылка
    |
    |УПОРЯДОЧИТЬ ПО
    |    НомерСтроки";
    
    Запрос.УстановитьПараметр("Ссылка", ВыборкаСФ.СчетФактура.ДокументОснование);
    
    РезультатЗапроса = Запрос.Выполнить();
    Таблица1 = РезультатЗапроса.Выгрузить();
    
    ТаблицаДокумента.Колонки.Добавить("НоменклатураДляПечати",Новый ОписаниеТипов("Строка"));
    //ТаблицаДокумента = Таблица1.Скопировать("СоответствиеНоменклатуры");  
    ТаблицаДокумента.ЗагрузитьКолонку(Таблица1.ВыгрузитьКолонку("НоменклатураДляПечати"),"НоменклатураДляПечати");
	  //+13.07.2018
        Если ПустаяСтрока(СтрокаДокумента.НоменклатураДляПечати)  Тогда
            ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.ТоварНаименование;
        ИНАЧЕ
            ОбластьМакета.Параметры.ТоварНаименование=СтрокаДокумента.НоменклатураДляПечати;
        КонецЕсли;
        //-- 13.07.2018	
Показать
17. Linda1C 23.11.20 15:40 Сейчас в теме
(16)
ТаблицаДокумента.Колонки.Добавить("НоменклатураДляПечати",Новый ОписаниеТипов("Строка"));


на эту строчку ругается
10. Linda1C 16.11.20 11:39 Сейчас в теме
(4), подскажите пожалуйста, этот запрос в какое место всталять?не пойму что-то..

Если в ВывестиСчетФактуруВТабличныйДокумент, то ругается программа
11. surebk 16.11.20 15:53 Сейчас в теме
(10) Можете прям перед циклом, вы поменяли везде "СоответствиеНоменклатуры" на
"НаименованиеПокупателя"?
12. Linda1C 17.11.20 11:48 Сейчас в теме
(4) ,получилось!

Спасибо большое!
8. AndKovalchuk 132 13.11.20 12:10 Сейчас в теме
Там в строке 105 обработке
Документы[Объект.Метаданные().Имя].ТекстЗапросаПечатьУниверсальныхПередаточныхДокументов();


Т.е. запрос берется из менеждера документа (либо счет-фактура) или (либо расходная накладная). Смотря откуда УПД формируется. Ну и соответстветственно нужно это место в обработке переписывать.
18. surebk 23.11.20 16:21 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением