УТ 11 заполнение цен по последней реализации

1. 9 16.10.20 04:27 Сейчас в теме
Добрый день уважаемые форумчане !!!
прошу помощи у гуру ...
Не нашел в катологе разработок но думаю кто то делал ...
УТ 11 Просят написать так чтобы при подстановке номенклатуры ставилась последняя цена реализации товара - потому что прайс-лист никто не заполняет. Понимаю что можно написать ... думаю наверное кто то делал что то подобное ...
Ткните пожалуйста - вознаграждение будет ...
Вознаграждение за ответ
Показать полностью
Найденные решения
19. EVKash 8 16.10.20 10:30 Сейчас в теме +0.4 $m
(1) вот в БП3
	Если Не ЗначениеЗаполнено(ПараметрыОбъекта.ТипЦен) Тогда
		ПараметрыОбъекта.Вставить("СпособЗаполненияЦены", Перечисления.СпособыЗаполненияЦен.ПоПродажнымЦенам);
	КонецЕсли;
	
	СведенияОНоменклатуре = БухгалтерскийУчетПереопределяемый.ПолучитьСведенияОНоменклатуре(
		СтрокаТабличнойЧасти.Номенклатура,
		ПараметрыОбъекта,
		Ложь);
Показать
			ТаблицаЦен = Ценообразование.ПолучитьТаблицуЦенНоменклатурыДокументов(СписокНоменклатуры, 
				СпособЗаполненияЦены,
				Дата);
Функция ПолучитьТаблицуЦенНоменклатурыДокументов(МассивНоменклатуры, СпособЗаполненияЦены, Дата) Экспорт
	
	ЦеныНоменклатуры = НовыйЦеныНоменклатуры();
	
	Если Не ПравоДоступа("Чтение", Метаданные.РегистрыСведений.ЦеныНоменклатурыДокументов) Тогда
		Возврат ЦеныНоменклатуры;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Период",					Дата);	
	Запрос.УстановитьПараметр("СпособЗаполненияЦены",	СпособЗаполненияЦены);
	Запрос.УстановитьПараметр("МассивНоменклатуры",		МассивНоменклатуры);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЦеныНоменклатурыДокументов.Номенклатура КАК Номенклатура,
	|	ЦеныНоменклатурыДокументов.Цена КАК Цена,
	|	ЦеныНоменклатурыДокументов.Валюта КАК Валюта,
	|	ЦеныНоменклатурыДокументов.ЦенаВключаетНДС
	|ПОМЕСТИТЬ ЦеныНоменклатуры
	|ИЗ
	|	РегистрСведений.ЦеныНоменклатурыДокументов КАК ЦеныНоменклатурыДокументов
	|ГДЕ
	|	ЦеныНоменклатурыДокументов.Номенклатура В(&МассивНоменклатуры)
	|	И ЦеныНоменклатурыДокументов.СпособЗаполненияЦены = &СпособЗаполненияЦены
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Валюта
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	КурсыВалютСрезПоследних.Валюта КАК Валюта,
	|	КурсыВалютСрезПоследних.Курс КАК Курс,
	|	КурсыВалютСрезПоследних.Кратность КАК Кратность
	|ПОМЕСТИТЬ КурсыВалют
	|ИЗ
	|	РегистрСведений.КурсыВалют.СрезПоследних(&Период, ) КАК КурсыВалютСрезПоследних
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Валюта
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	ЦеныНоменклатуры.Номенклатура КАК Номенклатура,
	|	ЦеныНоменклатуры.Цена КАК Цена,
	|	ЦеныНоменклатуры.Валюта КАК Валюта,
	|	ЕСТЬNULL(КурсыВалют.Курс, 1) КАК Курс,
	|	ЕСТЬNULL(КурсыВалют.Кратность, 1) КАК Кратность,
	|	ЦеныНоменклатуры.ЦенаВключаетНДС
	|ИЗ
	|	ЦеныНоменклатуры КАК ЦеныНоменклатуры
	|		ЛЕВОЕ СОЕДИНЕНИЕ КурсыВалют КАК КурсыВалют
	|		ПО ЦеныНоменклатуры.Валюта = КурсыВалют.Валюта";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
			ЗаполнитьЗначенияСвойств(ЦеныНоменклатуры.Добавить(), Выборка);
	КонецЦикла;
	
	Возврат ЦеныНоменклатуры;
	
КонецФункции
Показать

Сами цены в отдельном РС хранятся.
andrey7617; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
8. RocKeR_13 837 16.10.20 09:35 Сейчас в теме +0.2 $m
(1) Если клиент упрямый окажется все-таки, то, пожалуй, самый лучший вариант:
1) добавить вид цен для продаж
2) при проведении реализации сверять цены в реализации с актуальными на дату реализации в строках с видом цен "<Произвольная>": если есть отличия - автоматически создавать и заполнять документ установки цен
andrey7617; +1 Ответить
10. WellJustYouWait 16.10.20 09:45 Сейчас в теме +0.2 $m
(8)
упрямому клиенту
1.лучше объяснить последствия
2.в случае не согласия помахать рукой
3.в случае согласия не делать глупостей
andrey7617; +1 Ответить
11. WellJustYouWait 16.10.20 09:49 Сейчас в теме
(10)
--------------------при подстановке номенклатуры
ставилась последняя цена реализации товара
--------------------------------------------------------

здесь вообще интересный вопрос :)

простор для догадок
andrey7617; +1 Ответить
12. RocKeR_13 837 16.10.20 09:56 Сейчас в теме
(10)
1.лучше объяснить последствия

Это само собой

2.в случае не согласия помахать рукой

Когда работаешь не на себя, увы, это решать руководству)

3.в случае согласия не делать глупостей

С этим тоже не поспоришь)
andrey7617; +1 Ответить
13. FatPanzer 7 16.10.20 10:02 Сейчас в теме
(12)
Когда работаешь не на себя, увы, это решать руководству)
Чегой-то? Рабство отменено в любых формах, насколько я помню.
andrey7617; +1 Ответить
14. RocKeR_13 837 16.10.20 10:08 Сейчас в теме
(13) А при чем тут рабство? Клиент обратился к франчу с задачей; клиенту объяснили, что лучше сделать так и так; клиент все равно хочет по-своему и это его право; клиент за это готов платить озвученную сумму - программисту прилетает задача на исполнение. Если программист отказывается от выполнения своих обязанностей по исполнению задачи, то, естественно, руководство задумается, а нужен ли такой работник. Рабства никакого: не хочешь выполнять поставленные задачи - никто не держит, переходи в другую фирму)
andrey7617; +1 Ответить
15. FatPanzer 7 16.10.20 10:12 Сейчас в теме
(14) Так тебе и говорят - в случае несогласия помахать ручкой заказчику. А ты в ответ говоришь, "увы, это решать руководству".
Если ты работаешь во франче, то для тебя первый заказчик - франч. А клиент - просто постановщик задач.
Если ты не согласен с задачей, которую тебе заказал заказчик-франч, а установил клиент - помахай рукой франчу...
andrey7617; +1 Ответить
16. RocKeR_13 837 16.10.20 10:13 Сейчас в теме
(15) Где вы в исходном сообщении увидели предложение помахать рукой заказчику?)
упрямому клиенту
1.лучше объяснить последствия
2.в случае не согласия помахать рукой
3.в случае согласия не делать глупостей
17. FatPanzer 7 16.10.20 10:17 Сейчас в теме
(16) Ну-ну. Для тебя и клиент и заказчик - это все равно франч. Ты у него на субподряде.
andrey7617; +1 Ответить
18. RocKeR_13 837 16.10.20 10:25 Сейчас в теме
(17) Вы ушли уже в какие-то непросветные дебри)) Все намного проще: в наше время махать рукой работодателю - это непростительная глупость, а уж если вы не в Москве - вдвойне. Есть принципиальные знакомые, которые сидят без работы и денег, зато при своих принципах.
andrey7617; user1464234; +2 Ответить
21. Xershi 1032 16.10.20 10:59 Сейчас в теме
(1) научите пользоваться программой, люди настолько ленивые и глупые, что не понимают от чего отказываются.
andrey7617; WellJustYouWait; EVKash; +3 Ответить
2. AlexeyIsip 10 16.10.20 06:00 Сейчас в теме +0.2 $m
На сколько я знаю, цена подставляется в документ «Реализация товаров и услуг» из первого по времени документа ‘Установка цен номенклатуры’ после даты документа. Соответственно, вижу два варианта: 1) сделать регламентное задание, которое ежедневно заполняет документ «Установка цен номенклатуры» нужными ценами, 2) либо установить в справочнике ‘Вид цены’ способ задания цены «ручное назначение» и написать внешнюю обработку, которая через «Дополнительные отчеты и обработки» добавить кнопку в документ «Реализация товаров услуг», а уже к этой кнопке можно приладить любой механизм установки цен. Но каждый из способов имеет свои недостатки: первый способ: 1) регламентное задание обычно ночью выполняется и ,если утром клиент установил в документе реализация новые цены, то они автоматически будут подставляться только со следующего дня; 2) бесконтрольный автоматический ввод ввод очень значимых документов (кто будет крайним, продадут некондицию за 3 копейки, а потом будет продажа нормального товара на миллион и цены автоматически попадут из предыдущего документа). Второй способ: 1) сложно будет использовать автоматический механизм установки персональных скидок клиенту во внешней обработке 2) нельзя будет воспользоваться стандартным функционалом, связанным с документов «Установка цен номенклатуры», например, распечатать прайс. В целом два моих способа требуют вмешательства программиста и по мне правильнее убедить клиента, что все-таки лучше пользоваться стандартным функционалом.
6. FatPanzer 7 16.10.20 09:13 Сейчас в теме
(2)
1) сложно будет использовать автоматический механизм установки персональных скидок клиенту во внешней обработке
Да у них прайс-листа то нет, о каких скидках и акциях может идти речь? ;-)
andrey7617; +1 Ответить
3. muskul 16.10.20 06:09 Сейчас в теме
Вот жеж ленивые ))))и очень странные, если цен нет то по каким продавать? а если цена поменялась
andrey7617; WellJustYouWait; +2 Ответить
4. platonov.e 104 16.10.20 07:48 Сейчас в теме
Это не правильно. Так и скажите им. в (3) вам привели 2 примера почему это не правильно. В УТ 11 отличный механизм по установки цен. Можно устанавливать цены на оснваонии поступления товаров, с определенный процентом наценки. Этого наверняка вам должно хватить.
andrey7617; +1 Ответить
5. WellJustYouWait 16.10.20 08:39 Сейчас в теме
наверное это один из случаев, когда начинается путь к самописке

а потом в тендере задачи....


------------------------------------------
интересные люди с пониманием :
" мне не интересно, как оно должно работать ...
мне интересно как я хочу "

-----------------------------------------
andrey7617; +1 Ответить
7. EVKash 8 16.10.20 09:17 Сейчас в теме
(1) Если не ошибаюсь, в бухгалтерии так работает.
Посмотрите как там реализовано.
andrey7617; +1 Ответить
9. oleg-x 15 16.10.20 09:35 Сейчас в теме
(1) Типового механизма нет, если хотите, то можете заказать доработку программы. В принципе все можно сделать через расширение.
andrey7617; +1 Ответить
19. EVKash 8 16.10.20 10:30 Сейчас в теме +0.4 $m
(1) вот в БП3
	Если Не ЗначениеЗаполнено(ПараметрыОбъекта.ТипЦен) Тогда
		ПараметрыОбъекта.Вставить("СпособЗаполненияЦены", Перечисления.СпособыЗаполненияЦен.ПоПродажнымЦенам);
	КонецЕсли;
	
	СведенияОНоменклатуре = БухгалтерскийУчетПереопределяемый.ПолучитьСведенияОНоменклатуре(
		СтрокаТабличнойЧасти.Номенклатура,
		ПараметрыОбъекта,
		Ложь);
Показать
			ТаблицаЦен = Ценообразование.ПолучитьТаблицуЦенНоменклатурыДокументов(СписокНоменклатуры, 
				СпособЗаполненияЦены,
				Дата);
Функция ПолучитьТаблицуЦенНоменклатурыДокументов(МассивНоменклатуры, СпособЗаполненияЦены, Дата) Экспорт
	
	ЦеныНоменклатуры = НовыйЦеныНоменклатуры();
	
	Если Не ПравоДоступа("Чтение", Метаданные.РегистрыСведений.ЦеныНоменклатурыДокументов) Тогда
		Возврат ЦеныНоменклатуры;
	КонецЕсли;
	
	Запрос = Новый Запрос;
	Запрос.УстановитьПараметр("Период",					Дата);	
	Запрос.УстановитьПараметр("СпособЗаполненияЦены",	СпособЗаполненияЦены);
	Запрос.УстановитьПараметр("МассивНоменклатуры",		МассивНоменклатуры);
	
	Запрос.Текст =
	"ВЫБРАТЬ
	|	ЦеныНоменклатурыДокументов.Номенклатура КАК Номенклатура,
	|	ЦеныНоменклатурыДокументов.Цена КАК Цена,
	|	ЦеныНоменклатурыДокументов.Валюта КАК Валюта,
	|	ЦеныНоменклатурыДокументов.ЦенаВключаетНДС
	|ПОМЕСТИТЬ ЦеныНоменклатуры
	|ИЗ
	|	РегистрСведений.ЦеныНоменклатурыДокументов КАК ЦеныНоменклатурыДокументов
	|ГДЕ
	|	ЦеныНоменклатурыДокументов.Номенклатура В(&МассивНоменклатуры)
	|	И ЦеныНоменклатурыДокументов.СпособЗаполненияЦены = &СпособЗаполненияЦены
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Валюта
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	КурсыВалютСрезПоследних.Валюта КАК Валюта,
	|	КурсыВалютСрезПоследних.Курс КАК Курс,
	|	КурсыВалютСрезПоследних.Кратность КАК Кратность
	|ПОМЕСТИТЬ КурсыВалют
	|ИЗ
	|	РегистрСведений.КурсыВалют.СрезПоследних(&Период, ) КАК КурсыВалютСрезПоследних
	|
	|ИНДЕКСИРОВАТЬ ПО
	|	Валюта
	|;
	|
	|////////////////////////////////////////////////////////////­////////////////////
	|ВЫБРАТЬ
	|	ЦеныНоменклатуры.Номенклатура КАК Номенклатура,
	|	ЦеныНоменклатуры.Цена КАК Цена,
	|	ЦеныНоменклатуры.Валюта КАК Валюта,
	|	ЕСТЬNULL(КурсыВалют.Курс, 1) КАК Курс,
	|	ЕСТЬNULL(КурсыВалют.Кратность, 1) КАК Кратность,
	|	ЦеныНоменклатуры.ЦенаВключаетНДС
	|ИЗ
	|	ЦеныНоменклатуры КАК ЦеныНоменклатуры
	|		ЛЕВОЕ СОЕДИНЕНИЕ КурсыВалют КАК КурсыВалют
	|		ПО ЦеныНоменклатуры.Валюта = КурсыВалют.Валюта";
	
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
			ЗаполнитьЗначенияСвойств(ЦеныНоменклатуры.Добавить(), Выборка);
	КонецЦикла;
	
	Возврат ЦеныНоменклатуры;
	
КонецФункции
Показать

Сами цены в отдельном РС хранятся.
andrey7617; +1 Ответить
20. Азбука Морзе 88 16.10.20 10:46 Сейчас в теме
(19) Не уверен, но по-моему там хранятся цены поставщиков, а не цены реализации. Но в целом чисто технически верный подход.
andrey7617; +1 Ответить
22. dima21m 37 16.10.20 12:06 Сейчас в теме
Вот эту разработку посмотрите https://infostart.ru/public/1228256/
andrey7617; +1 Ответить
23. WellJustYouWait 16.10.20 12:37 Сейчас в теме
(22)
--------------------при подстановке номенклатуры
ставилась последняя цена реализации товара
--------------------------------------------------------


думаете он имел ввиду такую обработку :) ?
andrey7617; +1 Ответить
24. dima21m 37 16.10.20 12:41 Сейчас в теме
(23) Не ту ссылку вставил. Вот правильная - https://infostart.ru/public/1311113/
andrey7617; +1 Ответить
25. Азбука Морзе 88 16.10.20 12:43 Сейчас в теме
(24) Оперативненько))
andrey7617; +1 Ответить
26. WellJustYouWait 16.10.20 12:49 Сейчас в теме
(24)
--------------------при подстановке номенклатуры
ставилась последняя цена реализации товара

неужели вы так уверены :)

подстановка номенклатуры - раскройте тайну , как догадались :)
andrey7617; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением