Значения по умолчанию УТ 11.4, ERP 2.5

0. 794 14.09.20 18:43 Сейчас в теме
Расширение позволяет устанавливать пользователям значения для подстановки в документы, как это было в УТ 10.3.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. brenli 29.09.20 10:10 Сейчас в теме
Привет. Это все объекты которые были использованы при создании расширения ?
Ресурс регистра Настройка какого типа? ПВХ?
2. the1 794 29.09.20 11:52 Сейчас в теме
(1)
Ресурс регистра Настройка какого типа?
Строка неограниченной длины. Туда пишутся настройки в формате JSON.
3. the1 794 29.09.20 11:53 Сейчас в теме
(1)
Это все объекты
Да, полный список объектов
4. Ktyre 21.10.20 12:48 Сейчас в теме
а кроме тех что на скрине, реквизиты "склад" и например "типовое соглашение" можно в эти настройки выводить? как вообще это работает? Просто нажимаем добавить и выбираем нужный объект? выбрали в добавить поле Склад и подставили значение?
5. the1 794 21.10.20 15:06 Сейчас в теме
(4) Любое значение, при условии что оно впишется в 100 наиболее употребимых в конфигурации. Склад например будет точно доступен, а вот типовое соглашение надо смотреть, насколько оно используется.
как вообще это работает
Добавляем строку, выбираем реквизит и устанавливаем его значение. Во всех документах оно будет будет подставлено по умолчанию
6. Ktyre 21.10.20 15:56 Сейчас в теме
а вот типовое соглашение надо смотреть, насколько оно используется.

но это как определяется что оно наиболее используемое или нет. В конфигурации разработчиком или статистически по количеству ссылок на него в базе данных? Можете это проверить? нужно понимать подходит это расширение или нет именно для типовых соглашений.
7. the1 794 21.10.20 16:17 Сейчас в теме
(6) Можете проверить, какие реквизиты будут доступны. Выполнить код на своей конфигурации
ДоступныеНастройки = Новый ТаблицаЗначений;
ДоступныеНастройки.Колонки.Добавить("Настройка",	Новый ОписаниеТипов("Строка"));
ДоступныеНастройки.Колонки.Добавить("ТипЗначения",	Новый ОписаниеТипов());
ДоступныеНастройки.Колонки.Добавить("Количество",	Новый ОписаниеТипов("Число"));

Для Каждого Объект Из Метаданные.Документы Цикл
	
	Для Каждого Реквизит Из Объект.Реквизиты Цикл
		
		Если ТипПодходит(Реквизит.Тип) Тогда
			НоваяСтрока = ДоступныеНастройки.Добавить();
			НоваяСтрока.Настройка = Реквизит.Имя;
			НоваяСтрока.ТипЗначения = Реквизит.Тип;
			НоваяСтрока.Количество = 1;
		КонецЕсли;
		
	КонецЦикла;
	
КонецЦикла;

ДоступныеНастройки.Свернуть("Настройка, ТипЗначения", "Количество");
ДоступныеНастройки.Сортировать("Количество УБЫВ");

Пока ДоступныеНастройки.Количество() > 50 Цикл
	ДоступныеНастройки.Удалить(ДоступныеНастройки[ДоступныеНастройки.Количество() - 1]);
КонецЦикла;

Для Каждого Стр Из ДоступныеНастройки Цикл
	Сообщить(Стр.Настройка)
КонецЦикла;
Показать
8. user925712 19.12.20 10:49 Сейчас в теме
Приветствую. Планирую скачать и как вопрос/предложение реквизиты периодические храняться или статика?
9. the1 794 19.12.20 10:52 Сейчас в теме
10. user925712 19.12.20 11:08 Сейчас в теме
(9) Подскажите как решить проблему.
ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.12 и ниже
При проверке метаданных обнаружены ошибки!
11. the1 794 19.12.20 11:10 Сейчас в теме
(10) Повысить режим совместимости конфигурации до 8.3.13
12. user925712 19.12.20 11:18 Сейчас в теме
(11) Не могу снимать с поддержки, обновить не могу, придется переписать много расширений.Видимо придется без подписки на событие искать обход.
13. the1 794 19.12.20 11:24 Сейчас в теме
(12) Можно попробовать вызывать методы общих модулей из расширения из общего модуля конфигурации МодификацииКонфигурацииПереопределяемый, и вызывать их в событии ПриСозданииНаСервере
Если Форма.Параметры.Ключ.Пустая() Тогда
   // ... здесь вызываем автозаполнение
КонецЕсли;
Пишу по памяти, 1С нет под рукой
14. user925712 19.12.20 17:46 Сейчас в теме
(13) Помогло, но Реквизиты = Источник.Метаданные().Реквизиты; вызвал новую ошибку.
Ее удалось частично обойти через ДанныеФормыВЗначение и обратно, но работает для определенного документа и определенных реквизитов. Видимо все-таки придется обновляться. УТ (11.4.11.106) Платформа 8.3.15.1869
15. Atom74 36 24.12.20 14:36 Сейчас в теме
Режим совместимости конфигурации 8.3.14 (КА 2.4.13), но расширение не устанавливается.
"ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.12 и ниже
При проверке метаданных обнаружены ошибки!"
16. the1 794 24.12.20 21:02 Сейчас в теме
17. Atom74 36 25.12.20 07:32 Сейчас в теме
1С:Предприятие 8.3 (8.3.15.1830)
18. the1 794 25.12.20 10:21 Сейчас в теме
(17) Это странно. Можно по удаленке посмотреть веером, в личку напишите
19. user925364 19.01.21 17:54 Сейчас в теме
можно добавить реквизит "Цена включает НДС" ?
20. the1 794 19.01.21 21:49 Сейчас в теме
Проверяли по методе, может он и так доступен?
21. user925364 20.01.21 11:07 Сейчас в теме
24. the1 794 20.01.21 14:28 Сейчас в теме
(21) Зайдите в конфигуратор, в общем модуле расширения зпуНастройкиПользователейПовтИсп замените текст процедуры ДоступныеНастройкиПользователей на
Функция ДоступныеНастройкиПользователей() Экспорт
	
	ДоступныеНастройки = Новый ТаблицаЗначений;
	ДоступныеНастройки.Колонки.Добавить("Настройка",	Новый ОписаниеТипов("Строка"));
	ДоступныеНастройки.Колонки.Добавить("ТипЗначения",	Новый ОписаниеТипов());
	ДоступныеНастройки.Колонки.Добавить("Количество",	Новый ОписаниеТипов("Число"));
	
	Для Каждого Объект Из Метаданные.Документы Цикл
		
		Для Каждого Реквизит Из Объект.Реквизиты Цикл
			
			Если ТипПодходит(Реквизит.Тип) Тогда
				НоваяСтрока = ДоступныеНастройки.Добавить();
				НоваяСтрока.Настройка = Реквизит.Имя;
				НоваяСтрока.ТипЗначения = Реквизит.Тип;
				НоваяСтрока.Количество = 1;
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЦикла;
	
	ДоступныеНастройки.Свернуть("Настройка, ТипЗначения", "Количество");
	ДоступныеНастройки.Сортировать("Количество УБЫВ");
	
	Пока ДоступныеНастройки.Количество() > 50 Цикл
		НоваяСтрока = ДоступныеНастройки[ДоступныеНастройки.Количество() - 1];
		Если НоваяСтрока.Настройка = "ЦенаВключаетНДС" Тогда
			Продолжить;
		КонецЕсли;
		ДоступныеНастройки.Удалить(НоваяСтрока);
	КонецЦикла;
	
	Возврат ДоступныеНастройки;
	
КонецФункции
Показать

Вместо ЦенаВключаетНДС подставьте имя реквизита, как оно задано в конфигураторе.
22. sergeysea 20.01.21 12:50 Сейчас в теме
проблема следующая, во все документы вводимые на основании подставляются значения по умолчанию, а не из документа основания.
23. the1 794 20.01.21 14:22 Сейчас в теме
(22) Реально проблема, надо подумать над этим
31. sergeysea 27.01.21 21:00 Сейчас в теме
(23)Не думали еще над вопросом?
32. the1 794 27.01.21 21:10 Сейчас в теме
25. user925364 20.01.21 18:51 Сейчас в теме
не помогло, код добавил но новый параметр не появился(
https://i.paste.pics/03b18f097aed3ea7f8e2dfc31c3817b7.png
28. the1 794 24.01.21 21:51 Сейчас в теме
(25) Сорь, не видел сообщения почему-то. Сразу в голову не пришло, но это видимо булевый реквизит? Если да, тогда дополните код вместо
Если ТипПодходит(Реквизит.Тип) Тогда
написать
Если Реквизит.Имя = "ЦенаВключаетНДС" Или ТипПодходит(Реквизит.Тип) Тогда
26. user1530156 24.01.21 21:27 Сейчас в теме
подскажите пожалуйста подойдет ли данное расширение для 1С:ERP Управление предприятием 2 (2.4.13.57)
27. the1 794 24.01.21 21:42 Сейчас в теме
(26) К сожалению, проверить не на чем. На 2.5 работает.
29. user1530156 24.01.21 21:51 Сейчас в теме
не очень просто хочется платить за абонемент, чтоб скачать расширение, и чтобы оно потом не сработало((
30. the1 794 24.01.21 21:53 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением