Значения по умолчанию УТ 11.4, ERP 2, КА 2.

0. 909 14.09.20 18:43 Сейчас в теме
Расширение позволяет устанавливать пользователям значения для подстановки в документы, как это было в УТ 10.3.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. brenli 29.09.20 10:10 Сейчас в теме
Привет. Это все объекты которые были использованы при создании расширения ?
Ресурс регистра Настройка какого типа? ПВХ?
2. the1 909 29.09.20 11:52 Сейчас в теме
(1)
Ресурс регистра Настройка какого типа?
Строка неограниченной длины. Туда пишутся настройки в формате JSON.
3. the1 909 29.09.20 11:53 Сейчас в теме
(1)
Это все объекты
Да, полный список объектов
4. Ktyre 21.10.20 12:48 Сейчас в теме
а кроме тех что на скрине, реквизиты "склад" и например "типовое соглашение" можно в эти настройки выводить? как вообще это работает? Просто нажимаем добавить и выбираем нужный объект? выбрали в добавить поле Склад и подставили значение?
5. the1 909 21.10.20 15:06 Сейчас в теме
(4) Любое значение, при условии что оно впишется в 100 наиболее употребимых в конфигурации. Склад например будет точно доступен, а вот типовое соглашение надо смотреть, насколько оно используется.
как вообще это работает
Добавляем строку, выбираем реквизит и устанавливаем его значение. Во всех документах оно будет будет подставлено по умолчанию
6. Ktyre 21.10.20 15:56 Сейчас в теме
а вот типовое соглашение надо смотреть, насколько оно используется.

но это как определяется что оно наиболее используемое или нет. В конфигурации разработчиком или статистически по количеству ссылок на него в базе данных? Можете это проверить? нужно понимать подходит это расширение или нет именно для типовых соглашений.
7. the1 909 21.10.20 16:17 Сейчас в теме
(6) Можете проверить, какие реквизиты будут доступны. Выполнить код на своей конфигурации
ДоступныеНастройки = Новый ТаблицаЗначений;
ДоступныеНастройки.Колонки.Добавить("Настройка",	Новый ОписаниеТипов("Строка"));
ДоступныеНастройки.Колонки.Добавить("ТипЗначения",	Новый ОписаниеТипов());
ДоступныеНастройки.Колонки.Добавить("Количество",	Новый ОписаниеТипов("Число"));

Для Каждого Объект Из Метаданные.Документы Цикл
	
	Для Каждого Реквизит Из Объект.Реквизиты Цикл
		
		Если ТипПодходит(Реквизит.Тип) Тогда
			НоваяСтрока = ДоступныеНастройки.Добавить();
			НоваяСтрока.Настройка = Реквизит.Имя;
			НоваяСтрока.ТипЗначения = Реквизит.Тип;
			НоваяСтрока.Количество = 1;
		КонецЕсли;
		
	КонецЦикла;
	
КонецЦикла;

ДоступныеНастройки.Свернуть("Настройка, ТипЗначения", "Количество");
ДоступныеНастройки.Сортировать("Количество УБЫВ");

Пока ДоступныеНастройки.Количество() > 50 Цикл
	ДоступныеНастройки.Удалить(ДоступныеНастройки[ДоступныеНастройки.Количество() - 1]);
КонецЦикла;

Для Каждого Стр Из ДоступныеНастройки Цикл
	Сообщить(Стр.Настройка)
КонецЦикла;
Показать
8. user925712 19.12.20 10:49 Сейчас в теме
Приветствую. Планирую скачать и как вопрос/предложение реквизиты периодические храняться или статика?
9. the1 909 19.12.20 10:52 Сейчас в теме
10. user925712 19.12.20 11:08 Сейчас в теме
(9) Подскажите как решить проблему.
ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.12 и ниже
При проверке метаданных обнаружены ошибки!
11. the1 909 19.12.20 11:10 Сейчас в теме
(10) Повысить режим совместимости конфигурации до 8.3.13
12. user925712 19.12.20 11:18 Сейчас в теме
(11) Не могу снимать с поддержки, обновить не могу, придется переписать много расширений.Видимо придется без подписки на событие искать обход.
13. the1 909 19.12.20 11:24 Сейчас в теме
(12) Можно попробовать вызывать методы общих модулей из расширения из общего модуля конфигурации МодификацииКонфигурацииПереопределяемый, и вызывать их в событии ПриСозданииНаСервере
Если Форма.Параметры.Ключ.Пустая() Тогда
   // ... здесь вызываем автозаполнение
КонецЕсли;
Пишу по памяти, 1С нет под рукой
14. user925712 19.12.20 17:46 Сейчас в теме
(13) Помогло, но Реквизиты = Источник.Метаданные().Реквизиты; вызвал новую ошибку.
Ее удалось частично обойти через ДанныеФормыВЗначение и обратно, но работает для определенного документа и определенных реквизитов. Видимо все-таки придется обновляться. УТ (11.4.11.106) Платформа 8.3.15.1869
15. Atom74 36 24.12.20 14:36 Сейчас в теме
Режим совместимости конфигурации 8.3.14 (КА 2.4.13), но расширение не устанавливается.
"ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.12 и ниже
При проверке метаданных обнаружены ошибки!"
16. the1 909 24.12.20 21:02 Сейчас в теме
17. Atom74 36 25.12.20 07:32 Сейчас в теме
1С:Предприятие 8.3 (8.3.15.1830)
18. the1 909 25.12.20 10:21 Сейчас в теме
(17) Это странно. Можно по удаленке посмотреть веером, в личку напишите
19. user925364 19.01.21 17:54 Сейчас в теме
можно добавить реквизит "Цена включает НДС" ?
20. the1 909 19.01.21 21:49 Сейчас в теме
Проверяли по методе, может он и так доступен?
21. user925364 20.01.21 11:07 Сейчас в теме
24. the1 909 20.01.21 14:28 Сейчас в теме
(21) Зайдите в конфигуратор, в общем модуле расширения зпуНастройкиПользователейПовтИсп замените текст процедуры ДоступныеНастройкиПользователей на
Функция ДоступныеНастройкиПользователей() Экспорт
	
	ДоступныеНастройки = Новый ТаблицаЗначений;
	ДоступныеНастройки.Колонки.Добавить("Настройка",	Новый ОписаниеТипов("Строка"));
	ДоступныеНастройки.Колонки.Добавить("ТипЗначения",	Новый ОписаниеТипов());
	ДоступныеНастройки.Колонки.Добавить("Количество",	Новый ОписаниеТипов("Число"));
	
	Для Каждого Объект Из Метаданные.Документы Цикл
		
		Для Каждого Реквизит Из Объект.Реквизиты Цикл
			
			Если ТипПодходит(Реквизит.Тип) Тогда
				НоваяСтрока = ДоступныеНастройки.Добавить();
				НоваяСтрока.Настройка = Реквизит.Имя;
				НоваяСтрока.ТипЗначения = Реквизит.Тип;
				НоваяСтрока.Количество = 1;
			КонецЕсли;
			
		КонецЦикла;
		
	КонецЦикла;
	
	ДоступныеНастройки.Свернуть("Настройка, ТипЗначения", "Количество");
	ДоступныеНастройки.Сортировать("Количество УБЫВ");
	
	Пока ДоступныеНастройки.Количество() > 50 Цикл
		НоваяСтрока = ДоступныеНастройки[ДоступныеНастройки.Количество() - 1];
		Если НоваяСтрока.Настройка = "ЦенаВключаетНДС" Тогда
			Продолжить;
		КонецЕсли;
		ДоступныеНастройки.Удалить(НоваяСтрока);
	КонецЦикла;
	
	Возврат ДоступныеНастройки;
	
КонецФункции
Показать

Вместо ЦенаВключаетНДС подставьте имя реквизита, как оно задано в конфигураторе.
22. sergeysea 20.01.21 12:50 Сейчас в теме
проблема следующая, во все документы вводимые на основании подставляются значения по умолчанию, а не из документа основания.
23. the1 909 20.01.21 14:22 Сейчас в теме
(22) Реально проблема, надо подумать над этим
31. sergeysea 27.01.21 21:00 Сейчас в теме
(23)Не думали еще над вопросом?
32. the1 909 27.01.21 21:10 Сейчас в теме
33. the1 909 02.03.21 09:19 Сейчас в теме
(31) Выложил обновление по этому поводу.
25. user925364 20.01.21 18:51 Сейчас в теме
не помогло, код добавил но новый параметр не появился(
https://i.paste.pics/03b18f097aed3ea7f8e2dfc31c3817b7.png
28. the1 909 24.01.21 21:51 Сейчас в теме
(25) Сорь, не видел сообщения почему-то. Сразу в голову не пришло, но это видимо булевый реквизит? Если да, тогда дополните код вместо
Если ТипПодходит(Реквизит.Тип) Тогда
написать
Если Реквизит.Имя = "ЦенаВключаетНДС" Или ТипПодходит(Реквизит.Тип) Тогда
26. user1530156 24.01.21 21:27 Сейчас в теме
подскажите пожалуйста подойдет ли данное расширение для 1С:ERP Управление предприятием 2 (2.4.13.57)
27. the1 909 24.01.21 21:42 Сейчас в теме
(26) К сожалению, проверить не на чем. На 2.5 работает.
29. user1530156 24.01.21 21:51 Сейчас в теме
не очень просто хочется платить за абонемент, чтоб скачать расширение, и чтобы оно потом не сработало((
30. the1 909 24.01.21 21:53 Сейчас в теме
34. EvgenAEY 2 07.03.21 07:49 Сейчас в теме
платформа 8.3.16.1148, конфигурация 1т 11.4.13.71 при добавлении сообщение: ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.14 и ниже

Есть в конфигурации 2 расширения совместимость 8.3.14 и 8.3.12 (это расширение не активно)
Вариант тестовый: файловый, рабочий: клиент-сервер

Если использую 8.3.18 платформу то вопросов нет, добавляется работает, пытался в 18 платформе в вашем расширении сменить на 8.3.15 или нв 8.3.14, но все равно при добавлении в конфигурацию на 16 платформе та же ошибка выдается.

Что еще можно сделать чтобы использовать платформу 8.3.16.1148?
35. EvgenAEY 2 10.03.21 04:31 Сейчас в теме
Реализована возможность заимствования подписок на события и создания собственных подписок в расширении. (с) версия 8.3.17

Все что ниже с 1.9 не работает с платформой 8.3.16 и ниже, только выше 17, автор пожалуйста исправьте
36. the1 909 10.03.21 11:00 Сейчас в теме
(35) Попозже время появится, и я проинспектирую расширение, при необходимости внесу изменения в публикацию.
37. VladZel 7 31.03.21 09:56 Сейчас в теме
(36)
Добрый день, скачал расширение 1.9, можно добавить реквизит "Цена включает НДС" в реализации, этого реквизита там еще нет, в целом на моем релизе Управление торговлей, редакция 11 (11.4.13.103) и платформе 1С:Предприятие 8.3 (8.3.18.1208) все работает, спасибо.
38. the1 909 31.03.21 10:01 Сейчас в теме
(37) Добрый! прочтите ветки (19) и (25), должно помочь
39. пользователь 02.04.21 15:26
Сообщение было скрыто модератором.
...
40. пользователь 02.04.21 15:41
Сообщение было скрыто модератором.
...
41. пользователь 23.04.21 11:30
Сообщение было скрыто модератором.
...
42. пользователь 13.05.21 10:35
Сообщение было скрыто модератором.
...
43. пользователь 14.05.21 14:44
Сообщение было скрыто модератором.
...
44. пользователь 26.05.21 17:48
Сообщение было скрыто модератором.
...
45. пользователь 27.05.21 13:34
Сообщение было скрыто модератором.
...
46. Alex1c 19 24.06.21 13:32 Сейчас в теме
Версия 2.0 не работает с УТ 11.4.13.71 платформа 8.3.15.1830. Совместимость 8.3.14
ПодпискаНаСобытие.зпуЗаполнениеДокументаЗначениямиПоУмолчанию: Добавление дочерних объектов этого типа к заимствованным в расширениях недопустимо в режиме совместимости 8.3.12 и ниже
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Новосибирск
зарплата от 90 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 230 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 100 000 руб. до 140 000 руб.
Полный день

Программист 1С
Хабаровск
зарплата от 130 000 руб. до 160 000 руб.
Полный день