Дружелюбный интерфейс итогов в диалоге табличных частей, для Управляемых форм.

0. 196 14.09.20 10:58 Сейчас в теме
Небольшой набор функций и процедур, дающий возможность организовать итоги в подвале табличных частей с учетом быстрого отбора.
Работает только для: табл.частей справочников; табл.частей документов; табл.частей обработок; таблиц значений на форме.
(Обрабатываются колонки, содержащие числовой тип)

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. AnryMc 791 12.04.21 17:18 Сейчас в теме
&НаКлиенте
Процедура ОбновитьИтоги()

    ДанныеТаб = Отчет.ТаблицаФормы1;
	Сумма1 = 0;
	Если Элементы.ТаблицаФормы1.ВыделенныеСтроки.Количество() > 1 тогда
		Для каждого с из Элементы.ТаблицаФормы1.ВыделенныеСтроки цикл
			стр = ДанныеТаб.НайтиПоИдентификатору(с);
			Сумма1 = Сумма1 + стр.СуммаЗатрат;
		КонецЦикла;
	Иначе
		Для каждого стр из ДанныеТаб цикл
			Если Элементы.ТаблицаФормы1.ПроверитьСтроку(стр.ПолучитьИдентификатор()) тогда
				 Сумма1 = Сумма1 + стр.СуммаЗатрат;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	Элементы.ТаблицаФормы1.ПодчиненныеЭлементы.ТаблицаФормы1СуммаЗатрат.ТекстПодвала = Формат(Сумма1,"ЧДЦ=2");
КонецПроцедуры
Показать


ТаблицаФормы (FormTable)
ПроверитьСтроку (CheckRow)
Синтаксис:
ПроверитьСтроку(<Строка>)
Параметры:
<Строка> (обязательный)
Тип: Произвольный.
Строка таблицы. Тип параметра зависит от типа редактируемого значения.
Возвращаемое значение:
Тип: Булево.
Описание:
Проверяет, соответствует ли строка, установленному в таблице отбору.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение (клиент).
Показать


З.Ы. "Что тут думать! Трясти надо!" ©
3. DrZombi 196 13.04.21 12:05 Сейчас в теме
(2) Не нравится, не ешь...
Это статья Архив, пример рабочий. Записки же надо, где то хранить...

А там смотришь, и другие чего к себе подметят :)
4. AnryMc 791 14.04.21 08:40 Сейчас в теме
5. DrZombi 196 14.04.21 10:02 Сейчас в теме
(4) Вы случаем не путаете Итоги, и просто пометку с быстрым отбором?
Это как сравнивать воду в озере и воду в стакане (она там и там мокрая)

С ваших слов - "Зачем она в озере, если есть в стакане" :)

...Дружище, спасибо за ваше замечательное замечание, что кусочки кода в разных статьях повторяются, я учту на будущее это замечание...
7. AnryMc 791 15.04.21 10:37 Сейчас в теме
(5)
...Дружище, спасибо за ваше замечательное замечание, что кусочки кода в разных статьях повторяются, я учту на будущее это замечание..


Прошу обратить внимание что используется одинаковые методы но КОД РАЗНЫЙ. и соответствует заявленому в публикации...
Количество процедур и строк кода на порядок меньше...
Нет передачи данных между сервером и клиентом...

Код есть - можете попробовать - если не работает тогда и возмущайтесь, что я "гоню"...
6. DrZombi 196 14.04.21 10:06 Сейчас в теме
(4)
Так Вы уже продублировали в: Дружелюбный интерфейс пометки и отмены пометки в диалоге табличных полей, для управляемых форм.


Таки дублировал я не кусочки кода, а принцип использования двух различных алгоритмов, для двух различных задач.

...Спасибо что не обвинили меня в плагиате использования русского алфавита... :)
8. DrZombi 196 15.04.21 20:39 Сейчас в теме
(7) Пройди мимо, я не обижусь :)
,..Ваше мнение важно нам...
9. DrZombi 196 15.04.21 20:40 Сейчас в теме
(7) Мужик, я не хочу смотреть на твой код. Просто мне побоку как и что там у тебя. Даже не уговаривай. :)
10. DrZombi 196 15.04.21 20:46 Сейчас в теме
(7) Сынок, что ты несешь? Там два общих модуля, "Серверный" и "Клиентский"
Все остальное копирастишь в свою форму и наслаждаешься трудом мысли чужой головы, не думая, что и как :)

...Не стесняйся, возьми мой код и назови своим, я не жаден, дарю, Брат...
Оставьте свое сообщение
Вопросы с вознаграждением