Проблема с установкой клиентов 1С на Linux

1. PerlAmutor 107 01.08.20 12:05 Сейчас в теме
Добрый день. Пытаюсь поставить клиенты (толстый + тонкий, 32 и 64 бит) на сервер на базе Debian, где крутится сервер 1С 64.
Тонкие клиенты не ставятся, т.к. конфликт с пакетом common от сервера. 32 битные не ставятся никакие, т.к. тоже конфликты зависимостей пакетов. Ставится лишь один 64 битный толстый. Однако когда я пытаюсь запустить лаунчер 1С, то сначала мне предлагается добавить базу 1С, т.к. список баз пуст. Но неважно какую кнопку нажимаешь "Да" или "Нет", диалог закрывается, а процесс остается висеть бесконечно в фоне. Чего ему опять не хватает?
Прикрепленные файлы:
Найденные решения
13. ansh15 02.08.20 02:46 Сейчас в теме
Вендор предлагает создавать первую инфобазу вручную.
Что делать...
Может быть и с запуском сервера приложений, именно на Астре, тоже что-нибудь подобное
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. ---vagus--- 01.08.20 12:18 Сейчас в теме
можете на русском языке сообщить , что вы установили ...

вы хотите без зависимостей запустить 1с ?
у вас 64бит дебиан и 32бит 1с не можете установить ?

крутится чего.....что у вас установлено из 1с ?
3. PerlAmutor 107 01.08.20 12:19 Сейчас в теме
Я поставил сервер 1С и хочу на ту же машину установить все возможные клиенты как для него так и для платформ других версий. На Windows Server с этим проблем не было никогда.
4. ---vagus--- 01.08.20 12:21 Сейчас в теме
ну и к серверу 1с что не ставится ?
начнем с одной версии с сервером
5. PerlAmutor 107 01.08.20 12:24 Сейчас в теме
(4) Поставился лишь один толстый клиент 64 битной версии (той же что и сервер 1С). И он чудит, не хочет мне выводить окно со списком баз после закрытия диалога предлагающего добавить новую базу.

Клиенты других версий платформ не ставятся без пакетов server и common той же версии, что и клиент... Т.е. получается, чтобы поставить толстый клиент другой версии платформы мне надо еще и серверный пакет ставить.
6. ---vagus--- 01.08.20 12:28 Сейчас в теме
(5)
ну да.
можете без зависимостей устанавливать и потом искать, почему не запускается.

инфо в сети много, что нужно для установки 1с на линукс.
в папке opt/1c/.....bin..... запустите из консоли ./1c...... и увидите чего не хватает
7. PerlAmutor 107 01.08.20 12:35 Сейчас в теме
(6) Без зависимостей у меня ничего не устанавливается, т.к. менеджеры пакетов это контролируют. И опять же говорю, все исполнимые файлы запускаются. Без установленных зависимостей не произошло бы даже этого. А вот почему они висят в процессах после одного лишь диалога начального вопрос открытый.
8. ---vagus--- 01.08.20 12:38 Сейчас в теме
Проблема с установкой клиентов 1С на Linux

называется ваш вопрос...

А вот почему они висят в процессах после одного лишь диалога начального вопрос открытый
так что вам интересно ?

убить процессы или почему их так много ?
там ведь кроме 1с много других висит.

не понимаю вас
9. PerlAmutor 107 01.08.20 12:40 Сейчас в теме
(8)
не понимаю вас


Меня интересует где вот это окно

И зачем мне ставить поверх настроенного сервера 1С сервер 1С другой версии только ради того, чтобы поставился толстый клиент другой версии технологической платформы, т.к. пакет server есть в зависимостях. Ну бред же...
Прикрепленные файлы:
10. PerlAmutor 107 01.08.20 12:49 Сейчас в теме
12. PerlAmutor 107 01.08.20 13:38 Сейчас в теме
(11) В общем советы из астры тоже не помогли. Вторая ссылка лишь скрипт делающий тоже самое, что dpkg, разве что там еще иконки добавляются вторые.
13. ansh15 02.08.20 02:46 Сейчас в теме
Вендор предлагает создавать первую инфобазу вручную.
Что делать...
Может быть и с запуском сервера приложений, именно на Астре, тоже что-нибудь подобное
14. PerlAmutor 107 02.08.20 09:17 Сейчас в теме
Спасибо за наводку. Похоже дело именно в релизе 8.3.18.891, т.к. 8.3.17 такого поведения на Астре нет на другой машине. Команда, что дают по указанной вами ссылки должна быть такой:

/opt/1cv8/x86_64/8.3.18.891/1cv8 CREATEINFOBASE File=$HOME/testinfobase /ADDTOLIST testinfobase


Запускать надо от имени пользователя под которым будет запускаться клиент.

Интересно что за предупреждение сыпется в консоль при запуске клиента:

Gtk-WAARNING **: Theme parsing error: gtk.css:3693:13: Not using units is deprecated. Assming 'px'.
Прикрепленные файлы:
Оставьте свое сообщение
Вопросы с вознаграждением