Убрать доступ к панели разделов для пользователя

1. Altez 16.07.20 17:14 Сейчас в теме
Нужен АРМ с 1 кнопкой "Запустить обмен" в типовой конфигурации.
При этом должен быть доступ к типовым объектам на чтение и запись.

Желательно с минимальной правкой конфигурации.

Вариант добавить роль без прав на подсистемы в расширении заставляет тянуть в расширение все объекты основной конфигурации, на которые нужны права, даже неочевидные.
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. rst_filippov 39 16.07.20 22:39 Сейчас в теме
Это в какой конфигурации, можно расширением аккуратно настроить.
3. Altez 254 17.07.20 13:32 Сейчас в теме
(2) Было б познавательно.
Это УТ11.
на текущий момент создал урезанную роль АдминистраторМагазина с новой подсистемой Магазин,
иных ролей на отображение других подсистем в профиле у пользователя нет.

https://i.imgur.com/NlKdTWo.png
Не расширением, но задачу решает.

В идеале: убрать раздел Главное с рекламой,
жестко назначить обработкой рабочего стола обработку обмена с Фронтол.

Экспериментировал с убиранием панелей с помощью настроек пользователя - работает только установка Настроек Раб.стола, возможно, это выход. Подсмотреть в рабочем виде думаю в Рознице в режиме РМК, уже в свободное время.


Процедура ОчиститьИнтерфейс() Экспорт
	Если Рольдоступна("ПолныеПрава") Тогда Возврат КонецЕсли;
	Если Рольдоступна("трсФронтол") Тогда 
		УстановитьПривилегированныйРежим(Истина);
		НастройкиРабСтолаМенеджер = Новый НастройкиНачальнойСтраницы;
        СоставФормМенеджер = НастройкиРабСтолаМенеджер.ПолучитьСоставФорм();
        СоставФормМенеджер.ЛеваяКолонка.Очистить();
        СоставФормМенеджер.ПраваяКолонка.Очистить();
        СоставФормМенеджер.ЛеваяКолонка.Добавить("Обработка.трсОбменСФронтол.Форма.ОбменСФронтол");
        НастройкиРабСтолаМенеджер.УстановитьСоставФорм(СоставФормМенеджер);
        НастройкиИнтерфейсаМенеджера = Новый НастройкиИнтерфейсаКлиентскогоПриложения;
        СоставИнтерфейсаМенеджер = НастройкиИнтерфейсаМенеджера.ПолучитьСостав();
        СоставИнтерфейсаМенеджер.Верх.Очистить(); // панель инструментов убираем
        СоставИнтерфейсаМенеджер.Лево.Очистить();
        СоставИнтерфейсаМенеджер.Право.Очистить();
        СоставИнтерфейсаМенеджер.Низ.Очистить();
        СоставИнтерфейсаМенеджер.Низ.Добавить(Новый ЭлементНастройкиСоставаИнтерфейсаКлиентскогоПриложения("ПанельОткрытых"));
        НастройкиИнтерфейсаМенеджера.УстановитьСостав(СоставИнтерфейсаМенеджер);

        ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиНачальнойСтраницы",,НастройкиРабСтолаМенеджер,,); 
        ХранилищеСистемныхНастроек.Сохранить("Общее/НастройкиИнтерфейсаКлиентскогоПриложения",,НастройкиИнтерфейсаМенеджера,,);
		УстановитьПривилегированныйРежим(Ложь);

	КонецЕсли;	
КонецПроцедуры	
Показать

(2)
4. rst_filippov 39 17.07.20 13:43 Сейчас в теме
(3) Буду писать статью.
Оставьте свое сообщение
Вопросы с вознаграждением