1. digorec88 30.06.20 13:11 Сейчас в теме

Отправка звукового уведомления на мобильные устройства при проведении документа

Всем привет. Кто подскажет. Как можно организовать следующее.
Нужно настроить отправку звукового уведомления на мобильные устройства при проведении документа.
Сейчас на МУ-ствах установлен мобильный клиент.

На одном МУ создали документ. На остальных должно прийти уведомление звуковое(любой звук).
Ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
2. coollerinc 40 30.06.20 13:39 Сейчас в теме
Сделать регистр сведений, в котором будет при проведенении документа добавляться запись, что бы подать сигнал. В измерении добавить ИД пользователя или устройства, у которых должно сигналить. На самих устройствах включить обработчик ожидания который будет проверять, есть ли для них что то в этом регистре. Это простое и рабочее решение. Возможно можно на мобильного клиента кидать пуш, но это нужно разбираться со сторонними сервисами пушей, например от Гугла. И нужен будет обязательный доступ в интернет(только по wi-fi работать не будет).
3. digorec88 30.06.20 13:52 Сейчас в теме
(2)
На самих устройствах включить обработчик ожидания который будет проверять, есть ли для них что то в этом регистре


На этом месте можно пж-та по подробнее. Где конкретно это настраивается
4. coollerinc 40 30.06.20 15:06 Сейчас в теме
Можно в модуле приложения добавить, либо на конкретной форме

ПодключитьОбработчикОжидания (AttachIdleHandler)
Синтаксис:
ПодключитьОбработчикОжидания(<ИмяПроцедуры>, <Интервал>, <Однократно>)
Параметры:
<ИмяПроцедуры> (обязательный)
Тип: Строка.
Имя экспортируемой процедуры модуля приложения (модуля обычного приложения) или глобального общего модуля.
Процедура должна располагаться на клиенте.
Процедура не должна содержать параметров.
<Интервал> (обязательный)
Тип: Число.
Интервал времени в секундах с точностью до 1/10 секунды, через который будет осуществляться вызов процедуры (положительное число).
Если указано значение меньше 1, то значение третьего параметра должно быть равно Истина.
Внимание! Не следует использовать данный обработчик в качестве таймера. Фактический интервал срабатывания может отличаться от указанного.
<Однократно> (необязательный)
Тип: Булево.
Признак однократного выполнения обработчика ожидания.
Истина - указанный обработчик ожидания будет выполнен один раз.
Значение по умолчанию: Ложь.
Описание:
Подключает вызов указанной процедуры модуля приложения (модуля обычного приложения) или глобального общего модуля через определенный интервал времени. Вызов будет осуществляться только в "состоянии покоя", то есть в тот момент, когда программа не выполняет никаких действий.
Во время временной блокировки, вызванной методом ЗаблокироватьРаботуПользователя или соответствующей командой "Временная блокировка", обработчики ожидания не выполняются.
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, толстый клиент, мобильное приложение (клиент).
Примечание:
Вызов обработчика ожидания продолжается, пока система не завершит работу или пока не будет вызван метод глобального контекста ОтключитьОбработчикОжидания.
Пример:
Процедура ОтчетОпродажахЗаДень()
// ...

КонецПроцедуры

//...

ПодключитьОбработчикОжидания("ОтчетОпродажахЗаДень", 60); // каждую минуту
5. digorec88 01.07.20 08:41 Сейчас в теме
А нельзя получить список активных пользователей обойти их циклом Для Каждого , добавить условие "Если МобильныйКлиент Тогда", и после условия
СредстваМультимедии.ВоспроизвестиЗвуковоеОповещение(ЗвуковоеОповещение.ПоУмлочанию).

Т.е один пользователь нажал кнопку готово на МУ,документ создался, и после этого добавить вышесказанное.
6. digorec88 01.07.20 08:44 Сейчас в теме
&НаКлиенте
Процедура Готово(Команда)

ГотовоНаСервере();
#Если МобильныйКлиент Тогда

СредстваМультимедиа.ВоспроизвестиЗвуковоеОповещение(ЗвуковоеОповещение.ПоУмлочанию)
// вот добавить обход циклом списка пользователей и проверять на активность и на вид приложения
#КонецЕсли

КонецПроцедуры
7. digorec88 01.07.20 08:46 Сейчас в теме
Т.е не подключать обработчик ожидания, а сразу посылать звуковое уведомление на все мобильные устройства при создании документа
8. coollerinc 40 02.07.20 11:14 Сейчас в теме
"сразу посылать звуковое уведомление на все мобильные устройства при создании документа"
(7) как вы это сделаете?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Ведущий программист 1С (УТ 11)
Москва
зарплата до 200 000 руб.
Полный день