1. SanchoD 187 29.06.20 22:41 Сейчас в теме

Печать вложенных файлов в УТ 11?

Приветствую, коллеги!

Ситуевина, используя типовой функционал БСП, к документам прикрепляют файлы сканов сертификатов. Можно открыть список прикрепленных к документу файлов и открыть/распечатать. А как бы это сделать в одном флаконе при печати накладных из этого документа? Т.е. юзер выбирает в документе печать ТОРГ-12 (например) и печатается сама ТОРГ-12 и сканы, прикрепленные к документу.
Ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
6. andy_zhav 173 30.06.20 09:28 Сейчас в теме
(1) Я сделал у себя настраиваемый комплект документов по договору. В настройках можно выбрать, какие виды присоединенных файлов нужно отправлять. На инфостарте выложил, но в урезанном варианте - без вложенных файлов.
Прикрепленные файлы:
7. andy_zhav 173 30.06.20 09:30 Сейчас в теме
(6) Все что ниже счета фактуры - прикрепленные сканы.
Вот так настройка выглядит. Слева печатные формы, справа - присоединяемые файлы
Прикрепленные файлы:
2. user633533_encantado 7 29.06.20 23:06 Сейчас в теме
Внешняя печатная форма взамен Торг12.
3. SanchoD 187 29.06.20 23:27 Сейчас в теме
(2) Допустим. Каким образом выведя на печать ТОРГ-12, распечатать и файлы (doc, pdf и т.д.)?
9. andy_zhav 173 30.06.20 11:45 Сейчас в теме
(3) Если БСП то
РаботаСФайламиКлиент.НапечататьИзПриложенияПоИмениФайла(ИмяФайлаПечатнойФормы);


Если Не БСП то добавьте процедуру печати:

// Выполняет печать файла внешним приложением.
//
// Параметры
//  ИмяОткрываемогоФайла - Строка - полное имя файла.
//
Процедура НапечататьИзПриложенияПоИмениФайла(ИмяОткрываемогоФайла, ИмяПринтера = "") Экспорт
	
	Если Не ЗначениеЗаполнено(ИмяОткрываемогоФайла) Тогда
		Возврат;
	КонецЕсли;
		
	СистемнаяИнфо = Новый СистемнаяИнформация;
	Если СистемнаяИнфо.ТипПлатформы = ТипПлатформы.Windows_x86 
	 Или СистемнаяИнфо.ТипПлатформы = ТипПлатформы.Windows_x86_64 Тогда
		Shell = Новый COMОбъект("Shell.Application");
		Если ПустаяСтрока(ИмяПринтера) Тогда
			Shell.ShellExecute(ИмяОткрываемогоФайла, "", "", "print", 1);
		Иначе
			Shell.ShellExecute(ИмяОткрываемогоФайла, ИмяПринтера, "", "printto", 1);
		КонецЕсли;
	КонецЕсли;
	
КонецПроцедуры
Показать
10. SanchoD 187 30.06.20 16:30 Сейчас в теме
4. muskul 30.06.20 01:42 Сейчас в теме
Надо все делать "по науке" сертификат привязать к номенклатуре (можно один к группе номенклатуре) и потом печатать реестр сертифкатов как на каждую так и общий.
5. SanchoD 187 30.06.20 08:55 Сейчас в теме
(4) А если абстрагироваться от того, что к чему надо привязывать?
Есть документ (Реализация), к нему прикреплен файл (несколько файлов).
Как вызвать печать этих файлов одновременно с печатью какой-либо печатной формы?
8. oleg-x 14 30.06.20 10:09 Сейчас в теме
Не знаю, может что то изменилось сейчас. Но еще пару лет назад делали подобную задачу.
Если формат файла JPG, то можно распечатать сделав печатную форму.
А если любые форматы, тогда возникает проблема. Тот же PDF просто так не распечатаешь, нужно устанавливать сторонние программы/компоненты и печатать через них.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Ведущий программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Ведущий программист 1С (УТ 11)
Москва
зарплата до 200 000 руб.
Полный день