1. webaristan 29.06.20 14:59 Сейчас в теме

Как определить в двух строковых типах большее число

Подскажите пожалуйста, заранее благодарен.
В двух строковых полях разные числа типа IP адреса: 245.120.243.567 и к примеру 299.125.40.69. Как определить в другом текстовом поле большее число.

Подскажите где посмотреть пример или код, ну или описание этого метода обработки кода.
Благословений всем.
Ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
2. EVKash 7 29.06.20 15:13 Сейчас в теме
(1) Без проверки входных данных как то так можно
ПервоеБольше = ?(Число(СтрЗаменить(ПервыйИП, ".", "")) > Число(СтрЗаменить(ВторойИП, ".", "")), Истина, Ложь);
3. EVKash 7 29.06.20 15:56 Сейчас в теме
(1) А вообще-то нет... октеты же надо сравнивать. Иначе 254.1.1.1 будет меньше 1.254.254.254
Тогда так
	ПервыйИП = "254.1.1.1";
	ВторойИП = "1.254.1.1";

	МассивИП1 = СтрРазделить(ПервыйИП, ".");
	МассивИП2 = СтрРазделить(ВторойИП, ".");

	Для Индекс = 0 По 3 Цикл
		
		Октет1 = Число(МассивИП1[Индекс]);
		Октет2 = Число(МассивИП2[Индекс]);
		
		Если Октет1 = Октет2 Тогда
			Если Индекс = 3 Тогда
				Сообщить("IP равны");
			КонецЕсли;
			Продолжить;
		ИначеЕсли Октет1 > Октет2 Тогда
			Сообщить("Первый IP больше");
			Прервать;
		Иначе
			Сообщить("Второй IP больше");
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
Показать
4. webaristan 29.06.20 17:43 Сейчас в теме
(3)Числа заранее неизвестны. При вводе в разные два текстовые поля в третьем текстовом поле должен быть результат сравнения
5. EVKash 7 29.06.20 20:44 Сейчас в теме
(4) Что значит "Числа заранее неизвестны."?
Если в текстовой строке просто число, то перевести в число просто - Число(ВашаСтрока)
Если формат строки неизвестен, то это к гадалкам.
Для IP адресов пример я вам дал.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Ведущий программист 1С (УТ 11)
Москва
зарплата до 200 000 руб.
Полный день