HTTP сервисы по OpenAPI спецификациям

0. 243 29.06.20 14:58 Сейчас в теме
Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. cprit 637 29.06.20 19:59 Сейчас в теме
Спасибо. То чего давно не хватало
Если автор не против, включу в универсальные инструменты 1С https://github.com/cpr1c/tools_ui_1c. Лицензия в репозитории позволяет
2. shmalevoz 243 29.06.20 20:15 Сейчас в теме
(1) Конечно не простив, включайте. У вас кстати ссылка битая. Верна https://github.com/cpr1c/tools_ui_1c
3. cprit 637 29.06.20 20:16 Сейчас в теме
(2) Видимо из-за скобок было. Поправил комментарий
4. Xershi 1245 29.06.20 22:18 Сейчас в теме
Насколько я понял это сервис, который 1 раз опубликовал и дальше пилишь справочники в предприятии и сразу генерируется документация?
У самого была такая идея, но не было задач для реализации конечного варианта.
Единственное авторизация есть на уровне сервиса или пилится кодом?
Аналогично разделение прав?
5. shmalevoz 243 29.06.20 22:46 Сейчас в теме
(4) Это прослойка между входящим запросом и конечным функционалом расположенным в обработках. Может обслуживать произвольное количество сервисов конфигурации. Для каждого сервиса своя спецификация.
На входе нужны
1. HTTP сервис, достаточно одного ресурса сервиса с шаблоном /* и одной конечной точкой с обработкой любого http метода. Обработчик точки может содержать только Возврат оас_Сервис.Ответ(Запрос)
2. Спецификацию OpenAPI v3 в формате json. Делается визуальными редакторами/руками
В обработке управления загружаем спецификацию, получаем шаблоны модулей конечных обработок. Создаем обработки, копируем шаблоны для конечных точек, наполняем их смыслом. Назначаем вызовы созданных обработок для конечных точек сервиса.
Расширение выполняет контроль соответствия входящего запроса загруженной спецификации. Единая точка проверки. И далее по настройкам вызывает конечные обработки реализующие логику точек. Есть события ПередОбработкойЗапроса, ПослеОбработкиЗапроса, обработчики назначаемы. Плюс на основании спецификации формирует документацию в распространенном юзерфрендли формате. Конечную логику (авторизацию) не изменяет.
Справочники не использует, все хранится в ХранилищеСистемныхНастроек
JohnyDeath; +1 Ответить
6. Xershi 1245 30.06.20 10:37 Сейчас в теме
(5) я так понимаю сделано чтобы снизить совместимость решения?
Лучше тогда сделать 3 варианта, конфигурация до 8.3.6, хранилище до момент использования справочников 8.3.11 и использование справочников в расширении.
Для заметок сделал публикацию Эволюция расширения конфигурации. С 8.3.11 доступно создавать свои справочники, а сейчас типовые уже 8.3.12+.
7. shmalevoz 243 30.06.20 10:52 Сейчас в теме
(6) Не вижу смысла пилить справочники для хранения набора условно константных соответствий с текстовым содержанием. Тем паче это данные расширения. Для этих целей очень неплохо подходит ХранилищеНастроек, как раз они там и хранятся. А совместимость с 8.3.9 сложилось достаточно исторически, при разработке базовых зависимостей, не помню уже какой там метод использовался, надо тесты запускать на младших платформах.
Относительно решения в конфигурации, то расширение в конфигурацию конвертируется легко - в Configuration.xml расширения меняется узел <Properties> на узел из конфигурации и загружается из файлов. Получается готовая конфигурация. Работающим на старых релизах + полчаса работы с перекурами.
8. botokash 281 30.06.20 11:03 Сейчас в теме
(7) А как происходит миграция загруженных настроек работы сервиса в РИБ?
9. Xershi 1245 30.06.20 11:25 Сейчас в теме
(8) судя из ответов автора никак. РИБ же переносит только пользовательские данные. А "ХранилищеНастроек" это служебные.
10. shmalevoz 243 30.06.20 11:32 Сейчас в теме
(9) Да, на РИБ текущая реализация не рассчитана, понадобится модификация чтения/записи настроек. Надо будет в будущем сделать адаптер хранения настроек чтобы управлять этим делом.
11. Xershi 1245 30.06.20 11:33 Сейчас в теме
(10) перейдя на 1 и 3 вариант это не понадобится.
12. shmalevoz 243 30.06.20 11:36 Сейчас в теме
(11) Как раз использование адаптера позволит не менять расширение, а вызывать необходимую выбранную реализацию хранения.
14. Xershi 1245 30.06.20 11:39 Сейчас в теме
(12) в любом случае хранение через справочники надежнее. Если инфа в хранилище побьется или будет удалена не очень приятно будет)
18. shmalevoz 243 01.07.20 10:17 Сейчас в теме
(14) В свежей версии появился адаптер хранения настроек, можно использовать любую собственную реализацию хранилища
17. shmalevoz 243 01.07.20 10:16 Сейчас в теме
(8) Теперь можно хранить настройки где угодно - делаем обработку с интерфейсом как в оас_НастройкиХранилищеСистемныхНастроек, выбираем ее адаптером хранения настроек в ОМ. Управление адаптерами (вид ОАС. Хранение настроек) и управление по чтению/записи настроек передается на нее. А там уж где хоть справочник, хоть регистр сведений, что угодно
13. shmalevoz 243 30.06.20 11:37 Сейчас в теме
А там уж кто какую схему хранения использует это дело хозяйское =)
15. malikov_pro 729 30.06.20 14:58 Сейчас в теме
в модуле опечатка, style по идее.

Буду рад если поделитесь опытом ведения проекта в git и его сборки.
16. shmalevoz 243 30.06.20 15:09 Сейчас в теме
19. shmalevoz 243 01.07.20 10:21 Сейчас в теме
(15) Не вопрос, поделюсь. Только вопрос больно расплывчатый. В личку пожалуйста, кажется вопрос объемен и лучше там обменяться контактами
20. zavbak 10.03.21 04:45 Сейчас в теме
Добрый день!
Падает по ошибке.

Пользователи	= ом_Значение.СвойствоПолучить(Настройки, "Пользователи", Новый Соответствие());

// Т.К. в ЕРП существует модуль. Пользователи. И он переменную воспринимает как модуль и не может записать.


// Сохранение настроек. Раздельно по регионам использования
//
// Параметры: 
// 	Регион - Строка - Регион использования адаптеров
// 	Настройки - Структура - Сохраняемые настройки
//
Процедура Сохранить(Регион, Настройки) Экспорт
	
	#Если Сервер Тогда
		Если лг_Подсистема.АдминистрированиеДоступно() Тогда
			УстановитьПривилегированныйРежим(Истина);
			Коллекция	= ХранилищеСистемныхНастроек.Загрузить(ОбъектКлюч()
			, НастройкаКлюч()
			, 
			, ПользовательИмя());
			Коллекция		= ?(ом_Значение.СоответствиеЭто(Коллекция), Коллекция, Новый Соответствие());
			// Сами настройки храним фиксированными структурами
			Пользователи	= ом_Значение.СвойствоПолучить(Настройки, "Пользователи", Новый Соответствие());
			Если ом_Значение.СоответствиеЭто(Пользователи) Тогда
				Пользователи	= Новый ФиксированноеСоответствие(Пользователи);
			Иначе
				Если НЕ ом_Значение.ФиксированноеСоответствиеЭто(Пользователи) Тогда
					ВызватьИсключение лг_ПодсистемаТексты.МетодПараметрСтруктураОшибка();
				КонецЕсли;
			КонецЕсли;
			Хранение	= Новый Структура(Умолчание());
			ЗаполнитьЗначенияСвойств(Хранение, Настройки);
			Хранение.Вставить("Пользователи", Пользователи);
			Хранение	= Новый ФиксированнаяСтруктура(Хранение);
			Коллекция.Вставить(РегионИмя(Регион), Хранение);
			ХранилищеСистемныхНастроек.Сохранить(ОбъектКлюч()
			, НастройкаКлюч()
			, Коллекция
			, 
			, ПользовательИмя());
			ОбновитьПовторноИспользуемыеЗначения();
		Иначе
			ВызватьИсключение лг_ПодсистемаТексты.АдминистрированиеЗапрещено();
		КонецЕсли;
	#Иначе 
		ВызватьИсключение лг_ПодсистемаТексты.СредаВыполненияФункционалНедоступен();
	#КонецЕсли
	  
КонецПроцедуры // Сохранить
Показать
22. zavbak 17.09.21 04:39 Сейчас в теме
21. o.nikolaev 204 24.04.21 19:52 Сейчас в теме
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 100 000 руб.
Полный день

Программист 1С: ЗУП
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Разработчик 1C: ERP (Блоки: Снабжение, закупки, склад; Финансы и казначейство)
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день