1. user1383315 24.03.20 15:00 Сейчас в теме

Подстановка цены при выборе товара и типа цен

&НаСервереБезКонтекста
Функция ПолучитьЦенуНоменклатуры(Номенклатура)экспорт
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Номенклатура,
| ЦеныНоменклатурыСрезПоследних.ТипЦен,
| ЦеныНоменклатурыСрезПоследних.Цена
|ИЗ
| РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних";
//Параметры запроса
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);// Номенклатура
Запрос.УстановитьПараметр("ТипЦен",справочники.ТипЦен);// Типы цен номенклатуры


ЦеныНоменклатуры = Запрос.Выполнить().Выгрузить();

Если ЦеныНоменклатуры <> 0 Тогда
Возврат ЦеныНоменклатуры.Цена;
иначе
возврат 0;
КонецЕсли;
//Возврат ЦеныНоменклатуры.Цена
КонецФункции










и





&НаКлиенте
процедура ТоварыТоварПриИзменении(Элемент)
Текущие=элементы.Товары.ТекущиеДанные;
//ТекущиеДанные.Цена=ПолучитьЦенуНоменклатуры();
ПолучитьЦенуНоменклатуры(Текущие.Номенклатура);
КонецПроцедуры
Ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
3. alex-l19041 8 24.03.20 15:10 Сейчас в теме
(1)
Запрос.УстановитьПараметр("ТипЦен",справочники.ТипЦен)
- это зачем ???
4. user1383315 24.03.20 15:11 Сейчас в теме
6. alex-l19041 8 24.03.20 15:13 Сейчас в теме
(4) объясните подробнее каким образом надо выбрать тип цены
7. user1383315 24.03.20 15:17 Сейчас в теме
(6)в документе установка цен раставляются типы цен и их цена
это фиксируется в регистре сведений. Нужно чтобы при выборе товара в табличной части и типа цен в шапке, в табличной части выводилась цена товара по типу цен
8. user1383315 24.03.20 15:20 Сейчас в теме
9. alex-l19041 8 24.03.20 15:21 Сейчас в теме
(7) значит надо передавать тип цены как параметр функции
Функция ПолучитьЦенуНоменклатуры(Номенклатура, ТипЦены)


и в запросе надо добавить условия виртуальной таблицы по номенклатуре и типу цены
10. user1383315 24.03.20 15:22 Сейчас в теме
(9)
значит надо передавать тип цены как параметр функции

Как это написать
11. user1383315 24.03.20 15:30 Сейчас в теме
(10)
(9)
нуНоме

Реализовал условаие вот так
&НаСервереБезКонтекста
Функция ПолучитьЦенуНоменклатуры(Номенклатура)экспорт
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Номенклатура,
| ЦеныНоменклатурыСрезПоследних.ТипЦен,
| ЦеныНоменклатурыСрезПоследних.Цена
|ИЗ
| РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних
|ГДЕ
| ЦеныНоменклатурыСрезПоследних.Номенклатура = &Номенклатура
| И ЦеныНоменклатурыСрезПоследних.ТипЦен = &ТипЦен";
//Параметры запроса
Запрос.УстановитьПараметр("Номенклатура",Номенклатура);// Номенклатура
Запрос.УстановитьПараметр("ТипЦен",справочники.ТипЦен);// Типы цен номенклатуры


ЦеныНоменклатуры = Запрос.Выполнить().Выгрузить();

Если ЦеныНоменклатуры <> 0 Тогда
Возврат ЦеныНоменклатуры.Цена;
иначе
возврат 0;
КонецЕсли;
//Возврат ЦеныНоменклатуры.Цена
КонецФункции
13. alex-l19041 8 24.03.20 15:51 Сейчас в теме
(11)
Запрос.УстановитьПараметр("ТипЦен",справочники.ТипЦен)
- какой смысл в передаче справочника как параметра запроса ? надо передавать одно значение
12. user1383315 24.03.20 15:36 Сейчас в теме
(9)При записи товара в табличную часть пишет что "поле объекта не обнаружено (номенклатура)"
2. user834357 29 24.03.20 15:04 Сейчас в теме
Не совсем понятно в чем вопрос, но предположу, к примеру, что вместо
Если ЦеныНоменклатуры <> 0 Тогда
Возврат ЦеныНоменклатуры.Цена;
иначе
возврат 0;
КонецЕсли;
//Возврат ЦеныНоменклатуры.Цена
КонецФункции

Нужно
Если ЦеныНоменклатуры.Количество() <> 0 Тогда
Возврат ЦеныНоменклатуры[0].Цена;
иначе
возврат 0;
КонецЕсли;
//Возврат ЦеныНоменклатуры.Цена
КонецФункции
5. user1383315 24.03.20 15:12 Сейчас в теме
(2)вопрос состоит в том что при выборе товара и типа цен подставлялась цена
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Product Owner (Менеджер по продукту 1С)
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день

Тим лид по разработке 1С (Team Lead 1С)
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Новосибирск
зарплата от 30 000 руб.
Временный (на проект)

Программист 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день