1. Mister_1C 23.03.20 22:27 Сейчас в теме

Авторизация на сайте

Здравствуйте, помогите доработать авторизацию. Вот есть пример. Думал что он проходит. Но в HTML коде нашел что нет.
Заранее спасибо!!!
Процедура КнопкаВыполнитьНажатие(Кнопка)
	// Вставить содержимое обработчика.
	Соединение = Новый HTTPСоединение("www.della.ru",443,Логин,Пароль,,,Новый ЗащищенноеСоединениеOpenSSL());
	Запрос = Новый HTTPЗапрос("/"); 
    Результат = Соединение.Получить(Запрос);
    Если Результат.КодСостояния = 200 Тогда
   	А = Результат.ПолучитьТелоКакСтроку(); 
    Поз	 			= Найти(А,"<td>");                                    
	Поз1			= Найти(А,"</td>");
    Если Поз>0 Тогда
    Стр				= СокрЛП(Сред(А, Поз,Поз1-Поз ));
    КонецЕсли;
    //КонецЦикла; 
    КонецЕсли;

КонецПроцедуры
Показать
Ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
2. starik-2005 2021 23.03.20 23:34 Сейчас в теме
POST
login_mode=enter&login=XXX&password=YYY
3. Mister_1C 24.03.20 09:13 Сейчас в теме
(2)
POST
login_mode=enter&login=XXX&password=YYY

Куда это? и это не зависимо от структуры сайта?
4. starik-2005 2021 24.03.20 10:29 Сейчас в теме
(3) на данном сайте так авторизация происходит - можно в консоли браузера посмотреть (F12).
5. Mister_1C 24.03.20 14:49 Сейчас в теме
(4) Получается так?
Запрос.УстановитьТелоИзСтроки("login_mode=enter&login=XXX&password=YYY");
6. Mister_1C 24.03.20 15:03 Сейчас в теме
(4)
Результат = Соединение.ОтправитьДляОбработки(Запрос);

Все равно не прошло.
7. Mister_1C 24.03.20 15:13 Сейчас в теме
(4)
Результат = Соединение.ВызватьHTTPМетод("POST", Запрос);

Так тоже не работает.
8. Mister_1C 25.03.20 21:30 Сейчас в теме
Помогите, пожалуйста. Вопрос не закрыт.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Новосибирск
зарплата от 30 000 руб.
Временный (на проект)

Программист 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Специалист внедрения и сопровождения 1С
Москва
зарплата от 80 000 руб.
Полный день