Как отключить окно запроса интернет поддержки

1. FreeArcher 162 27.02.20 04:46 Сейчас в теме
Приветствую!

Собственно вопрос, как отключить окно запроса подключения интернет поддержки?

На вопрос, что надо приобретать ИТС клиент ответил так, и я с ним согласен: Он не пользуется услугами фирмы 1С, он не обновляет конфигурацию, доработки выполняет сторонними программистами. Зачем ему ИТС.

Окно появляется каждые минут 15. Все бы ничего, но если это происходит во время пробития чека, то возникает сбой.

Конфа розница 2, платформа 16.

Подскажите, может кто-нибудь выпиливал этот запрос к ИТС?
По теме из базы знаний
Вознаграждение за ответ
Показать полностью
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
3. ZergKRSK 130 27.02.20 07:22 Сейчас в теме
(1)
доработки выполняет сторонними программистами

логично было бы к ним и обратиться. Выпилить думаю можно.
Adilgeriy; +1 Ответить
4. EVKash 16 27.02.20 09:50 Сейчас в теме
(1) не выпиливается он. в платформу зашит.
5. FreeArcher 162 27.02.20 09:59 Сейчас в теме
(4) Точно? Я тогда покажу комментарий и скажу чтобы от меня отстали :)
6. user633533_encantado 11 27.02.20 10:17 Сейчас в теме
(4)
(5)

Мне кажется нет. У меня есть самописные конфы итам такие окна не беспокоят. Хотя может именно от версии платформы зависит.
41. ybatiaev 59 10.01.23 19:47 Сейчас в теме
(4) не в платформу точно. Мои самописные конфигурации ни у кого не требуют ввода логина и пароля от ИТС. Тут скорее всего внедрена БСП и она использует запросы по ресурсам "1С". Просишь инфу от 1С - плати по счетам ))))))
Но это только предположение )
7. ishelper 27.02.20 10:27 Сейчас в теме
(1)
кто-нибудь выпиливал этот запрос к ИТС?
Выпиливали, и даже тут, на Инфостарте, но не все публикации дожили до настоящего времени, из оставшихся в живых: https://infostart.ru/public/270662/

Будет ли работать на свежей платформе/конфигурации - ХЗ.
starik-2005; HAMAZ; +2 Ответить
9. HAMAZ 7 27.02.20 20:45 Сейчас в теме
(7) код из публикации работает на
1С:Предприятие 8.3 (8.3.15.1830) и
1С:ERP Управление предприятием 2 (2.4.8.63)
12. Xershi 1505 28.02.20 12:15 Сейчас в теме
(1) раз у вас типовая, то вам нужно ввести логин и пароль. Либо выпилить обработки.
Второй момент не типовые конфигурации проверяются на лицензирование платформой.
Там уже посложнее, но если ввести логин и пароль от ИТС, на котором была куплена коробка проблемы уйдут, а вот если пираты=)))
Тогда все сложнее, так что конкретизируйте вопрос!
15. Константин С. 671 02.03.20 08:43 Сейчас в теме
16. FreeArcher 162 02.03.20 09:09 Сейчас в теме
(15) (7) Это решение по отключению окна, которое появляется при старте. Его я уже убрал. Но есть ещё запросы, которые появляются каждые минут 15-20 и откуда они вызываются я не нашел.
17. Константин С. 671 02.03.20 11:47 Сейчас в теме
(16)
Глянь Права, убери Полные.
25. Begemot39 31 09.01.23 00:26 Сейчас в теме
(1)
Приветствую!


сделай регистрацию на портале ИТС и пропиши логин с паролем в окошке. больше не появится.
(бонус - добавить свою 1С в свой же ЛК. конверт с белым письмом)

при запуске будет писать, что "нет договора ИТС" - ну он ведь вам и не нужен, верно?)

изи, 5 мин, без напильника.
EvgeniyOlxovskiy; +1 Ответить
51. karamazoff 112 11.06.24 23:35 Сейчас в теме
(1)
На вопрос, что надо приобретать ИТС клиент ответил так, и я с ним согласен

ну можно же купить версию техно, это копейки, стоит ли работать с такими клиентами, которые не могут себе позволить подписку? А если ломать, то это другой ресурс
54. Kanigin 17.06.24 09:41 Сейчас в теме
(51) Интересно бы узнать, во сколько обошлись работы по "устранению" окна и сопоставимы ли они со стоимостью приобретения подписки?
2. qzr787 27.02.20 05:19 Сейчас в теме
Если программа лицензирована, просто вбиваете логин пароль от портала 1с, и рег номер, далее не будет выскакивать, в мониторе будет просто что итс нет
EvgeniyOlxovskiy; ASKiselev; ybatiaev; EVKash; +4 Ответить
8. mazechild 27.02.20 11:12 Сейчас в теме
Что-то я ничего подобного на 16 платформе не встречал. Хотя ситуации по обслуживанию конфы без ИТС встречаются часто. Мне кажется, что это настройка какая-то.
Где-нибудь в разделе "Администрирование"->"Интернет-поддержка и сервисы" и там выключить всё по максимуму.
10. Online-Ufa 27.02.20 20:55 Сейчас в теме
Какая проблема подключить интернет-поддержку?
11. ErshKUS 2 28.02.20 10:59 Сейчас в теме
(10) Проблема в том, что человек за частую, не любит когда его принуждают и долбают. А еще веселит реклама в купленной конфигурации, причем некоторая еще как уведомления сделана, т.е. выскакивает не только при начале работы (встречал в новой БП)
13. FilippovRI 74 01.03.20 11:25 Сейчас в теме
(11) Потому что получаете вы право работать и автоматизировать свой учет за счет решения 1С
14. Online-Ufa 01.03.20 19:12 Сейчас в теме
(11) Смысл ответа был в том, что если обновления не требуются, то можно ввести логин и пароль от портала и тогда предложение подключить интернет-поддержку больше появлятся не будет. Отсутствие подписки ИТС в этом случае проблемой не является.
Не уверен, что обсуждение того "что человек за частую, не любит когда его принуждают и долбают" чем-то поможет автору вопроса.
Fox-trot; +1 Ответить
18. w-w-w-w- 05.03.20 11:25 Сейчас в теме
Во всех конфигурациях 1С есть в Администрирование - Интернет поддержка и сервисы. Там выбираем Обновление версии программы. В этом разделе есть три варианта Автоматическая проверка обновлений с тремя вариантами выбора - 1)Отключена, 2) При запуске программы 3) По заданному расписанию
Вам подходит первый вариант - не будет проверять ничего и сравнивать с тем что у Вас есть.
Artyom_Potapov; erq@list.ru; ybatiaev; CaSH_2004; Sergitax; +5 Ответить
19. пользователь 26.08.21 09:11
Сообщение было скрыто модератором.
...
20. progr-2008 118 05.10.21 10:53 Сейчас в теме
(18)Для копии УПП появилось после обновления.
21. GranD1c 14.03.22 16:19 Сейчас в теме
Хотел найти решение, но не вышло) Пришло самому думать, решение простое, на самом деле - берем общую форму ПодключениеИнтернетПоддержки и ПриСозданииНаСервере ставим отказ. Готово)
mikeA; xoisim; 1Cynep4eJIoBek; +3 Ответить
22. kuzmina_ann 25 07.01.23 16:49 Сейчас в теме
Добрый день, подскажите, пожалуйста, а где именно ставить Отказ?

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если ОбщегоНазначения.РазделениеВключено() Тогда
		ВызватьИсключение НСтр("ru = 'Использование Интернет-поддержки недоступно при работе в модели сервиса.'");
	КонецЕсли;
	
	РежимВводаНастроекКлиентаЛицензирования = Параметры.РежимВводаНастроекКлиентаЛицензирования;
	Если РежимВводаНастроекКлиентаЛицензирования Тогда
		НастройкиСоединенияССерверами =
			ИнтернетПоддержкаПользователейСлужебныйПовтИсп.НастройкиСоединенияССерверамиИПП();
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Истина);
	ДанныеАутентификации = ИнтернетПоддержкаПользователей.ДанныеАутентификацииПользователяИнтернетПоддержки();
	Если ДанныеАутентификации <> Неопределено Тогда
		Логин = ДанныеАутентификации.Логин;
	КонецЕсли;
	
	Если Не ОбщегоНазначения.ПодсистемаСуществует("ИнтернетПоддержкаПользователей.СообщенияВСлужбуТехническойПоддержки") Тогда
		Элементы.НадписьПоясненияПодключенияАвторизация.Заголовок = СтроковыеФункции.ФорматированнаяСтрока(
			НСтр("ru = 'Введите логин и пароль, которые вы используете на Портале 1С:ИТС. '"));
	КонецЕсли;
	
КонецПроцедуры
Показать

(21)
(21)
23. Torin 783 08.01.23 11:26 Сейчас в теме
(22)
а где именно ставить Отказ?

в любом Отказ = Истина;
24. kuzmina_ann 25 08.01.23 15:01 Сейчас в теме
(23)
Пока сделала вот так, пока окна не вылетают:

Поиск строки "ИнтернетПоддержкаПользователейКлиент.ПередНачаломРаботыСистемы"...

Основная конфигурация Конфигурация.БухгалтерияПредприятия.Модуль приложения(50, 4) : //ИнтернетПоддержкаПользователейКлиент.ПередНачаломРаботыСистемы();

Основная конфигурация ОбщийМодуль.КлиентЛицензирования.Модуль(165, 8) : // См. ИнтернетПоддержкаПользователейКлиент.ПередНачаломРаботыСистемы.

Найдено вхождений: 2

Закомментировать строки внутри этих процедур!!!!
provider; user1734162; ybatiaev; Светлый ум; +4 Ответить
26. kuzmina_ann 25 10.01.23 10:17 Сейчас в теме
(23) Спасибо большое

Может быть еще поможете, как вот это окно в коде отключить или есть другой способ?
Прикрепленные файлы:
28. Torin 783 10.01.23 10:18 Сейчас в теме
29. kuzmina_ann 25 10.01.23 12:59 Сейчас в теме
(28) Теперь вот такое
Прикрепленные файлы:
30. Torin 783 10.01.23 13:05 Сейчас в теме
(29) Ну дак написано куда обратиться и что нужно сделать.
31. kuzmina_ann 25 10.01.23 15:50 Сейчас в теме
(30) Дак я сделала и вот такое окно
32. Torin 783 10.01.23 15:55 Сейчас в теме
(31) подписка ИТС действующая?
33. kuzmina_ann 25 10.01.23 15:56 Сейчас в теме
(32) В том тои дело, что нет
34. Torin 783 10.01.23 16:01 Сейчас в теме
(33) ну тогда какие вопросы? у вас нет действующей подписки , но конфигурация обновлена до последних релизов и вы возмущаетесь почему такое окно отображается? :) Забавно :)
35. kuzmina_ann 25 10.01.23 16:04 Сейчас в теме
(34) Дак я поэтому и спрашиваю: КАК это обойти, если нет подписки!!! Действительно, забавно )))
36. Torin 783 10.01.23 16:09 Сейчас в теме
(35) На ресурсе который принадлежит на половину вендору ( Фирме 1С) .. задавать вопросы нелегального использования .. моветон .. Вы не находите?
38. kuzmina_ann 25 10.01.23 16:12 Сейчас в теме
(36) Читайте посты выше, тут по-моему везде моветон... А лицензия у меня ЕСТЬ, НЕТ ИТС!!!
39. Torin 783 10.01.23 16:25 Сейчас в теме
(38) наличие лицензии не дает право на получение обновлений. А так как у вас конфигурация имеет релиз версии которого выше той когда закончилась подписка , то вы получаете данное уведомление ( это уведомление "вшито" в платформу" ).

Нет подписки? не обновляйтесь и уведомлений не будет. ( выше тема идет когда и лицензия есть и обновлять не требуется , и данные ИТС вносить не хочется)
Alex_E; ASKiselev; ybatiaev; kuzev; user1881120; +5 Ответить
37. пользователь 10.01.23 16:09
Сообщение было скрыто модератором.
...
27. kuzmina_ann 25 10.01.23 10:18 Сейчас в теме
(21) Спасибо большое, может быть еще поможете, как вот это окно в коде отключить или есть другой способ?
Прикрепленные файлы:
40. пользователь 10.01.23 17:26
Сообщение было скрыто модератором.
...
42. Yuanshuai 03.02.23 10:06 Сейчас в теме
Отключаете интернет, запускаете базу, в окне интернет-поддержки вводите любые буквы в логин и пароль.
Поддержка не сможет подключиться и появится окно с настройками подключения.
Внизу окна выбираете настройку "Никогда". Готово.
polax; v3rter; +2 Ответить
46. user1157812 20.06.23 14:26 Сейчас в теме
(42) Интересно, куда пишется "Никогда"?)
47. mspuz 26.12.23 16:34 Сейчас в теме
(42) Помогло, но с одним но - отключил на сервере интернет, прописал любые логин/пароль и все. При проверке выдало ошибку и все.
43. lordguard 37 06.02.23 13:02 Сейчас в теме
44. user1908169 12.02.23 13:16 Сейчас в теме
45. AVKitov 06.06.23 12:29 Сейчас в теме
окно появляется если версия базы свежее последней покупки ИТС, тоесть обновление произведено без покупки ИТС.
Я раз в год покупал месячную ИТС и обновлялся.Если обновиться без покупки ИТС - будет окошко.
48. Горыныч_Злой 19.03.24 07:50 Сейчас в теме
Часто приходиться работать на клиенте с клиентской базой,
и окно «достаёт» своей назойливостью.
Выхожу из положения закомментировав конфигурацию, это не дольше чем
ковырять обработками.
В ЗУП3.1
Прикрепленные файлы:
49. user-z99999 70 19.03.24 09:45 Сейчас в теме
(48)
Найти форму и в ней написать в событии при Открытии, --> Закрыть();
50. user2091954 11.06.24 17:00 Сейчас в теме
52. marik250 15.06.24 07:19 Сейчас в теме
(50) По ссылке новые регистрации отключены, можете поделится обработкой?
53. Asgard90 17.06.24 07:22 Сейчас в теме
Интернет поддержка пользователей, это общая форма, которая вызывается из конфигурации. Судя по сообщениям программа спирачена!
55. argon.87 26.06.24 16:18 Сейчас в теме
(1)
появляется
Можно ввести неправильный логин и пароль от ИТС, тогда 1С не будет показывать окошко, а будет ругаться в другом месте. После зайти в "Интернет-поддержка и сервисы" и нажимаем "отключить".
56. karamazoff 112 27.06.24 08:31 Сейчас в теме
Если лицензия на запуск 1с имеется и надо только окно убрать, то по щелчку - расширение в 2-х общих формах
ПодключениеИнтернетПоддержки
ИнтернетПоддержкаПользователейОшибкаДоступаКИнтернету
позаимствовать и
&НаСервере
Процедура Расш1_ПриСозданииНаСервереВместо(Отказ, СтандартнаяОбработка)
Отказ = Истина;
КонецПроцедуры
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот