0. ipoloskov 76 12.02.20 18:10 Сейчас в теме

Об обновлениях

Рассматриваются вопросы комментирования доработок стандартных конфигураций, необходимых для облегчения работы при обновлении конфигурации.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. BigB 178 12.02.20 23:11 Сейчас в теме
А не лучше ли доработки делать в виде расширений? Тогда и в конфигурации не надо включать возможность изменения и обновляться такая конфигурация будет без проблем.
costy_admin; ipoloskov; Alfn; +3 2 Ответить
2. ipoloskov 76 13.02.20 05:15 Сейчас в теме
(1) это тоже. Но у меня на поддержке еще находятся множество УПП, у других наверняка тоже.
Статью я написал по следам обновления "чужой" УПП, которую провожу в данный момент, и бардака, обнаруженного в этой конфигурации.

По поводу расширений. Я недавно вернул одну Бухгалтерию 3.0 на поддержку, перенеся все доработки в расширение. Но там я это сделал скорее для того, чтобы ускорить процесс обновления (конфигурация "на замке" обновляется в 2-3 раза быстрее, чем со снятым замком). Еще для одного клиента Бух30 я сделал новую подсистему полностью на расширении.

Какие я вижу минусы в полном перенесении правок в расширение:
Часто приходится вносить правки в модули конфигурации, причем делать правки где-нибудь в середине процедуры. Выносить процедуру в расширение чревато тем, что при обновлении она будет изменена - а видно этого не будет. На устоявшихся конфигурациях типа Бухгалтерии это, наверное, не страшно, но на развивающихся типа ERP при каждом обновлении добавится работа - искать в расширении процедуры с заголовком &Вместо, копировать новый код процедуры из основной конфигурации и заново расставлять в нем свои правки. Сравните с тремя щелчками мышью, необходимыми для обработки дважды измененного модуля с помощью kDiff3, и вы поймете, почему я не люблю директиву &Вместо в расширении.
Сейчас появилась возможность добавлять процедуры в расширение с контролем, но я этот механизм еще не пробовал.
3. MVK80 13.02.20 08:10 Сейчас в теме
(2), используйте в расширениях ИзменениеИКонтроль (это вместо &Вместо) и не надо править код основной конфигурации. Доступно с платформы 8.3.15....(последние цифры не помню). Но аккуратно, так как много багов пока в ИзменениеИКонтроль.
6. Monte Carlo 13.02.20 10:53 Сейчас в теме
(3) ERP в режиме совместимости с версией 8.3.12 до сих пор. В ней не работает ИзменениеИКонтроль.
7. MVK80 13.02.20 11:42 Сейчас в теме
(6), работает. Это платформенная фишка не привязанная к режиму совместимости. Попробуйте! Мы как раз и работаем с ERP и с ИзменениемИКонтролем.
9. Monte Carlo 13.02.20 13:35 Сейчас в теме
(7) Странно, пробовали не работает. Да это и логично. Если конфигурация работает в режиме совместимости с более старой версией платформы, то в ней не поддерживаются новые фишки.
17. MVK80 16.02.20 19:35 Сейчас в теме
(9), то есть вам проще поверить что я вру, когда явно пишу, что мы уже работаем с ИзменениемИКонтролем в ERP, нежели в то, что у вас могло не получится по тысячам причин (и вы сразу опустили руки) и теперь вы пытаетесь оправдать это какой-то логикой? Создайте пустую конфигурацию с режимом совместимости 8.3.12 на платформе выше 8.3.15. Создайте процедуру в общем модуле например с Сообщить("Основная конфигурация)" расширьте её с помощью ИзменениеИКонтроль и там замените на Сообщить("Расширение") и с помощью кнопки в обработке вызовите её.
19. Monte Carlo 18.02.20 11:00 Сейчас в теме
(17) Да, прошу прощения. Не работают клиентские методы, а серверная процедура отработала.
21. MVK80 18.02.20 11:21 Сейчас в теме
(19), да там достаточно нюансов, но какие-то пока обходим, регистрируем ошибки. Но в целом всё норм, можно работать!
По поводу клиентских методов вот ошибка: https://bugboard.v8.1c.ru/error/000062705
20. Ndochp 101 18.02.20 11:20 Сейчас в теме
(9) Вы изменение и контроль не по статье с зазеркалья делаете? а то в релизе "КонецВставить" таки переименовали в "КонецВставки" и у меня ерпа работает.
22. Monte Carlo 18.02.20 12:47 Сейчас в теме
(20) Нет, использую #КонецВставки. В клиентском методе падает с ошибкой в модуле ****.cpp. Внутренняя платформенная ошибка, после которой приложение прекращает работу.
23. Ndochp 101 18.02.20 14:47 Сейчас в теме
(22) Забавно. У меня на 8.3.15.1656 полет нормальный. Совместимость 8.3.12, как в поставке.
Но выпадение в cpp это явно не признак штатной работы механизма совместимости.
25. ipoloskov 76 19.02.20 12:57 Сейчас в теме
(3) попробовал (ERP на 8.3.16.1063)
Сразу же после запуска выскочило сообщение, что исходный код модуля изменен (или что-то в этом духе)
26. igee12 19.02.20 16:53 Сейчас в теме
(25) Проверьте, чтобы не было лишних пустых строк за пределами #Вставка .. #КонецВставки, иначе "исходный" код метода 1С считает измененным.
ipoloskov; +1 Ответить
16. costy_admin 47 15.02.20 09:59 Сейчас в теме
(1) Поддерживаю по моему сейчас проще все переводить на расширение.
4. stepan_s 13.02.20 08:27 Сейчас в теме
понятно что при помощи расширений будет красиво. Понятно что так лучше делать на будущее с типовыми....
Но автор наверное поделился опытом как было единственно возможно до недавнего времени....
Учитывая что функционал новый - не стоит слепо и не оглядываясь сразу использовать новые возможности, особенно поделки 1С :).

Но более меня смутило такое большое количество текста, интерпретирующее рекомендации 1С по обновлениям измененных конф, но только вскольз отмечен механизм сравнения при помощи сторонних инструментов (kDiff3) при этом с ремаркой "не расскажу".
Зачем упоминать если не рассказывать? Или как в голливудских фильмах - затравка на интерес к новой части?
8. ipoloskov 76 13.02.20 13:02 Сейчас в теме
(4) хммм, наверное потому, что я узнал про kDiff3 на этом сайте. Сейчас, к сожалению, не могу найти ту статью. Но про kDiff3 написано много где еще - зачем дублировать?
Рекомендации 1С не видел. Но, судя по попадающим ко мне конфигурациям, ранее поддерживавшихся другими компаниями, их вообще мало кто видел. Комментариев изменений форм не делают. Комментариев измерений ролей не делают. Я делюсь личным опытом, который позволяет мне обновлять десяток УПП, где я уже провел рефакторинг в соответствии с вышеуказанными рекомендациями, практически в фоновом режиме - минимально отвлекаясь от разработки.
5. vano-ekt 532 13.02.20 08:54 Сейчас в теме
О обновлениях

о правописании предлогов 🤦‍♂️
ben19791010; SpartakM; YanTsys; Monte Carlo; +4 Ответить
10. YanTsys 12 13.02.20 14:10 Сейчас в теме
Не добавляйте свои отчеты и обработки в дерево конфигурации. Их место - в дополнительных отчетах и обработках или в расширении.

Почему?
11. ipoloskov 76 13.02.20 14:34 Сейчас в теме
(10)
1) Это то, что просят подправить чаще всего. Чтобы лишний раз не изменять конфигурацию.
2) Отчетов накапливается много. Их перемещение вниз дерева конфигурации становится трудоемким (третий абзац снизу).
3) Можно настроить доступ конкретным пользователям, не заводя отдельные роли (если располагать в доп. отчетах).

Для обычных форм, минусы расположения в дополнительных отчетах - их нет в меню интерфейса, что неудобно пользователю. Я обходил это так: добавлял в интерфейс пункт меню с вызовом процедуры общего модуля:
Процедура ПлановыйТабельРабочегоВремени() Экспорт //эту процедуру я вызываю из меню
	
	ОткрытьВнешнийОтчет("Плановый табель рабочего времени");
	
КонецПроцедуры

Процедура ОткрытьВнешнийОтчет(Наименование)
	
	ВнешнийОтчет = Справочники.ВнешниеОбработки.НайтиПоНаименованию(Наименование, Истина);
	
	Если ВнешнийОтчет.Пустая() Тогда
		
		СообщениеОбОшибке = "Не найден внешний отчет """+Наименование+"""";
		Предупреждение(СообщениеОбОшибке);
		ЗаписьЖурналаРегистрации(СообщениеОбОшибке, УровеньЖурналаРегистрации.Ошибка, Метаданные.Справочники.ВнешниеОбработки);
			
	Иначе
	
		ЭтоОбработка = ?(ВнешнийОтчет.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Обработка, Истина, Ложь);
		ЭтоОтчет = ?(ВнешнийОтчет.ВидОбработки = Перечисления.ВидыДополнительныхВнешнихОбработок.Отчет, Истина, Ложь);
		
		Если НЕ (ЭтоОбработка ИЛИ ЭтоОтчет) Тогда
			Возврат;
		КонецЕсли;
		
		Попытка
			
			ИмяФайла = ПолучитьИмяВременногоФайла();
			ДвоичныеДанные = ВнешнийОтчет.ХранилищеВнешнейОбработки.Получить();
			ДвоичныеДанные.Записать(ИмяФайла);
			
			Если ЭтоОбработка Тогда
				
				Форма = ВнешниеОбработки.ПолучитьФорму(ИмяФайла);
				
			Иначе
				
				Форма = ВнешниеОтчеты.ПолучитьФорму(ИмяФайла);
				
			КонецЕсли;
			
			Если Не Форма = Неопределено Тогда
				
				Форма.Открыть();
				
			Иначе
				
				Если ЭтоОбработка Тогда
					ВнешняяОбработка = ВнешниеОбработки.Создать(ИмяФайла);
				Иначе
					ВнешнийОтчет = ВнешниеОтчеты.Создать(ИмяФайла);
					Форма = ВнешнийОтчет.ПолучитьФорму();
					Если Форма <> Неопределено Тогда
						Форма.Открыть();
					КонецЕсли;
				КонецЕсли;
				
			КонецЕсли;
			
			ЗаписьЖурналаРегистрации("Открытие внешнего отчета", УровеньЖурналаРегистрации.Информация, Метаданные.Справочники.ВнешниеОбработки, ВнешнийОтчет);
			
		Исключение
			
			Если ЭтоОбработка Тогда
				
				Предупреждение("Выбранный файл не является внешней обработкой.
							   |Либо, данная обработка не предназначена для
							   |запуска в этой конфигурации.");
			Иначе
				Предупреждение("Выбранный файл не является внешним отчетом.
							   |Либо, данный отчет не предназначена для
							   |запуска в этой конфигурации.");
			КонецЕсли;
			
			ЗаписьЖурналаРегистрации("Ошибка открытия внешнего отчета", УровеньЖурналаРегистрации.Ошибка, Метаданные.Справочники.ВнешниеОбработки, ВнешнийОтчет);
			
		КонецПопытки;
		
	КонецЕсли;
	
КонецПроцедуры
Показать

В конфигурациях на управляемых формах я располагаю отчеты в расширении. Там уже можно легко добавить их в произвольный интерфейс-подсистему. Но можно вывести в интерфейс и отчет из дополнительных отчетов и обработок. Для этого нужно добавить в расширение общую команду с кодом
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
	
	НаименованиеОбработки = "Этикетка товарных упаковок";
	
	ОбработкаСсылка = ОбработкаСсылка(НаименованиеОбработки);
	Если ОбработкаСсылка.Пустая() Тогда
		ОбщегоНазначенияКлиентСервер.СообщитьПользователю("Не найдена внешняя обработка """ + НаименованиеОбработки + """");
		возврат;
	КонецЕсли;
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("ДополнительнаяОбработкаСсылка", ОбработкаСсылка);
	
	ИмяОбработки = ДополнительныеОтчетыИОбработкиВызовСервера.ПодключитьВнешнююОбработку(ОбработкаСсылка);
	ФормаОбработки = ОткрытьФорму("ВнешняяОбработка."+ ИмяОбработки +".Форма", ПараметрыФормы);
	
КонецПроцедуры

&НаСервере
Функция ОбработкаСсылка(Наименование)
	
	возврат Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(Наименование);
	
КонецФункции
Показать

а эту команду уже добавить в подсистему-интерфейс. После этого можно будет менять отчет, не меняя расширение, и отчет располагается удобно для пользователя - в панели интерфейса.
12. YanTsys 12 13.02.20 14:53 Сейчас в теме
(11)
Отчетов накапливается много. Их перемещение вниз дерева конфигурации становится трудоемким (третий абзац снизу).


Почему вниз? Мы свои объекты располагаем в начале списка, тогда их потом не приходится искать...

Чтобы лишний раз не изменять конфигурацию.


Конечно динамическое обновление у многих вызывает фантомные боли, но у нас оно уже очень давно беспроблемно работает...

Можно настроить доступ конкретным пользователям, не заводя отдельные роли (если располагать в доп. отчетах).

Аргумент. Но будут и обратные ситуации когда мы хотим просто назначить роль человеку и не вспоминать какой комплекс отчетов и обработок ему еще нужно настроить.

Я обходил это так: добавлял в интерфейс пункт меню с вызовом процедуры общего модуля:

Я для внешних обработок просто добавляю общую команду и потом даю к ней доступ в нужной подсистеме.
13. ipoloskov 76 13.02.20 15:07 Сейчас в теме
(12)
Мы свои объекты располагаем в начале списка, тогда их потом не приходится искать...

Сравнение с конфигурацией поставщика (такое иногда приходится делать) вывалит все объекты конфигурации с пометкой "изменен порядок". Если свои объекты внизу, такого не будет.
14. kosmo0 95 14.02.20 02:32 Сейчас в теме
Личный опыт по обычным формам (УПП).
1. В измененных блоках желательно помечать начало и конец измененного блока. Так как если в модуле изменения в нескольких местах, то невозможно определить что менялось и что не менялось. Можно словами "НачалоБлока" и "КонецБлока", можно скобками "<<" и ">>".

Процедура ааа()
//мои изменения
  действие1
  действие2
  действие3
КонецПроцедуры

Процедура ааа()
//мои изменения
//НачалоБлока
  действие1
  действие2
//КонецБлока
  действие3
КонецПроцедуры
Показать


2. В комментариях обязательно ставил дату изменения. При багах проще находить исходный код и, при наличии, сразу представлять масштаб некорректных данных в БД из-за работы измененного кода.

3. В некоторых случаях полезно оставлять исходный код. Когда он относительно небольшой и расположен в "критическом" месте. Например в общем модуле - всегда есть вероятность один вызов из 10000 не будет отрабатывать как предусмотрено (то есть в этом вызове нужен только исходный код). При этом также обрамление //ИсходныйКод_НачалоБлока и //ИсходныйКод_КонецБлока. Лично я оставлял это примерно на год, потом удалял (становилось ясно что грабли отсутствуют). Просто с таким блоком намного проще отлаживать баги - что было сразу видно и не надо открывать старую конфигурацию.

4. При изменении единственной строки - комментарий в конце строки. Визуально гораздо быстрее понимать масштаб изменений при сравнении/объединении. То есть "лишние" комментарии об изменениях усложняют и увеличивают работу. Возможно при небольших изменениях в типовой конфигурации это и не критично.

5.
По возможности добавляйте свои элементы форм программно – тогда перенос изменений при обновлении сведется к копированию/вставке кусков кода. Но без фанатизма – на обычных формах проще выделить мышкой и скопировать-вставить десяток элементов на добавленной странице, чем создавать их все программным способом, задавая расположение и привязки - пусть даже в перспективе это придется делать 10 или 100 раз. Однажды я перенес все многочисленные изменения форм УПП в код, а завод через полгода обанкротился.


Лично я бы рекомендовал добавления делать программно. Если копипастить визуальные элементы ОБЫЧНОЙ формы, то при сравнении с типовой эти элементы будут показываться как различающиеся с типовыми. Причем по всем реквизитам полное совпадение, но будет показано как различающееся (по крайней мере в 8.3.8 так было).
И если типовая форма изменилась и на ней есть ваши изменения визуальных элементов, то при объединении получается такая чушь.

Если вы пришли в организацию в которой масса изменений, то не стоит сломя голову бросаться переписывать все изменения элементов форм в программный вид. Делайте это только с теми формами которые изменяются часто.

кстати, рекомендую программно создаваемые элементы формы привязывать к низу формы (панели). И если новые типовые элементы перекроют ваши, то можно будет их увидеть растянув форму вниз (а иначе переделка конфигурации - сколько времени это займет? и что скажет на это бухгалтерия в отчетный период?)
24. ipoloskov 76 19.02.20 12:56 Сейчас в теме
(14) отмечать, где в блоке начало, а где конец, имеет смысл в двух случаях:
1) блок слишком большой, и визуально на экране не видно, где он начинается и заканчивается. В этом случае необходимо выделить его в отдельную процедуру.
2) вставок много, и они идут чередой среди аутентичного кода.
Во всех остальных случаях пометки типа "начало" и "конец" только добавляют мусора на экран.
15. anton13m 14.02.20 14:12 Сейчас в теме
В некоторых случаях адаптация расширений под новую версию может существенно усложнить обновление, т.к. механизм сравнения расширений с конфигурацией поставщика или основной, вроде бы, до сих пор отсутствует, да и бывает, что внесение изменений в конфигурацию будет предпочтительней, чем выносить доработки в расширение.
ipoloskov; Ndochp; +2 Ответить
18. triviumfan 14 17.02.20 20:02 Сейчас в теме
Даже не читал. Раз название темы безграмотное, следовательно и статья тоже.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 180 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата до 130 000 руб.
Полный день