1. gai9151 13.01.20 12:46 Сейчас в теме

УстановитьПривилегированныйРежим

Здравствуйте!

УстановитьПривилегированныйРежим не работает на закрытом периоде , процедура запускается внешней обработкой, кто знает ?

Процедура КнопкаВыполнитьНажатие(Кнопка)
	Выборка=Документы.РеализацияТоваровУслуг.Выбрать(ДатаНач, ДатаКон);
	
	УстановитьПривилегированныйРежим(Истина);
	
	Пока Выборка.Следующий() цикл
		  ДокМар= Выборка.ПолучитьОбъект();
          ДокМар.ОтправленаВМаршрут = истина;
	      ДокМар.Записать();
		  Сообщить(ДокМар.Ссылка);
	КонецЦикла;
КонецПроцедуры
Показать
Ответы
Избранное Подписка Сортировка: Древо
4. alex-l19041 8 13.01.20 13:27 Сейчас в теме
(1)
ДокМар.ОбменДанными.Загрузка = ИСТИНА
5. gai9151 13.01.20 13:33 Сейчас в теме
(4) ДокМар.ОбменДанными.Загрузка = ИСТИНА тоже пробовал, не перезаписывает закрытый период
6. gai9151 13.01.20 15:10 Сейчас в теме
(4)
ТАК РАБОТАЕТ, ПОЧЕМУ- ТО В ЦИКЛЕ РАБОТАЕТ

Процедура КнопкаВыполнитьНажатие(Кнопка)
	
	
	Выборка=Документы.РеализацияТоваровУслуг.Выбрать(ДатаНач, ДатаКон);
	//УстановитьПривилегированныйРежим(Истина);
	
	Пока Выборка.Следующий() цикл
		  ДокМар= Выборка.ПолучитьОбъект();
		  
	ЗначениеКонстанты = Константы.ПрименятьДатуЗапретаДляПолныхПрав.Получить();
	Константы.ПрименятьДатуЗапретаДляПолныхПрав.Установить(Ложь);
	ПолныеПрава.УстановитьПараметрГраницыЗапретаИзмененияДанных();

		  
		  ДокМар.ОтправленаВМаршрут = истина;
	      ДокМар.Записать();
		  
	Константы.ПрименятьДатуЗапретаДляПолныхПрав.Установить(ЗначениеКонстанты);
    ПолныеПрава.УстановитьПараметрГраницыЗапретаИзмененияДанных();
	
	
		  Сообщить(ДокМар.Ссылка);
	  КонецЦикла;

КонецПроцедуры
Показать
7. alex-l19041 8 13.01.20 15:16 Сейчас в теме
(6) работать с константой надо вне цикла
2. Pacan4ik 13.01.20 12:50 Сейчас в теме
ДокМар.ДополнительныеСвойства.Вставить("ПропуститьПроверкуЗапретаИзменения", Истина);
ДокМар.Записать();
3. gai9151 13.01.20 13:20 Сейчас в теме
(2) не дает Редактирование данных этого периода запрещено. Изменения не могут быть записаны...
8. Romeo_1c_programmer 19 13.01.20 15:16 Сейчас в теме
А если так попробовать?


Процедура КнопкаВыполнитьНажатие(Кнопка)

УстановитьПривилегированныйРежим(Истина);

ЗначениеКонстанты = Константы.ПрименятьДатуЗапретаДляПолныхПрав.Получить();

Константы.ПрименятьДатуЗапретаДляПолныхПрав.Установить(Ложь);

ПолныеПрава.УстановитьПараметрГраницыЗапретаИзмененияДанных();

Выборка=Документы.РеализацияТоваровУслуг.Выбрать(ДатаНач, ДатаКон);

Пока Выборка.Следующий() цикл

ДокМар= Выборка.ПолучитьОбъект();

ДокМар.ОтправленаВМаршрут = истина;

ДокМар.Записать();

Сообщить(ДокМар.Ссылка);
КонецЦикла;

Константы.ПрименятьДатуЗапретаДляПолныхПрав.Установить(ЗначениеКонстанты);

ПолныеПрава.УстановитьПараметрГраницыЗапретаИзмененияДанных();

КонецПроцедуры 
Показать
9. gai9151 13.01.20 16:28 Сейчас в теме
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант по 1С:Документооборот
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:Бухгалтерии
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:ЗУП
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день