0. dakork 20 29.11.19 12:55 Сейчас в теме

Преобразование структуры в таблицу значений

Преобразование структуры в таблицу значений для последующего использования в запросе.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. AgnepuS 3 29.11.19 21:36 Сейчас в теме
Как-то сложно. Если данные структуры (а не массива структур) нужно использовать в запросе, то зачем вообще прослойка в виде таблицы значений?
Почему сразу не передавать данные структуры через установку параметров? Хорошо, допустим, состав элементов коллекции структуры неизвестен или же элементов много, то можно программно создать текст запроса. Например, так:
Процедура СоздатьВременнуюТаблицуСДаннымиСтруктуры(СтруктураДанных, МенеджерВременныхТаблиц, ИмяВременнойТаблицы = "АВотМнеТаблицаЗначенийНеНужна")
		
	Запрос = Новый Запрос;
	Запрос.МенеджерВременныхТаблиц = МенеджерВременныхТаблиц;	
	Запрос.Текст = "ВЫБРАТЬ";	
	Для каждого Элемент Из СтруктураДанных Цикл		
		Запрос.Текст = Запрос.Текст + Символы.ПС + Символы.Таб + "&" + Элемент.Ключ + " КАК " + Элемент.Ключ + ","; 
		Запрос.УстановитьПараметр(Элемент.Ключ, Элемент.Значение);	
	КонецЦикла;	
	Запрос.Текст = Лев(Запрос.Текст, СтрДлина(Запрос.Текст) - 1) + Символы.ПС + "ПОМЕСТИТЬ " + ИмяВременнойТаблицы;	
	Запрос.Выполнить();
			
КонецПроцедуры 
Показать
2. AgnepuS 3 30.11.19 02:13 Сейчас в теме
Кстати, код-то ваш ещё и нерабочий. Вы ведь в курсе, что созданное вами описание типов ОписаниеТиповСсылок содержит еще тип Неопределено, но не содержит никакие другие типы кроме ссылок справочников и документов? Попробуйте передать в функцию, например:
Новый Структура("Покупатель")
или
Новый Структура("Перечисление", Перечисления.ЮридическоеФизическоеЛицо.ПустаяСсылка())


Для чего нужна следующая конструкция?
ОписаниеТиповСсылок = Новый ОписаниеТипов(Новый ОписаниеТипов(...));


В чем заключается смысл исключения типов ссылок перечислений из исходного описания типов ссылок справочников? Ведь ихтамнет.
Почему вообще решили оставить только типы ссылок справочников и документов? Почему не создали описание типа, включающего в себя все возможные ссылочные типы конфигурации (для таких случаев даже есть БСП'шная функция ОписаниеТипаВсеСсылки())?
С другой стороны, если не ограничивать использование всех ссылочных типов, зачем вообще тогда огород с ОписаниеТиповСсылок и методом СодержитТип(), ведь тогда можно, например, сделать так:
...
Для Каждого ТекЭлем из Структра Цикл		
		
	МассивТипов = Новый Массив;
	МассивТипов.Добавить(ТипЗнч(ТекЭлем.Значение));		
	ТЗ.Колонки.Добавить(ТекЭлем.Ключ, Новый ОписаниеТипов(МассивТипов));	
	НовСтр[ТекЭлем.Ключ] = ТекЭлем.Значение;
							
КонецЦикла;
...
Показать


Ок, оставили только типы ссылок справочников и документов. А как быть с ссылками на справочники и документы из расширения?
dakork; Atticus2; sulfur17; triviumfan; asg.aleks; +5 Ответить
3. dakork 20 02.12.19 18:19 Сейчас в теме
Согласен с вами. Была пятница вечер. Усталость. Срочно нужно было использовать структуру в запросе. Поиск в интернете ничего не дал. Возможно, надо было просто выложить в качестве вопроса, но на тот момент казалось, что это рабочий вариант и ждать ответа не было времени. К тому же у меня в структуре не было перечислений и "неопределено". А так большое спасибо за предложенный вариант. В любом случае, решение найдено, и я скорее всего, буду использовать ваш вариант, но под массив структур, можно использовать мой, с небольшими корректировками.
4. AgnepuS 3 02.12.19 22:00 Сейчас в теме
(3)
и я скорее всего, буду использовать ваш вариант

Смотря какой вариант хотите использовать. Если из первого сообщения, то код в нем только лишь для примера программного создания текста вопроса, и там нужно внести кое-какие правки, ну, или учесть следующие моменты в самой процедуре (либо перед её вызовом).
Во-первых, нужно учесть (проверить), что структура не пустая (есть хотя бы один элемент коллекции).
Во-вторых, учесть, что в тексте вопроса в псевдонимах полей нельзя использовать ключевые слова такие как Истина, Ложь, Неопределено, Выразить, Выбор и тд. Соответственно имя полям либо вообще не устанавливать, либо контролировать эту установку (например, подменяя имя).
Далее, судя по контексту, состав структуры вам заранее известен, тогда почему бы вообще не обойтись без программного создания текста запроса.
Запрос = Новый Запрос;
Запрос.Текст = 
	"ВЫБРАТЬ
	|	&Параметр0, // Где Параметр{n} - ключ элемента структуры
	|	&Параметр1,
	...
	|	&ПараметрN";
Для каждого Элемент Из СтруктураДанных Цикл        
	Запрос.УстановитьПараметр(Элемент.Ключ, Элемент.Значение);    
КонецЦикла;
Показать

Если же говорите про вариант из второго сообщения, то вопрос остается открытым: "зачем вообще прослойка в виде таблицы значений?" То есть если бы задача была в том, чтобы перевести структуру в типизированную таблицу значений, то ок. Но вы сами указали, что таблица значений нужна для последующего использования в запросе.


(3)
но под массив структур, можно использовать мой, с небольшими корректировками

Не знаю как можно скорректировать ваш код, чтобы можно было работать с массивом структур. Но примерно представляю, что нужно сделать с моим вариантом. Если учесть что ключи (и их количество) могут отличаться у структур, а также типы значений у одноименных свойств (то есть тип колонок у итоговой таблицы значений будет составной) - то делается это, к сожалению, в два цикла. Если необходим будет пример - напишите. Если структуры в массиве созданы одним конструктором и не подразумевается использование более одного типа значений в одноименных свойствах, то заполняем описание типов колонок таблицы значений по первому элементу в массиве структур, а для остальных элементов только заполняем значения через ЗаполнитьЗначенияСвойств (где приемник новая строка таблицы, а источник структура).
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Разработчик 1С
Нижний Новгород
зарплата до 90 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата до 140 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант 1С
Москва
зарплата от 80 000 руб.
Полный день