Вывод полной истории в задаче по всему "дереву" бизнес-процессов

0. 50 20.11.19 13:00 Сейчас в теме
Вашему вниманию предлагается моя версия текста общего модуля "ОбзорЗадачВызовСервераПереопределяемый" для конфигурации 1С:Документооборот.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. mifka186 8 20.11.19 14:40 Сейчас в теме
Картинка с результатом была бы очень уместна.
2. rmIvanT 50 20.11.19 14:43 Сейчас в теме
(1) к публикации прикреплён всего один скриншот с результатом работы кода, поправил статью для большей ясности
3. xKEEPERx 08.12.19 02:33 Сейчас в теме
Спасибо за доработку!
А цвет текста по результатам выполнения задачи не должен меняться?

Выполненные под задачи не выводятся?
4. rmIvanT 50 08.12.19 02:39 Сейчас в теме
(3)Цвет не меняется, заказа такого не было.
по идее должно быть результат вывод всех задач, всех поцессов.
если что-то не выводится, пишите поправим
5. rmIvanT 50 30.01.20 11:19 Сейчас в теме
(3)
А цвет текста по результатам выполнения задачи не должен меняться?


Можете подробнее описать, какой текст, в какие цвета, и по чьим результатам. покрасим, но это не точно.
8. xKEEPERx 12.02.20 13:27 Сейчас в теме
(5) Если Согласовано - жирный Зелёный, если не Согласовано - жирный красный
Аналогично Подписано/Не подписано, Утверждено/Не утверждено
9. rmIvanT 50 13.02.20 09:04 Сейчас в теме
(8) Сейчас всё ссылки, их сложно покрасить по разному
6. awe007 30.01.20 11:52 Сейчас в теме
В историю процесса не попадают задачи "Рассмотреть вопрос", "Ознакомиться с ответом на вопрос". Это специально так сделано:
7. rmIvanT 50 30.01.20 16:34 Сейчас в теме
10. Mellentin 26.02.20 08:05 Сейчас в теме
Спасибо за статью, очень полезная вещь!
11. solaru 55 17.06.20 18:29 Сейчас в теме
Работает, для благодарности можно выложить расширение за $M
12. rmIvanT 50 19.06.20 08:33 Сейчас в теме
(11) В виде благодарности принимаются лайки(+) и хвалебные комментарии ;-)
на расширение нет ни времени, ни сил, ни желания. К тому же маловато функционала для расширения.
13. MSK_Step 22 15.09.20 20:24 Сейчас в теме
(12
)Функция ПолучитьГлавнуюВедущуюЗадачу(ИскомыйПроцессСсылка)
	врИскомыйПроцесс = ИскомыйПроцессСсылка.ПолучитьОбъект();
	Если ЗначениеЗаполнено(врИскомыйПроцесс.ВедущаяЗадача) Тогда
		Возврат врИскомыйПроцесс.ВедущаяЗадача;
	КонецЕсли;
	Попытка
		Если ЗначениеЗаполнено(врИскомыйПроцесс.ГлавнаяЗадача) Тогда
			Возврат врИскомыйПроцесс.ГлавнаяЗадача;
		КонецЕсли;
	Исключение
	КонецПопытки;
	Возврат Неопределено;
КонецФункции
Показать


врИскомыйПроцесс = ИскомыйПроцессСсылка.ПолучитьОбъект();
почему сразу ИскомыйПроцессСсылка.ВедущаяЗадача не написать?
14. rmIvanT 50 16.09.20 20:29 Сейчас в теме
(13) точно не помню, видимо в каких-то случаях не работало.
15. ElisGrey 22.10.20 10:53 Сейчас в теме
(14)Добрый день!
Хотелось бы узнать, как сделать видимой задачу, которая находится на выполнении/согласовании и тд ?
У меня отображается пустота, если задача не выполнена
16. rmIvanT 50 22.10.20 11:05 Сейчас в теме
(15) Видимо нет истории, пока задача не будет завершена/выполнена. Нужно подумать, над Вашим предложением, подумаю когда будет время.
17. ElisGrey 22.10.20 13:20 Сейчас в теме
(16) спасибо большое
Хотела ещё уточнить, у Вас: реквизиты завершён, датаначала и датазавершения в Функции ПолучитьПодчиненныеБизнесПроцессы находятся в регистре сведений дочерниеБизнесПроцессы?
18. rmIvanT 50 22.10.20 13:35 Сейчас в теме
(17) пока не за что, учитывая мою текущую занятость, решение может появится не скоро :-(
Нет это реквизиты процесса в регистре хранится ссылка на процесс, а реквизиты берутся из процесса.
19. ElisGrey 22.10.20 13:39 Сейчас в теме
(18) благодарю Вас, поняла
Попробую ещё сама разобраться, если доработка будет, то дополню)
20. ElisGrey 29.10.20 13:17 Сейчас в теме
(18)Немного изменила фнк
Может кому-то полезно будет)

Функция ПреобразоватьИсторияВыполненияHTML(БизнесПроцесс)
	Если БизнесПроцесс.Завершен Тогда
		СтатусБПСтрокой = "✅ Задача выполнена " + Символы.ПС;
	Иначе
		СтатусБПСтрокой = "Задача на выполнении " + Символы.ПС;
	КонецЕсли;
	//Заголовок
	ИсторияВыполненияHTML = "<hr><p>"+ СтатусБПСтрокой + Строка(БизнесПроцесс)+ "<p>";
	
	//Содержание						
	ИсторияВыполнения = РегистрыСведений.ИсторияВыполненияЗадач.ДН_ИсторияПоБизнесПроцессу(БизнесПроцесс);
	
	//Получаем задачи по процессу
	Запрос = Новый Запрос(
	"ВЫБРАТЬ
	|	ЗадачаИсполнителя.Ссылка КАК Ссылка,
	| 	ЗадачаИсполнителя.Исполнитель КАК Исполнитель
	|ИЗ
	|	Задача.ЗадачаИсполнителя КАК ЗадачаИсполнителя
	|ГДЕ
	|	ЗадачаИсполнителя.БизнесПроцесс = &БизнесПроцесс");
	
	Запрос.УстановитьПараметр("БизнесПроцесс", БизнесПроцесс.Ссылка);
	ВыборкаЗадач = Запрос.Выполнить().Выбрать(); 
	Если ЗначениеЗаполнено(ИсторияВыполнения) Тогда
		 Если ВыборкаЗадач.Следующий() Тогда
		ИсторияВыполненияHTML = ИсторияВыполненияHTML +	ИсторияВыполнения;
		КонецЕсли;
	Иначе
		Если ВыборкаЗадач.Следующий() Тогда
			ИсторияВыполненияHTML = ИсторияВыполненияHTML + "Текущая задача находится на выполнении: " + ВыборкаЗадач.Исполнитель;
		КонецЕсли;
	КонецЕсли;

	ИсторияВыполненияHTML = СтрЗаменить(ИсторияВыполненияHTML, Символы.Таб, "   ");
	ИсторияВыполненияHTML = СтрЗаменить(ИсторияВыполненияHTML, Символы.ПС, "");

	Возврат ИсторияВыполненияHTML; 

КонецФункции
Показать
Svet_Serg; +1 Ответить
21. ElisGrey 29.10.20 13:19 Сейчас в теме
(18) Единственный вопрос остался: как добавить текущего исполнителя задачи, если задача отправлена нескольким пользователям одновременно)
22. Svet_Serg 26.02.21 10:27 Сейчас в теме
Огромное спасибо!
Не планируете ли вывести реквизит "Содержание" из основного предмета? Это было бы вообще огонь!
23. rmIvanT 50 26.02.21 10:39 Сейчас в теме
24. user1018141 03.03.21 23:49 Сейчас в теме
Отлично решение Спасибо!
Может кто-то знает как, в историю выполнения вывести выбранное значение доп. реквизита в задаче?
Пример : 03.03.2021 00:00, ФИО. Задача выполнена. [ЗначениеДопРеквизита]
Оставьте свое сообщение
Вопросы с вознаграждением