1. user1255844 10.11.19 13:40 Сейчас в теме

Макет печатной формы

Здравствуйте! Подскажите, пожалуйста, как сделать чтобы печатная форма выводила каждую сточку табличной части? В моем примере сколько членов комиссии столько и должно выводить автоматически строчек. Прикрепляю файлы.
Прикрепленные файлы:
Найденные решения
4. user856012 8 10.11.19 14:51 Сейчас в теме
(3)
Цикл, который написала, выводит только одну строчку
И в ней - последний член комиссии, да?

Вы ведь просто присваиваете несколько раз одной и той же области макета разные значения должности и ФИО, а потом один раз выводите эту область.

А вам надо в макете выделить строчку с членом комиссии в отдельную область и несколько раз вывести ее, заполняя данными разных сотрудников.
5. tolyan_ekb 171 10.11.19 15:28 Сейчас в теме
в цикле получить область - присвоить параметры - вывести область
6. buganov 59 10.11.19 17:37 Сейчас в теме
(3)Вам нужно что то вроде:
Если Объект.ТабличнаяЧасть.Количество()>0 Тогда
Для каждого Стр из Объект.ТабличнаяЧасть Цикл
ОбластьМакетаПодпись = Макет.ПолучитьОбласть("ОбластьМакетаПодпись");
ОбластьМакетаПодпись.Параметры.ДолжностьЧленаКомиссии = Стр.Должность;
Сотрудник = Стр.Сотрудник;
ОбластьМакетаПодпись.Параметры.ФИОЧленаКомиссии = Сотрудник.Фамилия+" "+Лев(Сотрудник.Имя,1)+". "+Лев(Сотрудник.Отчество,1)+".";
ТабличныйДокументРезультат.Вывести(ОбластьМакетаПодпись);
КонецЦикла;
КонецЕсли;
Показать
Остальные ответы
Избранное Подписка Сортировка: Древо
2. buganov 59 10.11.19 14:12 Сейчас в теме
Нужно в цикле вывести область с сотрудниками.
Если в подвале помимо сотрудников еще чего то есть, то выделить из подвала отдельную область и запрограммировать вывод:
Подвал -> Сотрудники -> все, что осталось после
3. user1255844 10.11.19 14:29 Сейчас в теме
(2) Если Объект.ТабличнаяЧасть.Количество()>0 Тогда
Для каждого Стр из Объект.ТабличнаяЧасть Цикл
ОбластьМакетаПодпись.Параметры.ДолжностьЧленаКомиссии = Стр.Должность;
Сотрудник = Стр.Сотрудник;
ОбластьМакетаПодпись.Параметры.ФИОЧленаКомиссии = Сотрудник.Фамилия+" "+Лев(Сотрудник.Имя,1)+". "+Лев(Сотрудник.Отчество,1)+".";
КонецЦикла;
КонецЕсли;


Я понимаю, что нужен цикл, но не совсем понимаю как правильно его составить (новичок в программировании 1С). Цикл, который написала, выводит только одну строчку
4. user856012 8 10.11.19 14:51 Сейчас в теме
(3)
Цикл, который написала, выводит только одну строчку
И в ней - последний член комиссии, да?

Вы ведь просто присваиваете несколько раз одной и той же области макета разные значения должности и ФИО, а потом один раз выводите эту область.

А вам надо в макете выделить строчку с членом комиссии в отдельную область и несколько раз вывести ее, заполняя данными разных сотрудников.
6. buganov 59 10.11.19 17:37 Сейчас в теме
(3)Вам нужно что то вроде:
Если Объект.ТабличнаяЧасть.Количество()>0 Тогда
Для каждого Стр из Объект.ТабличнаяЧасть Цикл
ОбластьМакетаПодпись = Макет.ПолучитьОбласть("ОбластьМакетаПодпись");
ОбластьМакетаПодпись.Параметры.ДолжностьЧленаКомиссии = Стр.Должность;
Сотрудник = Стр.Сотрудник;
ОбластьМакетаПодпись.Параметры.ФИОЧленаКомиссии = Сотрудник.Фамилия+" "+Лев(Сотрудник.Имя,1)+". "+Лев(Сотрудник.Отчество,1)+".";
ТабличныйДокументРезультат.Вывести(ОбластьМакетаПодпись);
КонецЦикла;
КонецЕсли;
Показать
7. buganov 59 10.11.19 17:40 Сейчас в теме
(3)
ФИОЧленаКомиссии = Сотрудник.Фамилия+" "+Лев(Сотрудник.Имя,1)+".


Поищите по конфигурации функцию Которая сама сократи имя отчество. Пользуйтесь БСП
5. tolyan_ekb 171 10.11.19 15:28 Сейчас в теме
в цикле получить область - присвоить параметры - вывести область
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Консультант по 1С:Документооборот
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:Бухгалтерии
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:ЗУП
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день