1. AlenkaInt 25 08.11.19 09:43 Сейчас в теме

Обновление УФ после добавления элемента

Добрый день! Есть справочник с отбором по автору. Сотрудник добавляет элемент. Но сразу его выбрать не может, только если перезайдет в справочник. Как сделать, чтобы сразу этот элемент отображался?
Найденные решения
3. Akuji 14 08.11.19 09:51 Сейчас в теме
Можно при добавлении
Оповестить("НаименованиеСобытия");

форму списка
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник) 
 
      Если ИмяСобытия = "НаименованиеСобытия" Тогда 
            Прочитать(); 
      КонецЕсли; 
 
КонецПроцедуры
Остальные ответы
Избранное Подписка Сортировка: Древо
2. uk09 08.11.19 09:48 Сейчас в теме
(1) Добрый день!

Пришлите, пожалуйста, скриншот с формой выбора. Если правильно понимаю, с добавлением и отражением добавленного - проблем нет ?
7. AlenkaInt 25 08.11.19 11:20 Сейчас в теме
(2)Обычная управляемая форма выбора, никаких особенностей.
4. mar82 08.11.19 10:09 Сейчас в теме
(1) а может просто в форме поставить "обновлять динамический список" каждые - N секунд и все
6. AlenkaInt 25 08.11.19 11:19 Сейчас в теме
(4) Нет, не очень это. Я знаю как то можно обновлять форму, но пока не получается.
3. Akuji 14 08.11.19 09:51 Сейчас в теме
Можно при добавлении
Оповестить("НаименованиеСобытия");

форму списка
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник) 
 
      Если ИмяСобытия = "НаименованиеСобытия" Тогда 
            Прочитать(); 
      КонецЕсли; 
 
КонецПроцедуры
5. AlenkaInt 25 08.11.19 10:55 Сейчас в теме
(3)
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

Если ИмяСобытия = "НаименованиеСобытия" Тогда
Прочитать();
КонецЕсли;

КонецПроцедуры

Прочитать не находит..
8. AlenkaInt 25 08.11.19 12:23 Сейчас в теме
Коллеги, получилось! Надо было обнулить отбор сначала.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Системный аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Тестировщик 1С
Москва
зарплата от 70 000 руб.
Полный день

Программист 1С
Воронеж
зарплата от 100 000 руб. до 150 000 руб.
Полный день