0. GeterX 680 08.11.19 14:21 Сейчас в теме

Кнопка ПОДБОР для документа Заявка на открытие лицевых счетов

Расширение добавляет кнопку "Подбор" в документ "Заявка на открытие лицевых счетов".
И отключает проверку на 19 символов в латинском Фамилии, Имени при выгрузке.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. DJDUH 17 08.11.19 15:29 Сейчас в теме
Запрос в цикле, ай-я-я-й-й!!!

Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Справочники.Валюты.НайтиПоКоду("643");
		
КонецЦикла;
Показать



Валюта643 = Справочники.Валюты.НайтиПоКоду("643");
Для каждого Строка Из Объект.Сотрудники Цикл
		
	//Строка.ЯвляетсяЗарплатнойКартой = Истина;
	Строка.СистемаРасчетовПоБанковскимКартам = "МИР";
	Строка.ВалютаВклада = Валюта643 ;
		
КонецЦикла;
Показать
2. GeterX 680 08.11.19 17:04 Сейчас в теме
3. chesnokov-a-v 99 17.12.19 14:35 Сейчас в теме
Установил расширение, но кнопка "Подбор" не появилась. ЗУП 3.1.11.133
4. GeterX 680 17.12.19 14:40 Сейчас в теме
(3) в описании написано: "В расширении следует отключить безопасный режим."
5. chesnokov-a-v 99 17.12.19 20:06 Сейчас в теме
(4) конечно это было сделано. попробую разобраться в проблеме чуть позже.
6. GeterX 680 17.12.19 20:24 Сейчас в теме
(5) попробуйте поискать в меню Ещё табличной части документа.
7. chesnokov-a-v 99 18.12.19 11:28 Сейчас в теме
(6) Появилась. Удалил расширение и добавил заново, с несколькими перезапусками (магия).
8. Amras 43 20.12.19 09:41 Сейчас в теме
Так попроще будет, а уж добавить команду (ПодобратьСотрудников) на форму, думаю, труда не составит. И при всем при этом используем исключительно типовые механизмы (протестировано на ЗУП КОРП 3.1.10.223), кроме получения ФизическогоЛица.

&НаКлиенте
Процедура ПодобратьСотрудников(Команда)
	КадровыйУчетКлиент.ВыбратьСотрудниковРаботающихНаДатуПоПараметрамОткрытияФормыС­писка(
		Элементы.ЛицевыеСчета,,,,,АдресСпискаПодобранныхСотрудников());
КонецПроцедуры
	
// Возвращает адрес во временном хранилище массива уже подобранных сотрудников.
//
&НаСервере
Функция АдресСпискаПодобранныхСотрудников()
	СписокСотрудников = Объект.Сотрудники.Выгрузить(,"ФизическоеЛицо").ВыгрузитьКолонку("ФизическоеЛицо");
	
	Возврат ПоместитьВоВременноеХранилище(СписокСотрудников, УникальныйИдентификатор);
КонецФункции

&НаКлиенте
Процедура ЛицевыеСчетаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
	Для каждого ВыбранныйСотрудник Из ВыбранноеЗначение Цикл
		
		мФизЛицо = МГ_ПолучитьФизЛицо(ВыбранныйСотрудник);
		
		Если Объект.Сотрудники.НайтиСтроки(Новый Структура("ФизическоеЛицо", мФизЛицо)).Количество() = 0 Тогда
			НовыйСотрудник = Объект.Сотрудники.Добавить();
			НовыйСотрудник.ФизическоеЛицо = мФизЛицо;
			
			ЗаполнитьСтрокуНаСервере(НовыйСотрудник.НомерСтроки);
			
			Модифицированность = Истина;
		КонецЕсли;
	КонецЦикла; 
КонецПроцедуры

&НаСервере
Функция МГ_ПолучитьФизЛицо(Сотрудник)
	Возврат Сотрудник.ФизическоеЛицо;
КонецФункции
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Консультант по 1С:Документооборот
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:Бухгалтерии
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист по 1С:ЗУП
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день