Обмен с системой Ветис Меркурий для любых конфигураций. Гашение ВСД, списание продукции, пакетная печать ВСД (простые и управляемые формы)

0. 52 02.09.19 14:40 Сейчас в теме
Обработка предназначена для небольшого магазина или для небольшой торговой сети. Позволяет оперативно пакетно погасить ВСД, списать проданную продукцию в системе Меркурий, реализована пакетная печать ВСД.
Авторизация проходит через Логин и Пароль, предназначенный для входа через веб интерфейс Меркурий.
Проверка была проведена на релизе Обычные формы: "Управление торговлей", редакция 10.3 (10.3.53.2).
Управляемые формы: Управление торговлей, редакция 11 (11.4.7.128) Бухгалтерия предприятия, редакция 3.0 (3.0.75.37) Розница, редакция 2.2 (2.2.4.20)

Перейти к публикации

independ; +1 Ответить
Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. eiv76 03.09.19 09:06 Сейчас в теме
Отличная обработка. Спасибо.
2. Mister_Gluck 52 03.09.19 09:40 Сейчас в теме
(1) стоит переписывать под управляемые формы?
trickster; independ; +2 Ответить
3. independ 1211 04.09.19 15:36 Сейчас в теме
(2) неплохо, я так понял, может работать в пустой конфигурации без привязки к типовой?
И управляемые формы нужны, хотя если использовать как автономное решение, можно работать и в ОФ
Отлично
4. Mister_Gluck 52 04.09.19 18:16 Сейчас в теме
(3) да может использоваться в любой конфигурации на неуправляемых формах, так как специфических функций и метаданных конфигурации, кроме имени пользователя не использовал и то только для автоавторизации.
В описании только одно не указал, что для печати с функцией сразу на принтер необходим foxit reader.
5. independ 1211 04.09.19 18:22 Сейчас в теме
(4) есть у меня клиент, у которого сильно все запущено, на днях с ним поработаем с помощью вашей обработки
Есть мысль, сделать автономную конфигурацию/решение с обработкой, добавить справочник пользователей Меркурий, чтобы не заставлять пользователей вводит логины/пароли и по быстрому гасить/списывать ВСД. Желающие есть.
6. Mister_Gluck 52 06.09.19 10:37 Сейчас в теме
(5) Исправил ошибку:
Индекс находится за пределами массива в функции модуля ЗначИзDOMКоллекцииБезИмени, Возврат НайденнаяСтрока[Индекс].Значение.


Исправил ошибку при пакетной печати
7. Гость 13.10.19 18:59
(2)
а как ее можно заполучить? мне тут срочно задачу поставили - с нуля разбираться и писать - времени нет.. да и надо то всего - подтверждение ВСД для начала прикрутить к некой самописке... вот думал вашу обработку за исходную взять и дальше уже крутить... но тут какие-то стармани и прочая ересь....готов приористи за разумные копейки )))
8. Гость 13.10.19 18:59
(2)
а как ее можно заполучить? мне тут срочно задачу поставили - с нуля разбираться и писать - времени нет.. да и надо то всего - подтверждение ВСД для начала прикрутить к некой самописке... вот думал вашу обработку за исходную взять и дальше уже крутить... но тут какие-то стартмани и прочая ересь....готов приобрести за разумные копейки )))
10. Mister_Gluck 52 14.10.19 09:02 Сейчас в теме
9. independ 1211 13.10.19 19:38 Сейчас в теме
Скачал обработку на УФ - отлично
11. VKuser30549868 16 18.10.19 11:13 Сейчас в теме
Для гашения требуется сопоставление? Можно загрузить в чистую базу все ВСД и в пару кликов погасить?
12. Mister_Gluck 52 18.10.19 11:59 Сейчас в теме
(11)никакого сопоставление. Просто открываете обработку, выбираете галочками какие ВСД погасить и жмете кнопку погасить - все. Делалось для своих операторов, чтобы сократить время.
13. Const885 31.10.19 09:16 Сейчас в теме
В УТ 11.4.10.62 ошибка при открытии формы ошибка 1.ВнешняяОбработка.ВетИСМеркурий.Форма.ФормаВводаПароля.Форма(54)}: Преобразование значения к типу Число не может быть выполнено
ФайлСПаролями = ПутьШаблонов + "\Secret";
2. И далее по коду ТекущаяСтрока = ТаблицаПаролей.Добавить(); а таблицы такой ни где нет.

поправьте, пожалуйста.
14. Mister_Gluck 52 31.10.19 12:31 Сейчас в теме
(13) Если не собираетесь использовать функцию предварительного сохранения в файл логинов и паролей от Меркурия закомментируйте в формеВводаПароля

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ПодключитьОбработчикОжидания("ПрочитатьФайлПаролей", 0.1,Истина);
КонецПроцедуры

Если собираетесь использовать, посмотрите есть ли у вас в файле C:\Users\Администратор\AppData\Roaming\1C\1CEStart\1CEStart.cfg
такая строчка ConfigurationTemplatesLocation=C:\Users\Администратор\AppData\Roaming\1C\1cv8\tmplts
15. andrey_Gavrilov 123 08.11.19 14:12 Сейчас в теме
Добрый день, в файле secret ИдентификаторХС где найти? Логин и пароль для входа в Меркурий есть, а вот ИдентификаторХС что то не могу найти. Или это все таки IssuerID , который выдает сервис Ветис.API?
16. Mister_Gluck 52 09.11.19 04:28 Сейчас в теме
(15) в обработке когда авторизуетесь выходят окошки с выбором предприятий и хс если ползунок вправо прокрутить будут эти цифры.
Кстати, там везде я перепутал ХС И ПРЕДПРИЯТИЕ местами с тем что на самом деле в системе
17. Mister_Gluck 52 11.11.19 04:49 Сейчас в теме
В параметры POST запроса при гашении продукции добавились новые значения для молочной продукции: белки, жирность, плотность.
18. andrey_Gavrilov 123 11.11.19 11:04 Сейчас в теме
(17) В форме все отображается, но гашение не происходит. Обработка для управляемых форм. Торговля 11. В Меркурии все как было, так и осталось.
Прикрепленные файлы:
19. Mister_Gluck 52 11.11.19 11:24 Сейчас в теме
(18) напишите сюда или в личные свою электронку
20. andrey_Gavrilov 123 11.11.19 13:17 Сейчас в теме
(19) Все заработало, разобрался. Спасибо за помощь!
21. andrey_Gavrilov 123 11.11.19 14:24 Сейчас в теме
(19) Нет, не заработало. Оказывается параллельно бухгалтер руками погасила ВСД
30. user647710_vnufer 17.12.19 13:25 Сейчас в теме
31. Mister_Gluck 52 18.12.19 03:34 Сейчас в теме
(30)можете скинуть гифку с момента авторизации
33. Mister_Gluck 52 19.12.19 06:42 Сейчас в теме
(30) Попробуйте авторизоваться не использовав файл secret, есть подозрение, что вы указываете не правильный номер ХС в нем
34. user647710_vnufer 19.12.19 07:52 Сейчас в теме
(33)Проблема была в том что заполнение ТаблицаЗначенийХС не присходило.
Пришлось вызов процедуры вывести из условия ЗаполнитьмТаблицаЗначенийХС(РезультатHTTPGETЗапроса);
61. Mister_Gluck 52 15.04.20 06:30 Сейчас в теме
С трудом понимаю как поставщик засунул в название товара управляющие команды DC1, DC2, DC3...
Попробуйте в функции Функция локРаскодироватьСтроку(Строка,локСпособКодированияСтроки,локКодировкаСтроки="")

Строку
Возврат ?(локКодировкаСтроки="", РаскодироватьСтроку(Строка,локлСпособКодированияСтроки),РаскодироватьСтроку(Строка,локлСпособКодированияСтроки,локКодировкаСтроки));

Заменить на

РаскодированнаяСтрока = ?(локКодировкаСтроки="", РаскодироватьСтроку(Строка,локлСпособКодированияСтроки),РаскодироватьСтроку(Строка,локлСпособКодированияСтроки,локКодировкаСтроки));
Возврат СтрЗаменить(РаскодированнаяСтрока,Символ(19),"");
22. independ 1211 06.12.19 14:13 Сейчас в теме
Перестало работать списание, на сайте Меркурия произошли изменения, в детали я пока не вникал
23. Mister_Gluck 52 09.12.19 04:08 Сейчас в теме
Замените в модуле главной формы код
РезультатHTTPPOSTЗапроса = ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","_action=addInventoryFactRemove&_language=ru&pk="+НомерИнвентаризации+"&inventory.pk="+НомерИнвентаризации+"&inventory.inventoryFact.operation=3&inventory.inventoryFact.traffic.uuid="+СтрПолучитьСтроку(UIDНомераПродукции,1) + "&inventory.inventoryFact.traffic.guid="+СтрПолучитьСтроку(UIDНомераПродукции,2));


на

РезультатHTTPPOSTЗапроса = ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","_action=addInventoryFactRemove&_language=ru&pk="+НомерИнвентаризации+"&inventory.pk="+НомерИнвентаризации+"&inventory.inventoryFact.operation=3&uuid="+СтрПолучитьСтроку(UIDНомераПродукции,1) + "&guid="+СтрПолучитьСтроку(UIDНомераПродукции,2));
independ; +1 Ответить
24. independ 1211 09.12.19 08:35 Сейчас в теме
28. walera9674 13.12.19 17:42 Сейчас в теме
добрый день. не могу писать лс, а ватсап не смог найти
29. VKuser30549868 16 17.12.19 13:12 Сейчас в теме
При загрузке обработки в Рознице 2,3,1,47 вылетает ошибка https://prnt.sc/qbyji8
Метод объекта не обнаружен (Найти)
{ВнешняяОбработка.ВетИСМеркурийУФ.Форма.ФормаВводаПароля.Форма(69)}: НайденнаяСтрока = ТаблицаПаролей.Найти(ПользователиИнформационнойБазыТекущийПользовательИмя(),"Пользователь")
32. Mister_Gluck 52 18.12.19 03:40 Сейчас в теме
(29)проверю как в рознице, дам вам рекомендации. На этой базе не тестировалось
35. Mister_Gluck 52 19.12.19 09:30 Сейчас в теме
(29) Посмотрите решение в http://forum.infostart.ru/forum9/topic224948/message2353192/#message2353192 попытаюсь в ближайшее время решить.
36. user1044932 20.12.19 13:50 Сейчас в теме
(35) при гашении страницы в Рознице ошибка:
Индекс находится за границами массива
{ВнешняяОбработка.ВетИСМеркурийУФ.Форма.ГлавнаяФорма.Форма(985)}: Возврат НайденнаяСтрока[Индекс].Значение;
{ВнешняяОбработка.ВетИСМеркурийУФ.Форма.ГлавнаяФорма.Форма(1458)}: POSTЗапрос = ?(ЗначИзDOMКоллекцииВURL("enterpriseName_"+ЗначИзDOMКоллекцииБезИмени("producer",1),1)="","",ЗначИзDOMКоллекции("1_enterprise"))+
Прикрепленные файлы:
37. Mister_Gluck 52 21.12.19 17:12 Сейчас в теме
(36)единичная какая то ВСД?
38. Mister_Gluck 52 23.12.19 04:19 Сейчас в теме
(36)
Возврат НайденнаяСтрока[Индекс].Значение;

Добавьте к условию в 984 строчке
Если НайденнаяСтрока.Количество() > 0

Если НайденнаяСтрока.Количество() > 0 И НайденнаяСтрока.Количество()>Индекс Тогда
39. user1044932 23.12.19 09:37 Сейчас в теме
(36)единичная какая то ВСД? Гашение 200 ВСД (страница) Ошибка не появлялась если гасить с 1й страницы,появлялась если гасить с любой больше 1й страницы.А страниц у нас много надо погасить 40000 всд.

в 984 строчке поправил,ошибка пропала,спасибо. Но погасив страницу,остаются не погашенные то 4 всд ,то 11 всд,то 70 нет закономерности на скриншоте результат гашения страницы остались не погашенные 4шт.

И в выборе предприятий не показывалось ко-во всд ,я решил эту проблему в 364 стр заменил fa-truck""></i>","</sup>")); на fa-truck""></i>","</a>"));
и добавил в
Функция НайтиТекстМеждуДвумяСтрочками(Строка,ТекстПеред,ТекстПосле)

Позиция = Найти(Строка,ТекстПеред);

Если Позиция = 0 Тогда
Возврат "";
КонецЕсли;

Результат = Сред(Строка,Позиция + СтрДлина(ТекстПеред));
Результат = Сред(Результат,1,Найти(Результат,ТекстПосле)-1);
Если Найти(Результат, "<sup>") Тогда
Результат = СокрЛП(СРед(Результат ,1,Найти(Результат,"<sup>")-1));
КонецЕсли;
Возврат Результат

КонецФункции
Прикрепленные файлы:
40. Mister_Gluck 52 23.12.19 10:51 Сейчас в теме
(39) версия обработки у вас от какой даты?
48. Mister_Gluck 52 25.12.19 07:08 Сейчас в теме
(36) замените строчку

POSTЗапрос = ?(ЗначИзDOMКоллекцииВURL("enterpriseName_"+ЗначИзDOMКоллекцииБезИмени("producer",1),1)="","",ЗначИзDOMКоллекции("1_enterprise"))+

на

POSTЗапрос = ?(ЗначИзDOMКоллекцииВURL(ЭлементыDOMВТаблицеЗначений,"enterpriseName_"+ЗначИзDOMКоллекцииБезИмени(ЭлементыDOMВТаблицеЗначений,"producer",1),1)="","",ЗначИзDOMКоллекции(ЭлементыDOMВТаблицеЗначений,"1_enterprise"))+
41. user1044932 23.12.19 11:09 Сейчас в теме
(40) последняя, v1 ,я вместе с VKuser30549868.Просто через него не удобно переписываться.
42. Mister_Gluck 52 23.12.19 11:21 Сейчас в теме
43. user1044932 23.12.19 12:02 Сейчас в теме
(42)
(41)почту напишите

VKuser30549868 в личке.
44. metaeditor 936 23.12.19 15:55 Сейчас в теме
скажите пожалуйства, эта обработка работатет через API или парсингом вэб страниц?
спрашиваю, потому-что грозятся блокировать пользователей которые работают через вэб интерфейс личного кабинета

https://vetrf.ru/vetrf/news/32747.html
http://fsvps.ru/fsvps/news/26881.html
45. user1044932 23.12.19 17:23 Сейчас в теме
46. Mister_Gluck 52 23.12.19 17:56 Сейчас в теме
(44)Товарищ майор, если бы Api Меркурия нормально работали и не были написаны индусскими программистами, вопросов о таких внедрениях не возникало бы. Но к сожалению, мы сами заказали внедрение через Api, которое нам обошлось в 100 тыс руб., но работать в нем так и не смогли..., поэтому будем сидеть до последнего.
47. metaeditor 936 24.12.19 04:01 Сейчас в теме
(46) жалко конечно, пользуемся сейчас похожим решением через парсинг страниц, но в связи с этой новостью приходится искать что-то другое простеннькое на api просто для гашения всд
49. Andrekaa 25.12.19 16:28 Сейчас в теме
Добрый день
"Обработка предназначена для небольшого магазина или для небольшой торговой сети."
а почему именно такое позиционирование обработки?
50. Mister_Gluck 52 25.12.19 17:58 Сейчас в теме
(49)потому, что у нее фактически только 2 функции оприходование (гашение всд) и списание остатков.
51. metaeditor 936 20.01.20 12:05 Сейчас в теме
Скажите, нормально работает обработка? Неделю назад перестала работать программа через которую мы гасили, видимо на сайте меркурия что-то поменяли. Думаю качать эту или нет.
52. Mister_Gluck 52 20.01.20 13:50 Сейчас в теме
(51)все свои функции еще выполняет
53. metaeditor 936 20.01.20 15:20 Сейчас в теме
(52) Можно ли приобрести обработку не через сайт, чтобы не заморачиваться со стартмани?
Напишите пожалуйста в личку, сам не могу написать, сайт не пропускает без баланса.
54. Mister_Gluck 52 20.01.20 16:04 Сейчас в теме
55. rex400 28.01.20 12:15 Сейчас в теме
Здравствуйте, при авторизации не активны поля ввода логин пароль, в чем может быть проблема?
56. Mister_Gluck 52 28.01.20 15:53 Сейчас в теме
(55) возможно что-то с APPDATA + \1C\1CEStart\1CEStart.cfg
Нет глобальной Windows переменной appdata?
Если по быстрому скопируйте код в процедуру при открытии формы Ввода паролей

ЭлементыФормы.Login.Доступность = Истина;
ЭлементыФормы.Password.Доступность = Истина;
ЭлементыФормы.ОсновныеДействияФормы.Кнопки.ОсновныеДействияФормыВыполнить.Доступность = Истина;
57. ivan8211 19.02.20 13:06 Сейчас в теме
Вываливается ошибка "Неверный логин или пароль", обработка еще работает?
58. Mister_Gluck 52 20.02.20 05:58 Сейчас в теме
59. ivan453 14.04.20 13:14 Сейчас в теме
При гашении некоторых ВСД выходит ошибка:
{ВнешняяОбработка.ВетИСМеркурийУФ.Форма.ГлавнаяФорма.Форма(923)}: Ошибка при вызове метода контекста (локРаскодироватьСтроку)
product = JSONВОбъект(локРаскодироватьСтроку(локРаскодироватьСтроку(ЗначИзDOMКоллекцииБезИмени("productItemJson"),"СпособКодированияСтроки.КодировкаURL"),"СпособКодированияСтроки.КодировкаURL"));
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
форма: Элемент
имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка при записи XDTO
по причине:
Текст XML содержит недопустимый символ в позиции 167 :
{"fromDict":true,"allFields":false,"ignore":false,"dictOnly":false,"productName":{"pk":7131022,"name":"99604 Активия Биопродукт творожно-йогуртный обог.Отруби злаки4,50гСт.ГЛ8"},"packaging":{},"subProductTemplate":"4a6978c4-aeb5-43ad-b074-08cc43cee265","firmTemplate":"f3e0072d-0136-46c9-8998-1aa7e4c5c5d2"}
Прикрепленные файлы:
60. Mister_Gluck 52 14.04.20 16:22 Сейчас в теме
(59)
{"fromDict":true,"allFields":false,"ignore":false,"dictOnly":false,"productName":{"pk":7131022,"name":"99604 Активия Биопродукт творожно-йогуртный обог.Отруби злаки4,50гСт.ГЛ8"},"packaging":{},"subProductTemplate":"4a6978c4-aeb5-43ad-b074-08cc43cee265","firmTemplate":"f3e0072d-0136-46c9-8998-1aa7e4c5c5d2"}


видно что поставщик поставил символ переноса строки после *злаки4,5*
сможете сами заменить строку кода?
62. tulapc 28.04.20 13:59 Сейчас в теме
Розница 2.3.3.25 всё работает, счастье!!!
63. tulapc 01.05.20 18:06 Сейчас в теме
Вот только возвратные ВСД не оформляет, гасит как 100% принятые, есть решение?
64. Mister_Gluck 52 02.05.20 12:38 Сейчас в теме
(63) 0 ставили в колонке количество?
65. tulapc 02.05.20 12:55 Сейчас в теме
66. 1с2с 52 20.05.20 14:41 Сейчас в теме
а если для обычного входа необходимо ввести код из СМС.....
это не будет препятствием для авторизации?...
67. Mister_Gluck 52 20.05.20 17:55 Сейчас в теме
(66) Да такой вариант я не делал.
В принципе, через отладку с точкой останова можно реализовать
68. yadanil1984 31.05.20 22:11 Сейчас в теме
Пишет: "Неверный логин или пароль", что делать? На сайте захожу без проблем
69. tulapc 10.06.20 09:42 Сейчас в теме
(68) такая же ситуация пароль +Vav17011974+
Где засада? просьба выслать обновление с молочной продукцией на tulapc*gmail.com
И нет возможности срок годности столбец сделать сортировку? удобнее было бы
70. Mister_Gluck 52 10.06.20 11:00 Сейчас в теме
В обновлении подправлен механизм с авторизацией паролем содержащим спецсимволы.
Проблема в том что надо сделать преобразование спецсимволов: ПреобразоватьКURL(Password)

Сортировку по дате сроку годности можете сделать выполнив запрос:
ВыполнитьHTTPPOSTЗапрос("/hs/operatorui",
"sortByFirst=bestBeforeDate&sortByFirstOrder=asc&sortBySecon­d=none&sortBySecondOrder=asc&sortByThird=none&sortByThirdOrd­er=asc&=&=&pageList=&_action=sortAjaxRealTrafficVU&_language­=ru&stateMenu=2&request=×tamp="+UnixВремя());
71. tulapc 10.06.20 11:20 Сейчас в теме
Пароль в новой версии приняла обработка, спасибо за оперативность
72. user635667 117 25.06.20 07:35 Сейчас в теме
Два вопрос:
1. Оказывается остатки надо списывать? у меня там больше 7000 наименований. Это обязательно? (вопрос юридического характера)))
2. Как сделать что бы автоматически авторизовывалось? че то я не понял где создавать файл secret. 1CEStart.cfg у меня пустой, там надо что-то написать? (открыл в блокноте)
73. Mister_Gluck 52 25.06.20 09:42 Сейчас в теме
(72)
1. Требования списывать остатки в день реализации как в ЕГАИСе для розничных магазинов вроде нет, но нам ветврач говорил, что необходимо их держать в более менее актуальном состоянии. Поэтому мы для себя решили раз в неделю списывать то, у чего срок годности подходит к концу.
2. Этот режим предназначен, если вы для каждого пользователя 1С решили сделать своего пользователя mercury, который будет заходить только в 1 Склад. Для простоты откройте обработку в режиме Конфигуратора, в форме ФормаПароля найдите Процедура ПрочитатьФайлПаролей()
Удалите код:
Shell = Новый COMОбъект("WScript.Shell");
APPDATA = Shell.ExpandEnvironmentStrings("%APPDATA%");

ИмяФайла = APPDATA + "\1C\1CEStart\1CEStart.cfg";
Файл = Новый Файл(ИмяФайла);
Если НЕ Файл.Существует() Тогда
Возврат;
КонецЕсли;

ТекстовыйДокумент = Новый ТекстовыйДокумент();
ТекстовыйДокумент.Прочитать(ИмяФайла);
ПутьШаблонов ="";
Для НомерСтроки = 1 По ТекстовыйДокумент.КоличествоСтрок() Цикл
Текст = ТекстовыйДокумент.ПолучитьСтроку(НомерСтроки);
Если ВРег(Лев(Текст,СтрДлина("ConfigurationTemplatesLocation")))=ВРег("ConfigurationTemplatesLocation") Тогда
ПутьШаблонов = Сред(Текст,Найти(Текст,"=")+1);
Прервать;
КонецЕсли;
КонецЦикла;
Показать


А вместо ФайлСПаролями = ПутьШаблонов + "\Secret";
Напишите ФайлСПаролями = "C:\Secret";
user635667; +1 Ответить
74. user635667 117 25.06.20 14:25 Сейчас в теме
(73)Спасибо за ответ. Еще вопрос - я правильно понял что данная обработка это своеобразный парсер сайта Меркурий? т.е. отправлять им запрос на открытие доступа к api не нужно, достаточно логина и пароля от сайта?
77. Mister_Gluck 52 25.06.20 19:06 Сейчас в теме
75. user635667 117 25.06.20 15:06 Сейчас в теме
И еще вопрос - на один комп мне не хватает лицензий 1с, я скачал и поставил туда учебную версию платформы 8.3.17. В не вроде все работает. Как думаете через какое-то время ничего не отвалится и не перестанет работать?
78. Mister_Gluck 52 25.06.20 19:09 Сейчас в теме
(75) думаю все будет работать. В учебной версии на сколько помню ограничения на колиство записей в справочниках
(76) да, не больше чем на 1 страницу поместится.
76. user635667 117 25.06.20 17:57 Сейчас в теме
Ну и еще один вопрос - если у меня накопится больше 200 непогашенных ВСД, например 500шт - они также разобьются на страницы по 200 и придется гасить за раз по 200 шт?
79. user600262_turbo2049 04.07.20 14:28 Сейчас в теме
Привет! Как бы попробывать обработку, конфиг Штрихвский Торговое предприятие 5.2
80. Mister_Gluck 52 05.07.20 15:12 Сейчас в теме
(79) привет, работать будет на любой даже пустой конфигурации. Торговое оборудование от Штриха вроде уже содержит полноценный модуль работы с Меркурием? Демо версии к сожалению нет. Могу подключить к своему компьютеру для демонстрации возможностей под вашим паролем, если хотите
81. user600262_turbo2049 05.07.20 15:41 Сейчас в теме
Можно и так попробывать, вообще с доступом к ТП я думаю проблем не будет. В Штриховском конфиге есть ВЕТИС, но нуже более простой функцианал, на данный момент времяни работа оператора по ВЕТИСу сводится к банальному гашению доков. Да и заморочки с API, а так просто логин и паролm для web входа в ЛК Меркурий. Так как с организуемся? Могу дать доступ к рабочей базе ТП для пробы, пароль и логи от ВЕТИСа есть. В принципе доспуп можно любым способом организовать
82. Mister_Gluck 52 06.07.20 03:58 Сейчас в теме
(81) напишите на почту на яндексе, здесь в ветке есть время UTC+6
83. user600262_turbo2049 06.07.20 07:57 Сейчас в теме
84. Mister_Gluck 52 06.07.20 08:57 Сейчас в теме
85. user635667 117 08.07.20 10:10 Сейчас в теме
Ошибка при обработке. С чем связано?
Прикрепленные файлы:
86. Mister_Gluck 52 08.07.20 10:56 Сейчас в теме
(85) Связана с названием товара, в ближайшем исправлении попробую решить эту проблему
88. user635667 117 15.10.20 08:34 Сейчас в теме
Привет. А такая проблема с чем связана?
Прикрепленные файлы:
89. Mister_Gluck 52 15.10.20 09:22 Сейчас в теме
(88)
Изменили HTML код на сайте, необходимо найти (для простых форм)

НомерИнвентаризации = НайтиТекстМеждуДвумяСтрочками(ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","inventoryDate="+Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy")+"&userFromReference=true&userManual.fio="+ ИмяСтрокой + "&user.pk="+мТеущийПользовательМеркурия.id+"&_action=addInventory&_language=ru&stateMenu=0"), "operatorui?_action=addInventoryFactForm&pk=","&_language=ru");


и заменить на

НомерИнвентаризации = НайтиТекстМеждуДвумяСтрочками(ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","inventoryDate="+Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy")+"&userFromReference=true&userManual.fio="+ ИмяСтрокой + "&user.pk="+мТеущийПользовательМеркурия.id+"&_action=addInventory&_language=ru&stateMenu=0"), "operatorui?_action=addInventoryFactForm&pk=","'");



Для УФ

НомерИнвентаризации = НайтиТекстМеждуДвумяСтрочками(ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","inventoryDate="+Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy")+"&userFromReference=true&userManual.fio="+ ИмяСтрокой + "&user.pk="+IDПользователяМеркурий+"&_action=addInventory&_language=ru&stateMenu=0"), "operatorui?_action=addInventoryFactForm&pk=","&_language=ru");

на
НомерИнвентаризации = НайтиТекстМеждуДвумяСтрочками(ВыполнитьHTTPPOSTЗапрос("/hs/operatorui","inventoryDate="+Формат(ТекущаяДата(),"ДФ=dd.MM.yyyy")+"&userFromReference=true&userManual.fio="+ ИмяСтрокой + "&user.pk="+IDПользователяМеркурий+"&_action=addInventory&_language­=ru&stateMenu=0"), "operatorui?_action=addInventoryFactForm&pk=","'");
masik777; nasonkin; independ; user635667; +4 Ответить
90. user1176704 03.03.21 15:33 Сейчас в теме
Привет! При авторизации появилось окошко проверки защиты от "роботов", картинка не отображается ни в простых, ни в управляемых формах!
Прикрепленные файлы:
91. independ 1211 03.03.21 17:24 Сейчас в теме
(90) нужно в личном кабинете ветис паспорт ввести номер паспорт + телефон
masik777; +1 Ответить
92. Practic75 17.03.21 09:53 Сейчас в теме
Добрый день. На УФ требует ввести капчу, а вместо нее только большой крест. Номер паспорта и телефон введены в Ветис.Паспорт
93. Practic75 17.03.21 09:59 Сейчас в теме
Разобрался - еще СНИЛС был нужен
masik777; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением