0. nagaitseff 108 13.08.19 12:45 Сейчас в теме

Произвольная начальная страница через расширение (программно)

Установка своей формы произвольному пользователю на начальную страницу.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. akim2040 15 14.08.19 10:26 Сейчас в теме
Я не внимательно читал, или не пойму.
чем отличие от более удобного изменения рабочего стола вот этой обработкой? https://infostart.ru/public/556324/

каждый пользователь что хочет, то и может себе поставить на рабочий стол
2. nagaitseff 108 14.08.19 11:30 Сейчас в теме
(1) Конечно можно использовать и предложенную вами обработку, но у пользователя должно быть право "Интерактивное открытие внешних обработок", что например для больших организаций не очень и часто такое право отключают у пользователей или не дают вовсе.
Способ же который я предложил, не только не зависит от этого права, но и позволяет еще использовать дополнительные обработки, которых нет в базе на поддержке, это как пример.
3. akim2040 15 14.08.19 11:31 Сейчас в теме
4. AlexeyPapanov 352 15.08.19 14:32 Сейчас в теме
А что за начальная страница на скриншоте к публикации? Не из УНФ случайно? Так понравилось. Хочу найти.
6. nagaitseff 108 16.08.19 03:47 Сейчас в теме
(4) Добрый день, да это УНФ.
5. Yashazz 2944 16.08.19 00:03 Сейчас в теме
7. nagaitseff 108 16.08.19 03:50 Сейчас в теме
(5) Очень приятно, я Евгений.
9. Yashazz 2944 16.08.19 14:35 Сейчас в теме
Интересна позиция официальных представителей ИС насчёт копирования материалов с its.1c.ru. У автора есть такое разрешение, ведь правда же?
10. nagaitseff 108 16.08.19 14:58 Сейчас в теме
(9) Добрый день, на сайте 1с написано, копирование материала, только с указанием ссылки на материал (ресурс). Ссылки в статье указал.
11. WellMaster 99 21.08.19 16:08 Сейчас в теме
Вот если вы найдете способ убрать с начальной страницы заголовок "Начальная страница" и кнопки перехода - цены вам не будет! )
12. Trucker 6 22.08.19 09:08 Сейчас в теме
(11)
В режиме РабочееМесто мы скрываем все панели и область системных команд (главное меню и набор вспомогательных команд). Скрываем надпись Начальная страница, кнопки навигации Вперед/Назад, а также отключаем сочетания клавиш, которые используются в этих скрытых элементах интерфейса.

https://wonderland.v8.1c.ru/blog/novye-rezhimy-osnovnogo-okna/
13. PowerBoy 2938 06.11.19 09:21 Сейчас в теме
(11)
&После("ПередНачаломРаботыСистемы")
Процедура Плам_ПередНачаломРаботыСистемы(Отказ)
	КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.РабочееМесто);
КонецПроцедуры
WellMaster; nagaitseff; +2 Ответить
14. nagaitseff 108 07.11.19 06:15 Сейчас в теме
(13)
КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.РабочееМесто);


Отличное решение.
16. WellMaster 99 20.11.19 16:10 Сейчас в теме
(13) Спасибо. Лишний повод обновить платформу.
15. nagaitseff 108 07.11.19 06:20 Сейчас в теме
(11) Используйте предложенный вариант 13. PowerBoy, работает изумительно.

Единственно что можно добавить, это ограничение по роли, например. Как в моем примере.

Но перехваченная процедура из модуля работает только в тонком клиенте, значит проверку на роль надо поместить например свой общий модуль, который исполняется на сервере.

А здесь написать следующее:

&После("ПередНачаломРаботыСистемы")
Процедура Плам_ПередНачаломРаботыСистемы(Отказ)
    Если МояРоль = Истина Тогда   //Моя роль это возврат функции с вашего общего модуля. 
        КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.РабочееМесто);
    КонецЕсли;
КонецПроцедуры


Еще можно попробовать дополнительно другие варианты, в предложенном используется "РабочееМесто", а есть еще "Киоск" и "ПолноэкранноеРабочееМесто".

Успехов!
WellMaster; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Воронеж
зарплата от 70 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день

Программист 1С
Чебоксары
зарплата от 50 000 руб. до 70 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб. до 120 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 150 000 руб.
Полный день