1. _Enot_ 6 13.08.19 12:44 Сейчас в теме

Добавление кнопки в РМК 1С Розница программно

Здравствуйте. Подскажите пожалуйста. Вообщем через расширения добавил кнопку в РМК, прописал команду к ней на открытие форма, но при нажатии выходит как я понимаю предупреждение (скрин ниже), и соответственно все, в отладку тоже не заходит. Кто сталкивался?
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. RocKeR_13 659 13.08.19 12:50 Сейчас в теме
(1) вы лучше скрины приложите, как добавляли) Кнопка добавлена как картинка/надпись или как кнопка формы? Если как картинка/надпись, то установили свойство "Гиперссылка"?
3. _Enot_ 6 13.08.19 12:58 Сейчас в теме
4. RocKeR_13 659 13.08.19 13:01 Сейчас в теме
(3) вы добавили эту кнопку как картинку. Вам в этом случае не нужна команда формы: у добавленного элемента формы ищите событие "При нажатии" и в обработчике этого события пишите необходимые действия
5. _Enot_ 6 13.08.19 13:08 Сейчас в теме
8. RocKeR_13 659 13.08.19 13:13 Сейчас в теме
(5) Стоп, а зачем используете директиву "Вместо", если процедуру свою добавляете? Выберите "Перед" или "После". Скорей всего у вас безопасный режим у расширения стоит , который директиву "Вместо" просто игнорирует
6. _Enot_ 6 13.08.19 13:08 Сейчас в теме
Добавил, все равно тоже самое получаеться
7. RocKeR_13 659 13.08.19 13:09 Сейчас в теме
10. _Enot_ 6 13.08.19 13:57 Сейчас в теме
(7)

После попробовал
&НаКлиенте
Процедура Расш2_ОпросПокупателяНажатиеПосле(Элемент, СтандартнаяОбработка)
ОткрытьФорму("Обработка.РМКУправляемыйРежим.Форма.ФормаОпросаПокупателя");
КонецПроцедуры
13. independ 559 13.08.19 17:38 Сейчас в теме
(10) Нужно сделать так, аналогично другим кнопкам в РМК
&НаКлиенте 
Процедура Расш2_ОпросПокупателяНажатиеПосле(Элемент, СтандартнаяОбработка) 
   СтандартнаяОбработка=Ложь
   ВыполнитьОткрытиеФормыОпросПокупателя();
КонецПроцедуры

&НаКлиенте 
Процедура ВыполнитьОткрытиеФормыОпросПокупателя() 
   ОткрытьФорму("Обработка.РМКУправляемыйРежим.Форма.ФормаОпросаПокупателя"); 
КонецПроцедуры
Показать
9. WalterMort 303 13.08.19 13:51 Сейчас в теме
В макете команд РМК изменения вносил?
11. _Enot_ 6 13.08.19 13:57 Сейчас в теме
(9)да делал изменения, там будет влиять если не правильно? Из - за макета?
12. WalterMort 303 13.08.19 17:08 Сейчас в теме
(11) Там из этого макета + настройки РМК все эти действия перепривязываются при создании формы.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день