1. StanFitt_1C 13.08.19 10:08 Сейчас в теме

Выборка нескольких значений в отчете

Добрый день, товарищи.
Возник такой вопрос, как передать несколько значений в фильтрах отчета?
Заранее спасибо.
Прикрепленные файлы:
Найденные решения
16. StanFitt_1C 14.08.19 13:41 Сейчас в теме
(14) Вот мое решение
&НаСервереБезКонтекста
Функция ОтделыОтборочка()
	Отборочка = Новый СписокЗначений;
	Отборочка.Добавить(Справочники.Должность.НайтиПоНаименованию("Программирования"));
	Отборочка.Добавить(Справочники.Должность.НайтиПоНаименованию("Дизайнеры"));
	Возврат Отборочка;
КонецФункции

Показать


Убрал доступность "Пользовательских настроек" и прописал:
Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Должность",ОтделыОтборочка());
Остальные ответы
Избранное Подписка Сортировка: Древо
2. lexin1976 9 13.08.19 10:28 Сейчас в теме
Ну так то тип сравнения "В списке".
А по этому случаю. Даже не знаю что сказать.
3. StanFitt_1C 13.08.19 11:02 Сейчас в теме
(2) Я именно про отчет спросил)
4. mazechild 13.08.19 11:13 Сейчас в теме
А что в кнопке настройки?
7. StanFitt_1C 13.08.19 12:59 Сейчас в теме
(4) Странный вопрос не по делу. Цель данной публикаций получить данные отчета одновременно по нескольким отделам.
5. x_x 3 13.08.19 12:15 Сейчас в теме
По идее в ОСКД в параметрах необходимо задать тип параметра Составной или Любая ссылка и когда заполняете есть в списке, а там уже накидываете что хотите? что вы подразумеваете под фильтром?
6. antz 13.08.19 12:20 Сейчас в теме
(1) Это?
Прикрепленные файлы:
StanFitt_1C; +1 Ответить
8. StanFitt_1C 13.08.19 13:11 Сейчас в теме
(6) Спасибо тебе добрый человек, но у меня ошибка при формировании.
Прикрепленные файлы:
9. davealone 126 13.08.19 14:09 Сейчас в теме
(8) А у вас Должность обязательная? Может убрать из параметров и сделать отбором?
Если нельзя, то поменять в запросе на Сотрудники.Должность В (&Должность)
acanta; StanFitt_1C; +2 Ответить
10. StanFitt_1C 13.08.19 14:13 Сейчас в теме
(9) Сделал так, заработало в одном отчете.
Теперь это же нужно попробовать сделать в сложном)
А так спасибо Вам)
11. StanFitt_1C 14.08.19 06:33 Сейчас в теме
(6) А как указать готовый список значений ручками, чтобы пользователь не мог менять значения?
12. antz 14.08.19 10:04 Сейчас в теме
(11) Если предопределенные элементы справочника - можно прямо в настройках вкорячить. Если нет - либо программное заполнение в ПриКомпоновкеРезультата или в модуле формы в ПриСозданииНаСервере, например, либо в самом запросе выбирать во временную таблицу, больше не знаю как. Ну и сам параметр из пользовательских настроек убрать.
StanFitt_1C; +1 Ответить
13. StanFitt_1C 14.08.19 12:07 Сейчас в теме
(12)К сожалению не получится использовать предопределенные элементы.
Есть пример или образец у Вас по поводу второго способа?
14. antz 14.08.19 13:11 Сейчас в теме
(13)

Из пользовательских настроек параметр убираем. Создаем форму отчета, там пишем

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	ДобавитьДолжностиВСписок();
	
КонецПроцедуры

&НаСервере
Процедура ДобавитьДолжностиВСписок()
	
	Список = Новый СписокЗначений;
	Список.Добавить(Справочники.Должности.НайтиПоНаименованию("Генеральный директор"));//или заполняем запросом, как угодно
	ЭлементНастроек = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[0];//индекс может быть другим, надо посмотреть в отладчике
	ЭлементНастроек.Значение = Список;
	ЭлементНастроек.Использование = Истина
	
КонецПроцедуры
Показать


Не забываем, что ПриОткрытии - событие формы, процедура должна быть к нему привязана.
15. StanFitt_1C 14.08.19 13:21 Сейчас в теме
(14)
Список = Новый СписокЗначений;
Список.Добавить(Справочники.Должности.НайтиПоНаименованию("Генеральный директор"));//или заполняем запросом, как угодно
ЭлементНастроек = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы[0];//индекс может быть другим, надо посмотреть в отладчике
ЭлементНастроек.Значение = Список;
ЭлементНастроек.Использование = Истина


{Отчет.ОтчетФинансистаВыборка.Форма.ФормаОтчета.Форма(59)}: Поле объекта не обнаружено (Значение)
ЭлементНастроек.Значение = Список;
16. StanFitt_1C 14.08.19 13:41 Сейчас в теме
(14) Вот мое решение
&НаСервереБезКонтекста
Функция ОтделыОтборочка()
	Отборочка = Новый СписокЗначений;
	Отборочка.Добавить(Справочники.Должность.НайтиПоНаименованию("Программирования"));
	Отборочка.Добавить(Справочники.Должность.НайтиПоНаименованию("Дизайнеры"));
	Возврат Отборочка;
КонецФункции

Показать


Убрал доступность "Пользовательских настроек" и прописал:
Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Должность",ОтделыОтборочка());
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день