1. darkmessiahan 96 11.07.19 21:01 Сейчас в теме

Как запустить ножницы (SnippingTool.exe) из 1с?

Ни одна строка не сработала
ЗапуститьПриложение("C:\Windows\System32\SnippingTool.exe");
ЗапуститьПриложение("SnippingTool.exe");
WshShell = Новый COMОбъект("WScript.Shell");
WshShell.Run("C:\Windows\System32\SnippingTool.exe", 5, -1);//, 1, 0);
Вознаграждение за ответ
Показать полностью
Найденные решения
30. SlavaKron 12.07.19 15:20 Сейчас в теме +0.2 $m
24. Xershi 677 12.07.19 14:59 Сейчас в теме +0.05 $m
В (14) ответ!
Прикрепленные файлы:
1.bat
ЗапуститьНожницыУФ.epf
darkmessiahan; +1 Ответить
29. darkmessiahan 96 12.07.19 15:19 Сейчас в теме
(26) Так получилось без БАТ. Тестировал Пока только на одном ПК
//Выходит дурацкое окно CMD, мешает сделать снимок
Процедура КнопкаВыполнитьНажатие(Кнопка)
	WshShell = Новый COMОбъект("WScript.Shell");
	WshShell.Run("cmd.exe /c SnippingTool.exe", 5, -1);
КонецПроцедуры
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Fox-trot 93 11.07.19 21:05 Сейчас в теме
3. darkmessiahan 96 11.07.19 21:07 Сейчас в теме
(2) если это обычное приложение, нужно указывать код в форме?
А не в модуле обработки
4. Fox-trot 93 11.07.19 21:26 Сейчас в теме
(3) только на клиенте, а иначе ты его (окно запущенного приложения) не увидишь
5. darkmessiahan 96 11.07.19 22:06 Сейчас в теме
(4) не работает)
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ЗапуститьПриложение("C:\Windows\System32\SnippingTool.exe");
	ЗапуститьПриложение("SnippingTool.exe");
	WshShell = Новый COMОбъект("WScript.Shell");
	WshShell.Run("C:\Windows\System32\SnippingTool.exe", 5, -1);//, 1, 0);
КонецПроцедуры
Показать
6. spec8s 308 11.07.19 22:14 Сейчас в теме
(5)
SnippingTool.exe

Из командной строки получается запустить?

Вот так у меня получилось запустить:

ЗапуститьПриложение("SnippingTool.exe", "C:\Windows\System32");
7. darkmessiahan 96 11.07.19 22:27 Сейчас в теме
(6)
Из командной строки получается запустить?
получается
8. Xershi 677 11.07.19 22:28 Сейчас в теме
(5) на кнопку повесь. При открытии форма еще не открыта.
9. darkmessiahan 96 12.07.19 00:43 Сейчас в теме
(8) (4) не работает
&НаКлиенте
Процедура Команда1(Команда)
		//ЗапуститьПриложение("C:\Windows\System32\SnippingTool.exe", "C:\Windows\System32");
		ЗапуститьПриложение("SnippingTool.exe", "C:\Windows\System32");
КонецПроцедуры
10. ben19791010 12.07.19 07:38 Сейчас в теме
(9)%windir%\system32\SnippingTool.exe разве не так?
это не через выполнить разве делается?
11. darkmessiahan 96 12.07.19 08:00 Сейчас в теме
(10) {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(17)}: Ошибка компиляции при вычислении выражения или выполнении фрагмента кода
Выполнить("%windir%\system32\SnippingTool.exe");
по причине:
{(1,1)}: Неопознанный оператор
<<?>>%windir%\system32\SnippingTool.exe
16. ben19791010 12.07.19 09:03 Сейчас в теме
(11)
Выполнить("%windir%\system32\SnippingTool.exe");

неее...Вы чего? это ж объект винды
выполнить это команда windows
Прикрепленные файлы:
12. darkmessiahan 96 12.07.19 08:01 Сейчас в теме
(10)
%windir%\system32\SnippingTool.exe

{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(16)}: Ошибка при вызове метода контекста (ЗапуститьПриложение)
ЗапуститьПриложение("%windir%\system32\SnippingTool.exe", "C:\Windows\System32");
по причине:
Использование синхронных методов на клиенте запрещено!
13. darkmessiahan 96 12.07.19 08:04 Сейчас в теме
(12)
Использование синхронных методов на клиенте запрещено!

после включения синхр методов
Прикрепленные файлы:
18. Xershi 677 12.07.19 09:40 Сейчас в теме
(13) покажи каталог в проводнике.
14. Xershi 677 12.07.19 08:17 Сейчас в теме
(9) значит в битности дело или код не переписали на асинхронный.
15. darkmessiahan 96 12.07.19 08:32 Сейчас в теме
(14) вы сначала запустите, а потом говорите что я не так что то сделал)
Прикрепленные файлы:
ЗапуститьНожницыУФ.epf
17. Xershi 677 12.07.19 09:39 Сейчас в теме
(15) буду на пк попробую.
Возможно дело в антивирусе.
21. Xershi 677 12.07.19 14:29 Сейчас в теме
(15) так а где вы переписали на асинхронный вызов?
23. darkmessiahan 96 12.07.19 14:44 Сейчас в теме
(21) ничего не переписывал, в свойствах конфигурации что то поменял. Что бы ошибка с синхронн не выходила.
А только старая ошибка "А где же наши ножницы, не знаем таких" (с) Windows и 1C.
24. Xershi 677 12.07.19 14:59 Сейчас в теме +0.05 $m
В (14) ответ!
Прикрепленные файлы:
1.bat
ЗапуститьНожницыУФ.epf
darkmessiahan; +1 Ответить
25. darkmessiahan 96 12.07.19 15:02 Сейчас в теме
(24) пошел тестировать столь важное чудо)
27. darkmessiahan 96 12.07.19 15:05 Сейчас в теме
(24) Как костыль сойдет. Поздравляю)
19. MegasXXX 12.07.19 13:22 Сейчас в теме
Бред какой то.
Я тоже кинулся запускать эти "ножницы" - вот вообще никак не запускаются, всё(notepad, mspaint и тд...) запускается и по пути и без пути.... а ножницы как будто не существуют для 1С.
Я даже через BAT файл создаваемый в 1с пытался.... нечего не помогает. Вообще нечего не происходит. Причём если этот батник клацнуть мышкой, то всё нормально запускается.
Если получится сообщите как, очень интересно!
20. DJDUH 17 12.07.19 13:29 Сейчас в теме
Тоже игрался пол дня.

По логам виндельса ошибок нет(.

Подписался...
22. SlavaKron 12.07.19 14:36 Сейчас в теме
Странно, пишу:
ЗапуститьПриложение("C:\Windows\system32\SnippingTool.exe");

Приложение 1С 32-битное. А по факту 1С ищет этот файл в системной папке C:\Windows\SysWOW64

Если перенести SnippingTool.exe в C:\Windows\SysWOW64, тогда ошибку будет выдавать уже сама SnippingTool.
Прикрепленные файлы:
darkmessiahan; +1 Ответить
26. Xershi 677 12.07.19 15:03 Сейчас в теме
В принципе можно попробовать написать в ТП и подумать что они ответят, но возможно проблема в том что у меня на ПК разные битности стоят или проблема в винде.
Но по факту что было 32 битное приложение пыталось запустить 64-битное и не находило.
Проблема эта платформы или ОС спорно, да и на скорость решения не влияет!
28. darkmessiahan 96 12.07.19 15:06 Сейчас в теме
(26) это массовая проблема, на 4 ПК пробовал. Правда все 64х.
29. darkmessiahan 96 12.07.19 15:19 Сейчас в теме
(26) Так получилось без БАТ. Тестировал Пока только на одном ПК
//Выходит дурацкое окно CMD, мешает сделать снимок
Процедура КнопкаВыполнитьНажатие(Кнопка)
	WshShell = Новый COMОбъект("WScript.Shell");
	WshShell.Run("cmd.exe /c SnippingTool.exe", 5, -1);
КонецПроцедуры
30. SlavaKron 12.07.19 15:20 Сейчас в теме +0.2 $m
31. darkmessiahan 96 12.07.19 15:26 Сейчас в теме
(30)
ЗапуститьПриложение("SnippingTool", "C:\Windows\Sysnative");

Да, работает, и без дурацких окон cmd
MegasXXX; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству