1. AlenkaInt 25 11.07.19 17:32 Сейчас в теме

Перенос строки в письме

Добрый день!
Подскажите, как сделать, чтобы в письме был перенос строки?
Использую символ "|". В каких то строках он срабатывает, а в каких то нет. Символ.ПС не работает. Символ.ВК тоже.
Помогите пож.
Ответы
Избранное Подписка Сортировка: Древо
2. Boneman 222 11.07.19 17:40 Сейчас в теме
(1) если письма в HTML формате, то там строка закрывается </P>
а начинается <P>
3. AlenkaInt 25 11.07.19 17:47 Сейчас в теме
(2)

Нет, не в HTML формате. Причем в каких то случаях "|" нормально отрабатывает. Из 6 строк в 2.
4. darkmessiahan 91 11.07.19 20:03 Сейчас в теме
(3) а в каком формате?
Письмо = Новый ИнтернетПочтовоеСообщение;	
// добавляем текст
Текст = Письмо.Тексты.Добавить(Тело);
	Если ПараметрыПисьма.Свойство("ТипТекста", ТипТекста) Тогда
		Если ТипЗнч(ТипТекста) = Тип("Строка") Тогда
			Если      ТипТекста = "HTML" Тогда
				Текст.ТипТекста = ТипТекстаПочтовогоСообщения.HTML;
			ИначеЕсли ТипТекста = "RichText" Тогда
				Текст.ТипТекста = ТипТекстаПочтовогоСообщения.РазмеченныйТекст;
			Иначе
				Текст.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
			КонецЕсли;
		Иначе
			Текст.ТипТекста = ТипТекста;
		КонецЕсли;
	Иначе
		Текст.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
КонецЕсли;
Показать
5. AlenkaInt 25 11.07.19 21:40 Сейчас в теме
(4)
Сообщение = Новый ИнтернетПочтовоеСообщение(); 		  
ИнтернетТекстПочтовогоСообщения = Сообщение.Тексты.Добавить();
ИнтернетТекстПочтовогоСообщения.Текст = ТекстСообщения;
ИнтернетТекстПочтовогоСообщения.ТипТекста = ТипТекстаПочтовогоСообщения.ПростойТекст;
Почта.Послать(Сообщение);
6. darkmessiahan 91 11.07.19 21:43 Сейчас в теме
(5)
ПростойТекст
почему именно он
вместо столь удобного и универсального HTML
7. AlenkaInt 25 11.07.19 23:11 Сейчас в теме
(6) Конфа уже досталась такой. Что то можно сделать с тем, что есть?
8. spacecraft 12.07.19 00:00 Сейчас в теме
(1)
Символ.ПС не работает. Символ.ВК тоже

Можно попробовать использовать их вместе:
Текст = СтрокаТекста + Символы.ПС + Символы.ВК
9. AlenkaInt 25 12.07.19 00:09 Сейчас в теме
(8) Так тоже пробовала, получалась одна лишняя строка.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
Полный день

Программист 1С
Нижневартовск
зарплата от 60 000 руб.
Полный день

Руководитель проекта, аналитик, консультант
Санкт-Петербург
По совместительству

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день