Markdown-editor в 1С (с сохранением в HTML)

0. 334 04.07.19 13:00 Сейчас в теме
В этой обработке вы пишете свой текст, используя синтаксис Markdown, а на выходе получаете чистый HTML-код, избавленный от JS-библиотеки, которая его сформировала. Совместим с Webkit и IE.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. infosoft-v 560 04.07.19 14:45 Сейчас в теме
Отлично! Спасибо.
json; YPermitin; +2 Ответить
2. json 2948 05.07.19 09:46 Сейчас в теме
Но я не вижу причин, чтобы оно не работало на любой другой конфигурации на Управляемых формах.


Минимальный режим совместимости 8.3.7.
На платформе 8.3.10 и ниже - не работает

А так тема крутая, спасибо!
3. riposte 334 05.07.19 10:16 Сейчас в теме
(2)
Минимальный режим совместимости 8.3.7.
На платформе 8.3.10 и ниже - не работает

Спасибо.
4. PolAlex2 118 03.12.20 19:26 Сейчас в теме
Добрый день! Планируется ли доработка под новые платформы?
Начиная с платформы 3.8.15 (или 8.3.14) она больше не работает, так как не заточена под WebKit...

И сразу еще вопрос - сама конвертация без HTML-поля (без визуала) будет работать или нет? Код не успел еще посмотреть..
5. riposte 334 05.12.20 22:52 Сейчас в теме
Попробую на досуге сделать универсальный вариант.
(4)
сама конвертация без HTML-поля (без визуала) будет работать или нет?

На сколько я понял, HTML-страница без отображения - просто не формируется. Т.е. у нее не сработает событие ДокументСформирован. А значит и выполнения скриптов не будет.
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	тест = "https://google.com";
	тест_скрыто = "https://google.com";
КонецПроцедуры

&НаКлиенте
Процедура тестДокументСформирован(Элемент)
	Сообщить("тест сформирован");
КонецПроцедуры

&НаКлиенте
Процедура тест_скрытоДокументСформирован(Элемент)
	Сообщить("тест_скрыто сформирован");
КонецПроцедуры

Показать
Прикрепленные файлы:
6. riposte 334 16.01.21 02:20 Сейчас в теме
Обновлено до версии 1.1.0.1
Добавлена поддержка Webkit.
Дмитрий74Чел; +1 Ответить
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Руководитель проектов 1С
Москва
зарплата от 200 000 руб.
Полный день

Консультант-аналитик 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день

Аналитик 1С ERP
Санкт-Петербург
зарплата до 200 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб.
Полный день