1. jimli 11.06.19 14:36 Сейчас в теме

Сделать выпадающий список в ТЗ с полями из таблицы Товары документа ПоступлениеТоваровУслуг

Замучилась...
УТ10.3, обычные формы.
Нужно сделать соответствие между полями, загружаемыми из файла и полями таблицы Товары документа ПоступлениеТоваровУслуг
Загружаю данные из файла в тзФайл
Есть ссылка на документ ПоступлениеТоваровУслуг

На форму добавила тзСоответствиеКолонок, в ней сделала 2 колонки: ИзФайла и ВПоляТаблицы. У каждой колонки Элемент управления - Поле выбора
Мне нужно, чтобы после загрузки данных в тзФайл в колонке ИзФайла в поле выбора появлялся список выбора, соответствующий полям тзФайл. А в колонке ВПоляТаблицы в поле выбора появлялся список выбора, соответствующий полям тч Товары.

Не могу докопаться, как заполнить списки выбора?
Ответы
Избранное Подписка Сортировка: Древо
2. JohnGalt 14 11.06.19 14:54 Сейчас в теме
В цикле перебрать колонки ТЗ и ячейки с названиями колонок в файле и заполнить свойство элемента формы "СписокВыбора", Элементами формы в данном случае будут поля в тзСоответствиеКолонок
3. jimli 11.06.19 15:05 Сейчас в теме
(2) Спасибо! Не получается само присвоение

	
СП = новый СписокЗначений;
Для Каждого кол из тзТовары.Колонки цикл
		СП.Добавить(кол.имя)
КонецЦикла;

ЭлементыФормы.тзСоответствиеКол.Значение.Колонки.Файл.ПолеВыбора.СписокВыбора = сп;
4. Isa816 19 11.06.19 15:08 Сейчас в теме
(3) Как то так
Для Каждого кол из тзТовары.Колонки цикл
ЭлементыФормы.тзСоответствиеКол.Значение.Колонки.Файл.ПолеВыбора.СписокВыбора.Добавить(кол.имя);
КонецЦикла;
9. jimli 11.06.19 15:29 Сейчас в теме
(4) Ошибка.
{ВнешняяОбработка.ИмпортИзФайлов.Форма.Форма.Форма(1315)}:
Поле объекта не обнаружено (ПолеВыбора)
ЭлементыФормы.тзСоответствиеКол.Значение.Колонки.ИзФайла.ПолеВыбора.СписокВыбора.Добавить(кол.имя);
5. x_x 3 11.06.19 15:09 Сейчас в теме
1. вы сформировли список выбора это хорошо, а дальше?


у вас событие у ячейки "НачаловыбораИзСписка" есть и галочка установлена использовать выбор из списка?
6. jimli 11.06.19 15:15 Сейчас в теме
(5) События нет, а галочку не нашла... Пыталась при чтении файла заполнять.
7. Isa816 19 11.06.19 15:18 Сейчас в теме
(6) Вот тут она
Прикрепленные файлы:
8. jimli 11.06.19 15:26 Сейчас в теме
(7) Спасибо! У меня обычные формы, выбор из списка используется, если его предопределить. Ругается на констркцию

ЭлементыФормы.тзСоответствиеКол.Значение.Колонки.ИзФайла.ПолеВыбора.СписокВыбора = СП;
{(1)}: Поле объекта не обнаружено (ПолеВыбора)

Не понимаю, как присвоить список значений в поле ТЗ.
12. Isa816 19 11.06.19 15:46 Сейчас в теме
(8) Сделал вот так, проверил работает

&НаКлиенте
Процедура ТЗПриАктивизацииСтроки(Элемент)
Элемент.ПодчиненныеЭлементы.ТЗРеквизитТЗ.СписокВыбора.Очистить();
Элемент.ПодчиненныеЭлементы.ТЗРеквизитТЗ.СписокВыбора.Добавить("Тест");
КонецПроцедуры
Прикрепленные файлы:
11. jimli 11.06.19 15:45 Сейчас в теме
(5) спасибо за наводку!
Процедура тзСоответствиеКолФайлНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
  Список = Элемент.СписокВыбора;	
  Список.очистить();
   Для Каждого кол из тзФайл.Колонки цикл 
		Список.Добавить(кол.имя);
	КонецЦикла;
   
КонецПроцедуры

Процедура тзСоответствиеКолВПоляТаблицыНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
  Список = Элемент.СписокВыбора;	
  Список.очистить();
  
   Для Каждого кол из тзТовары.Колонки цикл 
		Список.Добавить(кол.имя);
	КонецЦикла;
КонецПроцедуры

Показать
10. jimli 11.06.19 15:36 Сейчас в теме
Форма


Процедура КоманднаяПанель3Действие(Кнопка)
	
Для Каждого кол из тзТовары.Колонки цикл 
		ЭлементыФормы.тзСоответствиеКол.Значение.Колонки.ИзФайла.ПолеВыбора.СписокВыбора.Добавить(кол.имя);
КонецЦикла;

КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Бобров
зарплата от 100 000 руб. до 150 000 руб.
Временный (на проект)

Студент (стажер) 1С
Нижний Новгород
зарплата от 25 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 80 000 руб.
Полный день