Как открыть упр форму на весь экран

1. Gendelf 10.06.19 13:02 Сейчас в теме
Добрый день, есть пара вопросов, делаю рабочий стол пользователя, ничего другого для работы ему не нужно, следовательно Режим открытия окна = Блокировать весь интерфейс.
1) Как открыть окно рабочего стола на весь экран?
2) Как убрать сверху галку закрытия окна? Свойство "отображать кнопку закрытия" снял, толку нет.
По теме из базы знаний
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. laperuz 46 10.06.19 13:08 Сейчас в теме
(1)
Посмотрите в сторону режима Киоск (появился, если не ошибаюсь, в версии 8.3.10).
Я решал подобную задачу именно через него.

P.S. Собственно, скрытие кнопки закрытия работает только в новых режимах

Ещё одно новое свойство управляемой формы, ОтображатьКнопкуЗакрытия, позволяет вам скрыть кнопку закрытия формы и одновременно отключить стандартные действия, выполняемые по клавише Esc. Оно работает только в новых режимах открытия основного окна РабочееМесто, ПолноэкранноеРабочееМесто или Киоск.

С помощью этого свойства вы можете создавать формы, которые пользователь не сможет закрыть стандартными способами. Предполагается, что для таких форм вы определите иной способ закрытия.
3. Gendelf 10.06.19 13:14 Сейчас в теме
(2) спасибо, про Киоск не знал, нашёл вот. Изучаю.
4. Gendelf 10.06.19 13:18 Сейчас в теме
(2) Изменение режима не удобно, тут бы настройку для конкретного окна...
5. Sergitax 11.06.19 09:32 Сейчас в теме
(1)
В управляемых формах окно открывается на весь экран только если установлен режим открытия формы "Независимый" (есть в свойствах формы). Во всех остальных случаях это окно (не на всю область приложения).
KirillZ44; +1 Ответить
6. Gendelf 13.06.19 09:59 Сейчас в теме
(5) У меня как раз "Независимый" , можно программно или в свойствах его сразу открыть на весь экран? Вручную работает, но необходимо сразу.
7. Sergitax 13.06.19 12:06 Сейчас в теме
(6) Если Вы открываете форму программно через метод "ОткрытьФорму()", то последний параметр (8-й) как раз и отвечает за режим открытия окна формы. Даже если у вас с свойствах формы установлен режим "Независимый", то при программном открытии формы его можно переопределить. В вашем случае и там необходимо указать:

РежимОткрытияОкнаФормы.Независимый


И форма должна будет открыться на весь экран.

И еще: если вы добавляете свою форму на начальную страницу - то она по определению будет открыта на всю область приложения.
lan_krsk; wild83; Istur; +3 Ответить
8. Gendelf 13.06.19 12:25 Сейчас в теме
(7) В свойствах формы проставил, при открытии формы тоже указал параметр. Форма так осталась маленькой по центру экрана.
Попытаюсь настроить начальную страницу с этой формой, для одной учетки. Не знаю пока что из этого получится.
14. pashamak 310 19.06.24 07:00 Сейчас в теме
(1)Заметил особенность что окно разворачивается на весь экран только если нет открытых модальных окон и у открываемого окна установлен режим открытия окна "Независимый".

В похожем кейсе при начале работы системы у пользователя установил режим киоска "КлиентскоеПриложение.УстановитьРежимОсновногоОкна(РежимОсновногоОкнаКлиентскогоПриложения.Киоск);"
В рабочую область начальной страницы выставил нужную форму обработки с указанным свойством режима открытия окна "Независимый" у самой формы. Далее все формы открываются не модально и только как назависимые методом открыть форму.

Работает как в тонком клиенте так и в мобильном клиенте.
Прикрепленные файлы:
9. hansel 18 17.04.20 13:32 Сейчас в теме
На версии 8.3.16.1148 тонкий клиент УФ
РежимОткрытияОкна = Блокировать весь интерфейс

Окно можно максимизировать так:

&НаКлиенте
Процедура ПриОткрытии(Отказ)

	WSHShell = Новый COMОбъект("WScript.Shell");
	WSHShell.SendKeys("% ");
	WSHShell.SendKeys("{DOWN}{DOWN}{DOWN}{DOWN}{ENTER}");
    
КонецПроцедуры
user1252779; myoker; itserve; aka Любитель XML; +4 Ответить
10. aka Любитель XML 17.04.20 15:37 Сейчас в теме
(9) +1. Делал именно так, но у меня такой код:
 Попытка
    	WSHShell = Новый COMОбъект("WScript.Shell");
    	WSHShell.SendKeys("% ");
   		WSHShell.SendKeys("{UP}{UP}{ENTER}");
    Исключение
	КонецПопытки;


также сделал чтобы по крестику не закрывалось:
&НаКлиенте
Процедура ПередЗакрытием(Отказ, СтандартнаяОбработка)
	Отказ = Истина;
КонецПроцедуры
Показать


и добавил кнопку, которая закрывает 1с по нажатию:

&НаКлиенте
Процедура Выход(Команда)
	ЗавершитьРаботуСистемы(ложь);
КонецПроцедуры


Платформа 8.3.13, режим совместимости 8.2.16
NightRain; Infected; GG_Dots; +3 Ответить
11. fixin 4262 09.02.23 20:55 Сейчас в теме
(10) Что-то у меня не сработало, поэтому просто сделал группу без отображения с большой шириной и высотой.
12. alex_imfi 13 12.10.23 15:18 Сейчас в теме
WSHShell = Новый COMОбъект("WScript.Shell");
WSHShell.SendKeys("^%F");
user1457274; +1 Ответить
13. user1457274 05.04.24 03:41 Сейчас в теме
(12)
Единственный рабочий вариант оказался. Win10
15. pashamak 310 19.06.24 07:26 Сейчас в теме
(10)Заметил при наличии модального окна окно открытое в режиме "Независимый" не разворачивается
16. pashamak 310 19.06.24 07:28 Сейчас в теме
Решил похожую проблему следующим образом:
1. при начала работы системы установил пользователю режим киоск
2. в рабочую область начальной страницы добавил "стартовую" обработку
3. все последующие окна открывал как независимые
Прикрепленные файлы:
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот