1. frodoirbit 20.05.19 11:00 Сейчас в теме

Как перемножить таблицы

Добрый день Уважаемые!
Возник вопрос, возможно Вы подскажите как его оптимально решить.
Пытаюсь сделать закрытие счета.
Мне нужно взять одну таблицу (каждую строку) (один счет) разделить на ИТОГ другого счета и умножит на каждую строку второго счета. Так вот я голову сломал каким способом это реализовать. Помогите
Ответы
Избранное Подписка Сортировка: Древо
2. ksen 20.05.19 11:04 Сейчас в теме
на всякий случай уточню, таблицы вообще никак не связаны? Просто нужно умножение матриц?
3. frodoirbit 20.05.19 11:06 Сейчас в теме
(2) Нет не связаны, беру одну таблицу с одного счета 20 и вторую с 25 счета
4. ksen 20.05.19 11:12 Сейчас в теме
(3)
for Row in table1:
    total=Row/ITOG;
    for Row2 in table2:
        total=total*Row2;
5. Romeo_1c_programmer 19 20.05.19 11:13 Сейчас в теме
Может такой вариант подойдет
ИтогоТ2 = Т2.Итог("Сумма");
Для каждого Стр1 из Т1 Цикл
	Сумма = Стр1.Сумма;
	Для каждого Стр2 из Т2 Цикл
	 	Стр1.Сумма = Стр1.Сумма + (Сумма/ИтогоТ2 * Стр2.Сумма);
	КонецЦикла;
КонецЦикла;
6. ksen 20.05.19 11:16 Сейчас в теме
(5)Вроде как по тз разделить надо 1 раз а не m*n.
7. Romeo_1c_programmer 19 20.05.19 11:20 Сейчас в теме
>>каждую строку) (один счет) разделить на ИТОГ другого счета
ИтогоТ2 = Т2.Итог("Сумма");
Для каждого Стр1 из Т1 Цикл
    Сумма = Стр1.Сумма/ИтогоТ2;
    Для каждого Стр2 из Т2 Цикл
         Стр1.Сумма = Стр1.Сумма + (Сумма * Стр2.Сумма);
    КонецЦикла;
КонецЦикла;
16. Oldsad 21.05.19 04:45 Сейчас в теме
(7)
это эквивалентно
ИтогоТ2 = Т2.Итог("Сумма");
Для каждого Стр1 из Т1 Цикл
    Сумма = Стр1.Сумма/ИтогоТ2;
    Стр1.Сумма = Стр1.Сумма + Стр1.Сумма;
КонецЦикла;
8. frodoirbit 20.05.19 11:23 Сейчас в теме
В примере опишу беру каждую строку 25 счета делю на итог 20 потом умножаю на каждую строку 20
9. ksen 20.05.19 11:24 Сейчас в теме
(8) какая размерность должна получиться на выходе? Допустим в Т1 20 строк, в Т2 15, Если на выходе нужна таблица в 20 строк то (4)

(7) Стр1.Сумма = Стр1.Сумма + (Сумма * Стр2.Сумма); Откуда сумма то?
10. frodoirbit 20.05.19 11:27 Сейчас в теме
(9)я полагаю будет повторятся столько количество раз сколько строк на 20 счете
13. ksen 20.05.19 11:32 Сейчас в теме
(10)
"я полагаю"
Эмм, думаю вам для начало надо точно определиться что вы хотите получить, потом уже задавать конкретные вопросы. Ну или хотя бы пример со столбцами 3x3 сюда написать.
alex-l19041; +1 Ответить
11. Romeo_1c_programmer 19 20.05.19 11:28 Сейчас в теме
(9)
дополнительная переменная для хранения промежуточного результата
Сумма = Стр1.Сумма/ИтогоТ2;
14. ksen 20.05.19 11:36 Сейчас в теме
(11)Я не про это, где в сообщениях автора вы увидели слово сумма чтобы получить данную конструкцию Стр1.Сумма + (Сумма * Стр2.Сумма)?
12. frodoirbit 20.05.19 11:31 Сейчас в теме
на 25 счете берутся строки к примеру Амортизация, зарплата, отчисления и тд
15. KirinaAS 49 20.05.19 17:09 Сейчас в теме
я только вот не совсем поняла задачу, вот у вас есть на 25 счете амортизация, вы хотите на 20 найти ТОЛЬКО амортизацию, найти произведение 25 на 20 и разделить на итог по амортизации на 20? Или вы хотите амортизацию умножить на каждую статью затрат на 20 счете и разделить на общий итог 20?
17. Oldsad 21.05.19 04:54 Сейчас в теме
вы не можите сформулировать задачу, поэтому и не получается ее решить
как я уже писал выше если сумму разделить на итог таблицы, а потом умножить на каждую строчку этой таблицы и сложить, то получим ту же самую сумму с которой начинали
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Бобров
зарплата от 100 000 руб. до 150 000 руб.
Временный (на проект)

Студент (стажер) 1С
Нижний Новгород
зарплата от 25 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 90 000 руб. до 150 000 руб.
Полный день