1. Mister_1C 16.05.19 16:21 Сейчас в теме

Отправка на почту с 1с

Здравствуйте, возникла ошибка. Не могу понять в чем проблема. 1С 7.7 Самописная. Хочу реализовать отправку по почте с 1С. Но что то не выходит!)
Процедура Сформировать()
	
Если ЗагрузитьВнешнююКомпоненту("DialMail.dll")=0 Тогда
Сообщить("Не удалось загрузить внешнюю компоненту DialMail.dll ");
Возврат;
Конецесли; 




//Подключаемся к почте с указанными параметрами
Почта                      = СоздатьОбъект("AddIn.SMTP");
//Почта.РабочийКаталог     = КаталогПользователя();
Почта.ИспользоватьПрокси = 0;
Почта.ИспользоватьSSL     = 1;
Почта.ВестиЛогФайл         = 0;
//Почта.ИмяЛогФайла         = КаталогПользователя()+"dialmail.smtp.log";

//МойАдрес = глПользователь.ЭлПочта;
СМТП     = "smtp.mail.ru"; 
//Логин     = глПользователь.ЭлПочта;
//Пароль     = глПользователь.Пароль;
Почта.ПочтоваяПрограмма="Client on DialMail";
Почта.MakeContentDescriptionTag = 0;
Почта.ТипТелаПисьма=0;    

ТекПисьмо = Почта.СоздатьПисьмо("*********@mail.ru","*********@tut.by",,"Отправил с 1с!",,"Я гений!",);
Если ПустоеЗначение(текписьмо)=1 тогда 
    Сообщить("Ошибка при создании письма!");
    Возврат; 
КонецЕсли;

Если Почта.Подключиться(СМТП,465,"*******@mail.ru","********",1)=0 тогда
    Сообщить("Ошибка при подключении к SMTP!");
Возврат;
КонецЕсли;

рез=Почта.ОтправитьПисьмо(,1,0);
Если рез<>1 тогда
    Сообщить("Ошибка отправки!");
    Возврат;
КонецЕсли;
Почта.Отключиться();
Почта.УдалитьПисьмоИзРабочегоКаталога(); 
КонецПроцедуры;
Показать

Выдает ошибку "Ошибка отправки!". Заранее спасибо!)
Ответы
Избранное Подписка Сортировка: Древо
2. Mister_1C 16.05.19 16:56 Сейчас в теме
Прблема была в сервере!) все порешал!)
3. SGordon1 16.05.19 16:57 Сейчас в теме
а мейл ру еще принимает SMTP , на SSL не перешли?
4. Mister_1C 16.05.19 17:03 Сейчас в теме
(3)Ну как видите!)
Прикрепленные файлы:
5. Mister_1C 16.05.19 17:03 Сейчас в теме
6. Mister_1C 16.05.19 17:06 Сейчас в теме
(3)У них даже еще в справочной есть инструкция!)
7. SGordon1 16.05.19 20:31 Сейчас в теме
Увидел Почта.ИспользоватьSSL = 1; ....
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 180 000 руб.
Полный день

Программист 1С
Москва
зарплата до 160 000 руб.
Полный день