1. zayden 16 16.05.19 11:42 Сейчас в теме

Новая общая форма - как сделать?

Сделал Общую форму КассаПоУмолчанию - она должна устанавливать в настройках пользователя ОсновнуюКассу

Перем Кассы;

Процедура ПриОткрытии()

Кассы = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ПараметрыСеанса.ТекущийПользователь, "ОсновнаяКасса");
УстановитьПараметры();
КонецПроцедуры

Процедура КассыПриИзменении(Элемент)

УстановитьПараметры()


КонецПроцедуры

Процедура ОсновныеДействияФормыОК(Кнопка)

ПараметрыСеанса.Кассы = Кассы; // - сбоит на этой строке
Закрыть();
КонецПроцедуры

Процедура ОсновныеДействияФормыОтмена(Кнопка)
ПараметрыСеанса.Кассы = Справочники.Кассы.ПустаяСсылка();
Закрыть();
КонецПроцедуры


Процедура УстановитьПараметры()
Кассы = Кассы;

КонецПроцедуры

Помогите зеленому
Найденные решения
9. x_x 3 16.05.19 12:22 Сейчас в теме
так же как вы добавляли форму, через конфигуратор заходите и добавляете параметр сеанса.
10. zayden 16 16.05.19 12:44 Сейчас в теме
(9)добавил права все получилось
Остальные ответы
Избранное Подписка Сортировка: Древо
6. alex-l19041 9 16.05.19 12:04 Сейчас в теме
(1)
Процедура УстановитьПараметры()
Кассы = Кассы;

КонецПроцедуры
- это зачем ?
2. x_x 3 16.05.19 11:58 Сейчас в теме
У вас добавлен в "параметры сеанса" элемент кассы? или это объявлена только переменная?
4. zayden 16 16.05.19 12:03 Сейчас в теме
5. ErshKUS 16.05.19 12:03 Сейчас в теме
(2) + и еще проверьте права на параметре сеанса
3. x_x 3 16.05.19 12:01 Сейчас в теме
я к чем это клоню, есть "модуль сеанса" и есть процедура "УстановкаПараметровСеанса" типовая и есть процедура УстановитьЗначениеПараметраСеанса() не легче через них?
alex-l19041; +1 Ответить
11. zayden 16 16.05.19 12:47 Сейчас в теме
7. x_x 3 16.05.19 12:04 Сейчас в теме
вот добавьте параметр сеанса, вы же пытаетесь в него записать.
8. zayden 16 16.05.19 12:13 Сейчас в теме
9. x_x 3 16.05.19 12:22 Сейчас в теме
так же как вы добавляли форму, через конфигуратор заходите и добавляете параметр сеанса.
10. zayden 16 16.05.19 12:44 Сейчас в теме
(9)добавил права все получилось
12. zayden 16 16.05.19 12:48 Сейчас в теме
(9) все спасибо огромное все получилось )))
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Программист 1С
Новосибирск
зарплата от 80 000 руб.
Полный день

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день