1. ulvi96 15.05.19 17:04 Сейчас в теме

Платформа 8.х

Здравствуйте. Я плохо знаю русский. Извините за этого. Я еще новичок в 1С программирование. В УТ 10.3. Когда документ открывается дата = пустой. Если смотреть с отладкей тогда видно что после Процедуру ПередЗаписи дата заполняется. Где этот реквизит заполняется? Это стандартный реквизит. Заполняется через платформу или как ?
Ответы
Избранное Подписка Сортировка: Древо
2. lefthander 15.05.19 17:12 Сейчас в теме
(1)Должно быть что то типа
Если НЕ ЗначениеЗаполнено(Дата) Тогда Дата = ТекущаяДата(); КонецЕсли;
Смотреть в обработкаЗаполнения ОбработкаПроверкиЗаполнения в модуле объекта, там же в модуле объекта может быть тоже процедура передЗаписью, хотя в 10.3 наверно нет ее.
3. Xershi 560 15.05.19 17:16 Сейчас в теме
(1) включай замер производительности и смотри что выполняется.
По нему поймешь где конкретно идет заполнение!
4. lefthander 15.05.19 17:17 Сейчас в теме
(3)Можно в стеке вызовов тоже смотреть.
6. Xershi 560 15.05.19 17:34 Сейчас в теме
(4) только стека. А если код размазан, то только замер все покажет!
5. darkmessiahan 33 15.05.19 17:20 Сейчас в теме
Зачем вам знать как устанавливается дата, скорее вам для одного вида нужен свой алгоритм
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
	Если РежимПроведения=РежимПроведенияДокумента.Оперативный И ЗначениеЗаполнено(ДатаДляПроведения) Тогда
		Дата = КонецДня(ДатаДляПроведения) - 1;
		Записать();
	КонецЕсли;
КонецПроцедуры // ОбработкаПроведения()
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству


Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день