1. tusv 135 14.05.19 12:54 Сейчас в теме +1 $m

Как мне заставить СКД, чтобы не задавал вопросы

Вопрос тот же, что и Как мне заставить СКД не задавать глупых вопросов
Есть пример кода
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;
	Настройки = КомпоновщикНастроек.ПолучитьНастройки();
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	
	ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;
	
	Если ЭтоРасшифровка Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;	
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,, ДанныеРасшифровки);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
КонецПроцедуры
Показать

Оно работает. Повторю суть вопроса.
Как мне заставить СКД, чтоб не задавал вопросы.
Смотрели классику, что тут не понятного для Сэра Генри.Ну купил коричневые: "Черные, чтобы были"
Формы нет. Потому и вопрос
Не стесняйтесь. Отвечайте. Самый глупый ответ это ноль. Кто то минус поставит, подрихтую
Вознаграждение за ответ
Показать полностью
Найденные решения
37. tusv 135 16.05.19 09:20 Сейчас в теме
(35)
чтобы с голоду не сдохнуть надо удочку дать, а не рыбу

Дарую все таки рыбу
Вопрос все же СКД задает. Но уже с нужными мне вопросом.
Создал вычисляемое поле "ОтчетОстаткиТоваров" и в диалог выбора поля рашифровки он уже выводится.
На ненужные в Наборе данных поля поставил Ограничение поля Недоступно для группировки в истину, чтобы их в диалоге не показывало.
А дальше дело техники
ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;

Если ЭтоРасшифровка Тогда
	ИмяРашифровки = МакетКомпоновки.Тело[МакетКомпоновки.Тело.Количество()-1].Группировка[0].ИмяПоля;
	Если ИмяРашифровки  = "ОтчетОстаткиТоваров" Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;
КонецЕсли; 
Показать
Остальные ответы
Избранное Подписка Сортировка: Древо
7. dandykry 3 14.05.19 13:06 Сейчас в теме
(1) Вдохни и выдохни.

Как с новичком....
"Какая конфигурация?"
"Конфигурация на БСП?"
"Если конфигурация не на БСП, то какая форма выбрана как общая форма отчетов"?
".....?"
27. Xershi 559 14.05.19 14:55 Сейчас в теме
(1) наверно надо сформулировать грамотно вопрос. С такой постановкой и велосипед не поедет.
2. ZergKRSK 126 14.05.19 12:56 Сейчас в теме
Неужели пишется слитно ))
26. tusv 135 14.05.19 14:54 Сейчас в теме
(2)Вам преподавать. Как так с моей грамотностью, два незаконных вышки получил?. Упущение с Вашей стороны:(
Вознаграждение забираю в зад. Ибо грамоте не обучен и Гуру отдыхают где то н пляжу
Я временно замещаю. можно?
11. user856012 8 14.05.19 13:12 Сейчас в теме
(8)
уан стартмани
"Малавата будет. Малавата!" (с)
15. tusv 135 14.05.19 13:24 Сейчас в теме
(11)Потому и вопрос впервые задаю. Сам то я местный уже 6 лет. Ответите на мой вопрос, Вам не только стартмани начислят, но и реальную денюжку. в карман положат Эдак на 100 тысяч повезет
9. Swetlana 10 14.05.19 13:09 Сейчас в теме
СКД задает вопросы - форум отвечает)
12. tusv 135 14.05.19 13:13 Сейчас в теме
(9)Нудык ответьте что нибудь. Я Вам дал простейший пример, как обмануть СКД. Мне стармани полагаеЦА
13. dandykry 3 14.05.19 13:17 Сейчас в теме
(12)
Ща объясню

Ты привел код ПриКомпоновкеРезультата. Он вызывается уже после того, как тебе задали глупый вопрос. Это произошло в форме отчета. Если у тебя нет формы отчета, то это произошло в общей форме, которая выбрана как основная форма отчетов.
Если конфигурация на БСП, то есть общий модуль ОтчетыКлиентПереопределяемый.ОбработкаРасшифровки можно написать там и обмануть СКД.

В задаче не стояло не изменять типовые модули.
Давай стартмани
starik-2005; alex-l19041; +2 Ответить
16. tusv 135 14.05.19 13:33 Сейчас в теме
(13)Нннн. Ни за что. Я жадный. Повторю методы формы.супротив кости сапрыкина я знаю не хуже тебя
В задаче не стояло не изменять типовые модули. ?
В задаче стоит формы нет! ИЛИ Общая форма, которую я не хочу и не буду изменять ибо ЛЕНЬ.)))
17. dandykry 3 14.05.19 13:34 Сейчас в теме
(16) Это не общая форма, это общий модуль

P.S Здесь никто не виноват, что у тебя давно нормального мужика не было. нечего на нас срываться
19. tusv 135 14.05.19 13:47 Сейчас в теме
(17)Смотрите внимательней. Форма отсутствует. Стармани? Не дождешься. Вознаграждение? Это Мне за этот код и челу, который Мину подскажет правильный путь
20. dandykry 3 14.05.19 13:48 Сейчас в теме
(19) Смотри внимательнее -
Форма НЕ.....НУ.......ЖНА!!!! Та даааааааам!!!!! па рам па ба пам
28. tusv 135 14.05.19 15:06 Сейчас в теме
(20)Да да. Лень напала. С формой то каждый дурак сможет
18. majoram 7 14.05.19 13:40 Сейчас в теме
а какие вопросы задаёт? про вариант отчёта что ли?
21. majoram 7 14.05.19 13:52 Сейчас в теме
(18) а, всё понял, ссылку на прошлый вопрос не заметил
22. tusv 135 14.05.19 13:56 Сейчас в теме
32. majoram 7 14.05.19 16:12 Сейчас в теме
(22) извини, но переопределить обработку расшифровки можно только в поле табличного документа.
23. tusv 135 14.05.19 13:57 Сейчас в теме
Если жадный, то не нужно
24. starik-2005 1839 14.05.19 14:45 Сейчас в теме
#МодульФормыОтчета
Proc РезультатОбработкиРасшифровки(Э, Р, С)

  ОткрытьФорму(Отчеты.МойДолбанныйОтчет.Форма.ФормаОтчета", Новый Структура("Отбор", Новый Структура("Часы", ПолучитьЧасыИзР(Р))),...);

endProc
29. tusv 135 14.05.19 15:10 Сейчас в теме
(24) Читото похожие на Ответ. Первый претендент на стартмани
Но увы это не работает. Мой вопрос гораздо сильнее
30. tusv 135 14.05.19 15:20 Сейчас в теме
(24)Вам тот же ответ, что и в( 29)
Бываю бредовые идеи, которые бывают вкусными.Вот Мой такой и запрос на бред. Но он работает!
Ваше замечание, точно не эта
25. toypaul 64 14.05.19 14:53 Сейчас в теме
на тупой оригинальный вопрос, такой же ответ - нужно попробовать в макете прописать расшифровку по умолчанию
31. tusv 135 14.05.19 15:38 Сейчас в теме
(25
) нужно попробовать в . Я потом обязательн выстмакете прописать расшифровку по умолчанию

Ближе к телу. Второй глупый ответ. Я потом обязательно в стармаяхх укажу. Пытался, при спящих Гуру,Пока Гуру спят можно наделать столько глупостей
Увы мне тут не стартмани, мне охрененная квалификация нужна. Пока вопрос дороже ответа
35. toypaul 64 15.05.19 08:03 Сейчас в теме
(31)
Увы мне тут не стартмани, мне охрененная квалификация нужна


почитай библию что ли. там умные люди говорили, чтобы с голоду не сдохнуть надо удочку дать, а не рыбу. а ты какой-то дерзкий - подавай тебе рыбу и все тут. еще и как проститутки за твои "бабосики" твои вопросы расшифровывать. поменяй концепцию общения. задай правильный вопрос - получи правильный ответ.
36. starik-2005 1839 15.05.19 11:18 Сейчас в теме
(35)
там умные люди говорили, чтобы с голоду не сдохнуть надо удочку дать, а не рыбу
Да ну? Это Конфуций сказал. В Библии как раз наоборот: "они идут за мной потому, что если хлеб и насытились". С точки зрения библейских текстов акт спасения - это подарок "чтобы никто не хвалился". Потому уж католики, понимая, что народ начинает халявничать, "ввели" епитимью.
37. tusv 135 16.05.19 09:20 Сейчас в теме
(35)
чтобы с голоду не сдохнуть надо удочку дать, а не рыбу

Дарую все таки рыбу
Вопрос все же СКД задает. Но уже с нужными мне вопросом.
Создал вычисляемое поле "ОтчетОстаткиТоваров" и в диалог выбора поля рашифровки он уже выводится.
На ненужные в Наборе данных поля поставил Ограничение поля Недоступно для группировки в истину, чтобы их в диалоге не показывало.
А дальше дело техники
ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;

Если ЭтоРасшифровка Тогда
	ИмяРашифровки = МакетКомпоновки.Тело[МакетКомпоновки.Тело.Количество()-1].Группировка[0].ИмяПоля;
	Если ИмяРашифровки  = "ОтчетОстаткиТоваров" Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;
КонецЕсли; 
Показать
38. Ганс 16.05.19 14:12 Сейчас в теме
(37)
Вопрос все же СКД задает. Но уже с нужными мне вопросом.


Так вам нужно было чтоб СКД не задавал вопросов или всё же задавал с нужными вам полями!? это немного разные задачи)
39. starik-2005 1839 16.05.19 14:19 Сейчас в теме
(38)
или всё же задавал
Ему нужно кликнув на ячейку получить расшифровку сразу, а не после выбора единственного поля. То, что вопросы он не научился формулировать - оставим за кадром.
40. tusv 135 16.05.19 14:28 Сейчас в теме
(38)Ну раз в лоб не получилось. То "Нормальные герои всегда идут в обход" © Бармалей
Либо без вопросов, либо с нужным. Задача выполнена
41. Ганс 16.05.19 17:26 Сейчас в теме
(40)Ну это вы уже хитрите, стояла чёткая задача "никаких вопросов") Про "нужные вопросы" там не было.
42. tusv 135 16.05.19 17:28 Сейчас в теме
(41)Та схитрил, если в лоб не получается. А как заставить выводит без вопросов я не знаю и мне не ответили
33. tusv 135 14.05.19 22:00 Сейчас в теме
Вопрос закрыт, ввиду спящих Гуру. Стартмани оправляется мине
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 120 000 руб.
Полный день

Работа от Инфостарт
Санкт-Петербург
Временный (на проект)

Программист 1С
Новосибирск
зарплата от 80 000 руб.
Полный день

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день