1. tusv 147 14.05.19 09:59 Сейчас в теме +0.5 $m

Не понедельник. Уже приятно

Почему мне запрос ВЫБРАТЬ * ИЗ Выдает слишком много колонок? Отставить. Вопрос о ленивом выводе расшифровки
Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	СтандартнаяОбработка = Ложь;
	Настройки = КомпоновщикНастроек.ПолучитьНастройки();
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	
	ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;
	
	Если ЭтоРасшифровка Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;	
	
	ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,, ДанныеРасшифровки);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпоновки);
КонецПроцедуры
Показать

Как мне заставить СКД, чтоб не задавал глупых вопросов, как в скрине, а сразу выводил, то что доктор при ПриКомпоновкеРезультата прописал
Прикрепленные файлы:
Вознаграждение за ответ
Показать полностью
Найденные решения
6. tusv 147 14.05.19 22:37 Сейчас в теме
8. tusv 147 16.05.19 09:15 Сейчас в теме
(7)Вопрос СКД задает. Но уже с нужными мне вопросом.
Создал вычисляемое поле "ОтчетОстаткиТоваров" и в диалог выбора поля рашифровки он уже выводится.
На ненужные в Наборе данных поля поставил Ограничение поля Недоступно для группировки в истину, чтобы их в диалоге не показывало.
А дальше дело техники
ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;
Если ЭтоРасшифровка Тогда
	ИмяРашифровки = МакетКомпоновки.Тело[МакетКомпоновки.Тело.Количество()-1].Группировка[0].ИмяПоля;
	Если ИмяРашифровки  = "ОтчетОстаткиТоваров" Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;
КонецЕсли;
Показать
Остальные ответы
Избранное Подписка Сортировка: Древо
3. laperuz 33 14.05.19 11:44 Сейчас в теме
(1)
Создать свою форму отчета, в ОбработкаРасшифровки СтандартнаяОбработка = Ложь, дальше все что угодно.
4. tusv 147 14.05.19 11:56 Сейчас в теме
(3)Это каждый сможет. У меня отчет без формы. Лень напала назначать форму да еще процедуру прописывать. Все должно делаться в макете. Эту статью я читал. Слишком много букаф.. Мой вопрос в пику этой статьи. Код работает. Строк кода почти нет. Вопрос в том, чтобы СКД не задавал вопросов, а сразу выводил.
Пример в (2)
2. tusv 147 14.05.19 10:11 Сейчас в теме
И да. Кто то мне говорил, что невозможно вывести номера колонок стандартными методами
Прикрепленные файлы:
ВнешнийОтчет1.erf
5. tusv 147 14.05.19 12:14 Сейчас в теме
Мда. Вторник. Мозги требуют смазки. Подсластим стартманями
6. tusv 147 14.05.19 22:37 Сейчас в теме
7. ksen 15.05.19 09:58 Сейчас в теме
8. tusv 147 16.05.19 09:15 Сейчас в теме
(7)Вопрос СКД задает. Но уже с нужными мне вопросом.
Создал вычисляемое поле "ОтчетОстаткиТоваров" и в диалог выбора поля рашифровки он уже выводится.
На ненужные в Наборе данных поля поставил Ограничение поля Недоступно для группировки в истину, чтобы их в диалоге не показывало.
А дальше дело техники
ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;
Если ЭтоРасшифровка Тогда
	ИмяРашифровки = МакетКомпоновки.Тело[МакетКомпоновки.Тело.Количество()-1].Группировка[0].ИмяПоля;
	Если ИмяРашифровки  = "ОтчетОстаткиТоваров" Тогда
		Отчет = Отчеты.ОстаткиТоваров.Создать();
		Настройки = Отчет.КомпоновщикНастроек.Настройки;
		//Устанавливаем отборы и параметры
		МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
	КонецЕсли;
КонецЕсли;
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству


Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день