1. user1143074 14.05.19 08:22 Сейчас в теме

Связка пользователей и документа

Ребят, выручайте. Срочно нужна помощь.
Есть база, в ней есть пользователи, роли и подразделения.
Нужно связать пользователей и подразделения, чтобы при открытии определенного документа, пользователи видели только те документы, которые относятся к его подразделению.
Ответы
Избранное Подписка Сортировка: Древо
2. user834357 19 14.05.19 08:43 Сейчас в теме
М.Б. как-нибудь поставить в списке документов отбор по подразделению?
3. catena 99 14.05.19 08:46 Сейчас в теме
Помощь нужна в чем? В целом механизм реализации непонятен, или неясно, как связать, или как поставить доступность?
Конфигурация, ОФ/УФ, платформа - ?
alex-l19041; +1 Ответить
4. WhiteDragon 14.05.19 09:07 Сейчас в теме
(0) пальцем в небо - искать в интернетах "Ограничение доступа на уровне записей". Что-то более адекватное, без информации, которую описали в (3) получить не удастся
5. user1143074 14.05.19 10:39 Сейчас в теме
Необходимо сделать отбор : при открытии списка документов (Реализация товаров и услуг), отбор по группе подразделений (в которые сгруппированы пользователи которые открыли список документов), соответственно если пользователь в группе "Х" то он и видит документы только из группы "Х", изменять отбор по подразделению запрещен если ты не из списка подразделений Управление.
6. user1143074 14.05.19 10:44 Сейчас в теме
То есть вот скрин, что за документ и вот кусок кода, но все равно не работает:(

Процедура ОтборОрганизацияОткрытие(Элемент, СтандартнаяОбработка)
	Перем Стр, ТекПоль;
ПолеОтбора = Новый ПолеКомпоновкиДанных("Подразделение");
ОтборыКомпановщика = ОтборОрганизация.КомпоновщикНастроек.Настройки.Отбор.Элементы;
	Для Каждого Стр Из ОтборыКомпановщика Цикл
		Если Стр.ЛевоеЗначение = ПолеОтбора Тогда
			Отбор = Стр;
		КонецЕсли;
	КонецЦикла;
	Если Отбор = Неопределено Тогда
		Отбор = ОтборОрганизация.КомпоновщикНастроек.Настройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		Отбор.ЛевоеЗначение  = ПолеОтбора;
	КонецЕсли;
	
	Если ТекПоль <> Неопределено Тогда
		Отбор.ВидСравнения   = ВидСравненияКомпоновкиДанных.ВИерархии;
		Отбор.Использование  = Истина;
		Отбор.ПравоеЗначение= ТекПоль;
		
	Иначе
		Отбор.Использование  = Ложь;
		КонецЕсли;
КонецПроцедуры
Показать
Прикрепленные файлы:
7. user1143074 14.05.19 11:56 Сейчас в теме
Ребят, есть ПолеПодразделение в документе. И нужно, чтобы пользователь подразделения "Х" видел в документе только свои файлы из своего подразделения "Х"

Как связать пользователей из подразделений с подразделениями в документе?


Помогитеее.....
8. user1143074 14.05.19 13:41 Сейчас в теме
аппп.
Редакция 3.0
Документ реализация (акты, накладные). При открытии выходит "Подразделение", но нужно, чтобы писалось, то подразделение, к которому закреплен пользователь.

Помогите, пожалуйста, ребята. Очень нужно.
10. user1143074 14.05.19 15:42 Сейчас в теме
(9)Вот что пишет.

Параметры Отбора, Сортировки, Группировки или список отображаемых полей заданы неверно.
по причине:
Невозможно применить фиксированные настройки. Пересекаются элементы отбора.


Хотя сделал все как там, по второму методу.
11. x_x 3 14.05.19 15:52 Сейчас в теме
В принципе ответ уже дали.

Т.е. пользователей добавляешь реквизит или еще чтонить с ссылкой на подразделения.
Дальше заходишь с нужную форму списка ( созданную из динамического списка) и при создании на стороне сервера

ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Подразделение");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
ЭлементОтбора.ПравоеЗначение = ПараметрыСеанса.ТекущийПользователь.Подразделение; //если через реквизит иначе через запрос свойства или

доп реквизита. аналогично остальные параметры
это только пример он рабочий 100% потому что только так сделал.
Прикрепленные файлы:
user1143074; +1 Ответить
12. user1143074 14.05.19 16:15 Сейчас в теме
(11)Сделал все также, только теперь пишет
{Документ.РеализацияТоваровУслуг.Форма.ФормаСписка.Форма(634,32)}: Переменная не определена (ПараметрыСеанса)
ЭлементОтбора.ПравоеЗначение = <<?>>ПараметрыСеанса.ТекущийПользователь.ПодразделениеОрганизации; (Проверка: Тонкий клиент)


Добавляю этот код в формусписка, документа реализация товаров

У меня просто ПодразделениеОрганизации называется реквизит
13. x_x 3 14.05.19 16:28 Сейчас в теме
Ок. пробуйте так ПользователиИнформационнойБазы.ТекущийПользователь()



У меня на УАТ управляемых формах работает через параметры сеанса.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству


Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день